Advanced Packaging Tool, the package manager for Debian-based distributions. It is also the most used tool for installing packages in Ubuntu. Questions about using any of the apt tools should use this tag.

learn more… | top users | synonyms (1)

2
votes
2answers
85 views

My ubuntu decided to remove itself

One week ago, my ubuntu has died. That day, I decided to do smth (I can't remember, what exacly I wanted to). And to do this I was informed by system to update libc++ to newer version. As aptitude ...
-1
votes
1answer
34 views

unable to lock admin dir [duplicate]

How do I fix a Could not get lock /var/lib/dpkg/lock problem? E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable) E: Unable to lock the administration directory ...
0
votes
1answer
66 views

update manager and it won't work [duplicate]

I'm trying to update Ubuntu 12.04 to 12.10 so I could update to most current Ubuntu. when I used the "update manager" it doesn't work. I read that it could be corrupted and to try the code: sudo ...
1
vote
2answers
66 views

Given a package name, how can I find out what will change if I install the package?

Given a set of apt commands and packages to apply (e.g. install foo bar baz, autoremove quux blerg bang), is there a way to calculate the diff of the system state that will be produced if I run the ...
1
vote
1answer
51 views

Can't install any software using apt-get [duplicate]

fumetaloca@fumetaloca-Extensa-5635ZG:~$ sudo apt-get install imageJ Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be ...
0
votes
2answers
114 views

unable to access dash after uninstalling google chrome

After i removed the package google chrome through command sudo apt-get remove google-chrome-stable. I couldnot access dash. I tried sudo apt-get install unity-scope-home command, but it gives me ...
-1
votes
2answers
2k views

“The following packages were automatically installed and are no longer required:” what to do?

After trying to open and install google earth through the terminal it keeps bringing up this message. The following packages were automatically installed and are no longer required: ...
2
votes
3answers
996 views

“Install” option disappeared from the software center

I cannot install anything from the Ubuntu software center (on 13.10). The "Install" button is missing and only the one fore "More information" is there. I suspect it is a problem with the software ...
0
votes
1answer
669 views

Why apt-get wants to install Cinnamon when I try to install Nemo?

My wallpaper in Unity started behaving strangely some weeks ago and after much searching I finally understood it was Cinnamon messing it. I never installed Cinnamon myself, but use - I mean used - ...
1
vote
1answer
749 views

Rerun missing command with apt-get [duplicate]

When I run a command on a new machine (or install that I'm testing) I often find that the package needs to be installed first. This leads, for example, to the following sequence: > colordiff The ...
4
votes
3answers
20k views

Steam needs libgl1-mesa-dri:i386, libgl1-mesa-glx:i386

I have just installed Steam on my Ubuntu 13.10 64 bit and it works well and I can play games but each time I launch it I get the following prompt: Steam needs to install these additional packages: ...
2
votes
1answer
265 views

Replace packaged install with one from source

Ubuntu currently only has a package for OpenIPMI 2.0.18 - I need OpenIPMI 2.0.19 or later. How should I go about replacing the Ubuntu package with one from the OpenIPMI source itself? I am planning ...
1
vote
2answers
60k views

apt-get command not found [closed]

I was going to update all the software on a Linux server. I have root access into this server. I tried to type sudo apt-get update, I got an error says apt-get: command not found $ uname -a ...
0
votes
0answers
963 views

what is “Clearsigned file isn't valid, got 'NODATA' (does the network require authentication?)” [duplicate]

I installed a fresh Ubuntu 13.10 , the first thing I want to do is to update system but I got this error: E: GPG error: http://extras.ubuntu.com saucy InRelease: Clearsigned file isn't valid, got ...
3
votes
1answer
13k views

E: Could not open file /var/lib/dpkg/status - open (2: No such file or directory)

When I use sudo apt-get update I get following error. E: Could not open file /var/lib/dpkg/status - open (2: No such file or directory) E: The package lists or status file could not be parsed or ...
4
votes
1answer
5k views

apt-get not working behind socks proxy

I am trying to connect a Ubuntu 12.04 machine to a socks proxy server. I have my 192.168.30.0/24 LAN, and dante socks proxy server is running on 192.168.30.134:1018. I have also a pfsense router on ...
0
votes
1answer
24 views

Why doesn't apt doesn't know that I have some applications already installed from sources?

If I install something through source, and install it, when apt-get something else, apt-get can't find the app I installed through source as dependency, How can I solve this problem?
1
vote
0answers
1k views

dpkg: error processing cgroup-lite (--configure)

i upgrade ubuntu 12.04 server today and i found with this error: # apt-get install -f Reading package lists... Done Building dependency tree....... Reading state information... Done The following ...
3
votes
2answers
4k views

How can I view last installed package or program? [duplicate]

Can user list last installed packages by apt-get in terminal? I need to know which last package I installed on Ubuntu 12.04.
1
vote
1answer
3k views

How to remove temp installation packages

not very well versed with Ubuntu. i got this msg when i tried to get some updates: The upgrade needs a total of 31.9 M free space on disk '/boot'. Please free at least an additional 27.6 M of disk ...
0
votes
3answers
171 views

Help please with manually reinstalling some 'purged' packages in the right order to get back my network connection

I removed packages I shouldn't have after using 'purge' to remove isc-dhcpd-server, isc-dhcpd-client and isc-dhcpd-common. Of the last two Iḿ actually wondering if I should have had them removed at ...
0
votes
1answer
49 views

Hey whats wrong with Ubuntu 10.10 [closed]

Hey whats wrong with ubuntu 10.10 . Software center is not working. cannot install chrome , flash or anything in command line also .
0
votes
1answer
2k views

Can't install root-system-bin [duplicate]

Im using Ubuntu 13.0.4 and have tried getting updates via the command line ..no joy Latest issue is trying to install Root sudo apt-get install root-system-bin Getting message Reading package lists ...
2
votes
1answer
5k views

“The following signatures were invalid: BADSIG 16126D3A3E5C1192”

I am new to ubuntu and I just installed it. when I tried to install git using "apt-get install git" I received error with "unable to connect". Then I found this question and did as what the question ...
0
votes
2answers
429 views

Failed to fetch http://ppa.launchpad.com 404 not found [duplicate]

I am a newbie, so I can't explain my problem using the proper terminology. All I know is that, every time I open the terminal and type the command line sudo apt-get update, I get a certain error just ...
25
votes
2answers
26k views

WARNING: The following packages cannot be authenticated. `apt-key update` doesn't work

I'm trying to install bitcoind by simply doing sudo apt-get install bitcoind, but I get this error saying that the following packages could not be authenticated: libdb5.1++ libcrypto++9 bitcoind I ...
23
votes
1answer
28k views

Install with sudo app-get install doesn't work, “Not using locking for read only file /var/lib/dpkg/lock”

I just installed Ubuntu Touch on my Nexus 7. Unfortunately I can't install anything from the terminal app: If I enter: sudo apt-get install yasm -y git make g++ build-essential libminiupnpc-dev I ...
1
vote
0answers
84 views

aptdaemon simulation not updating dependencies

I started playing with aptdaemon on Ubuntu 13.10 recently, and I'm baffled. Calling simulate() on a transaction doesn't update the dependencies list. Debug from aptd shows that several events are ...
1
vote
0answers
466 views

Cannot install Ubuntu SDK on Ubuntu 13.10

I am setting up a Development environment on Ubuntu 13.10 for developing HTML5 App for Ubuntu. I used the following command to install the Ubuntu SDK sudo add-apt-repository ppa:ubuntu-sdk-team/ppa ...
0
votes
2answers
25 views

Does ubuntu apt eliminate the need of backporting (as described by RedHat)?

I see Backporting mentioned below. https://access.redhat.com/site/security/updates/backporting/ I'm not sure what they mean by "module". For the example scenario mentioned in the link, it sounds ...
0
votes
2answers
577 views

unable to install synaptic neither ubuntu software center nor terminal

i just installed Ubuntu 13.04 but i'm not able to install Synaptic. i tried these steps: sudo apt-get update sudo apt-get upgrade sudo apt-get remove synaptic sudo apt-get install synaptic the ...
9
votes
7answers
128k views

How to install build-essential?

I am trying to install G++ compiler in Ubuntu 13.10. It told me I needed to install the build-essential package. I have tried the below code sudo apt-get update sudo apt-get install build-essential ...
4
votes
1answer
18k views

Fix dependency when apt-get -f install fails [closed]

I'm trying to get cgminer 3.5 on my Ubuntu 12.04 to work but it fails because libudev.so.1 is missing. I tried to install libc6 and now I have unmet dependencies. Even when I try to run sudo apt-get ...
0
votes
0answers
22 views

problem in pckage installation from terminal [duplicate]

I'm trying to install Firefox from terminal but everytime I have this error: ehsan@ehsan-LIFEBOOK-AH530:~$ sudo apt-get install firefox E: Could not get lock /var/lib/dpkg/lock - open (11: Resource ...
2
votes
2answers
2k views

How do I uninstall Lightworks?

This is what I have tried so far: $ sudo apt-cache search lightworks lightworks - Hollywood-strength editing for everyone $ sudo apt-get --purge remove "lightworks - Hollywood-strength editing ...
0
votes
1answer
19k views

How to uninstall BOOST 1.49 and install BOOST 1.54 in ubuntu?

I have a boost 1.49 in my ubuntu system. And I am trying to uninstall boost 1.49 and completely remove it from my system. And after that install the Boost 1.54.0 I did like this to uninstall 1.49 ...
0
votes
1answer
174 views

apt-cache --installed show lists packages that are not installed

The --installed option does not appear to do anything. The man page isn't specific as to what is intended by its behavior, ie I can't tell if it either. For the applicable actions (presumably show and ...
0
votes
1answer
504 views

Install custom version of node with apt-get

I've installed nodejs this way: sudo apt-get install python-software-properties python g++ make sudo add-apt-repository ppa:chris-lea/node.js sudo apt-get update sudo apt-get install nodejs The ...
2
votes
1answer
65 views

Prevent the installation of a specific kernel version

Having had major problems with kernel 3.11.0-14 (WLAN, desktop login, ALSA crashes) I decided to back out -14, returning to 3.11.0-12. >>ALL<< problems then disapeared. Now I want to block ...
0
votes
0answers
40 views

Problems in installing packages from terminal [duplicate]

Whenever I try to install any missing packages from my terminal by using the command sudo apt-get install (package name) It shows the following error: E: Could not get lock /var/lib/dpkg/lock - ...
5
votes
1answer
802 views

Can I call other dpkg or apt-* commands within my preinst scripts?

As part of my custom (in-house) .deb file that will be deployed to Ubuntu 12.04 devices, I need to add several PPA repositories, run apt-get update, and then install packages from those PPAs. Can ...
0
votes
2answers
314 views

Why is medibuntu.org still offered as a package source if it has been shutdown since 2010?

When trying an update, my output showed that "Some index files failed to download" and "They have been ignored, or old ones used instead." Have I misconfigured something, or is there a reason why ...
0
votes
1answer
291 views

How to remedy unmet dependencies error while downloading Steam?

I'm running Ubuntu 12.04 LTS on a new Asus notebook computer (Ubuntu was pre-installed). I tried to download Steam from the software center and received the following error: Package dependencies ...
0
votes
2answers
49 views

apt-get problem

every time I try to install something by writing sudo apt-get install in the terminal, I have always the same answer : E: The package linux-image-3.0.0-32-generic needs to be reinstalled, but I can't ...
-1
votes
1answer
517 views

Is there any 64 bit version of skype available ? [duplicate]

I was just trying to install skype on my fresh Ubuntu 13.10 64 bit but I have discovered that I would require a lot of my already installed libraries to be installed in 32 bit version just as : $ ...
1
vote
0answers
50 views

Error while trying to update packages [duplicate]

yesterday I tried to install skype using the terminal, but I did something wrong because skype did not get installed and today, when I opened the pc, an error message appeared. It seems that while ...
-1
votes
2answers
120 views

Start installing packages while further fetching the update

Is there a package manager that during installation/update will already start installing first fetched packages whlie other packages are still being downloaded? Example made up scenario: Chromium ...
0
votes
1answer
74 views

Installed waha-system-adjustments_all.deb this did take over several places of my system

I accidentally installed waha-system-adjustments all.deb from Sourceforge, which changed my Synaptic sources. I cannot get rid of it am not able to update or upgrade, what should I do? dom@dom:~$ cat ...
1
vote
1answer
1k views

“E:Malformed line 1 in source list /etc/apt/sources.list.d/medibuntu.list (type),” [duplicate]

I want to update Ubuntu, but I see this message: E:Malformed line 1 in source list /etc/apt/sources.list.d/medibuntu.list (type), E:The list of sources could not be read., E:The package lists or ...
0
votes
1answer
37 views

Where to find information sources about the APT system?

The APT seems to have developed into a very comprehensive environment, hosting a multitude of command-line, and GUI based tools. Comprehensive information regarding the APT system, specially from the ...