Advanced Packaging Tool, the package manager for Debian-based distributions. It is also the most used tool for installing packages in Ubuntu. Questions about using any of the apt tools should use this tag.

learn more… | top users | synonyms (1)

0
votes
1answer
106 views

Upgrade aborts half-way through with the error message there is too little space in the /boot folder [duplicate]

I have tried to run the updater to install 14.04. It aborts half-way through with the error message there is too little space in the /boot folder. It recommends emptying the trash and running apt-get ...
2
votes
3answers
277 views

Why can't I install more than one application at once?

Why can't APT install more than one application at a time? Why does it need to exit before installing the next. I know with MS Windows you can install how many application at once. This problem is ...
41
votes
7answers
139k views

Installing and testing CUDA in Ubuntu 14.04

I am uncertain about how to install CUDA in my system. looking around there are many tutorials about cuda on 12.04 LTS and a few on 13.04 and 13.10, but they all talk about acquiring a deb package ...
0
votes
2answers
332 views

Update Error (using apt-get install -f)?

So I tried updating my system, to find this pop-up error upon attempt, The package system is broken Check if you are using third party repositories. If so disable them, since they are a ...
1
vote
0answers
126 views

`apt` log files: is there a log for `apt-add-repository ppa:…`?

The apt command has the nice behavior to log all what you request it to do in /var/log/apt/history* file. This is quite handy, because in case of reinstall you can see which packages you have ...
2
votes
1answer
528 views

What happens when we cancel apt-get install manually or due to network failure

hi today I was installing mongodb using apt-get its 114 mb download , when apt-get was running I lost network connection so downloading stopped so cancelled it using Ctrl + c . Later when my ...
0
votes
1answer
38 views

How do I replace the release in sources.list?

Is there an easy way to replace all instances in /etc/apt/sources.list with the new release? I want to replace all instances of my current release (whatever it is) with the new release for 14.04 ...
3
votes
0answers
527 views

Synaptic Loading/Running Slowly [closed]

Synaptic has been running extremely slow lately, it's been taking ages to start up and goes dark (what an program does when it's not responding). After installing stuff, it goes dark again, and ...
3
votes
2answers
4k views

When attempting upgrade from 13.10 to 14.04 upgrade halted at “aborting samba-libs preinst” [closed]

During the upgrade process the upgrade process halted and I can not restart the updater. It seems to be related to samba. I ran sudo apt-get install -f and got the following result: Reading package ...
1
vote
2answers
127 views

Upgrade available after upgrading normal release to LTS

Just after upgrading my Xubuntu 13.10 to Xubuntu 14.04, I run the command: sudo apt-get dist-upgrade and tell me that upgrade are available, and after do it again and again I get the same result after ...
1
vote
1answer
1k views

Update Manager, Software Center, Synaptic Package Manager segfault

I made and ran a shell script made up of the following: wget -q "http://deb.playonlinux.com/public.gpg" -O- | sudo apt-key add - sudo wget http://deb.playonlinux.com/playonlinux_precise.list -O ...
0
votes
1answer
175 views

PPA spring cleaning — list packages installed from a PPA?

This is a Q&A-style thing --- hoping to help you in this period of new LTS release(s). There are a lot of links in this post, follow them and upvote them to give the authors the relevant kudos. ...
14
votes
4answers
48k views

Can't find boot-repair package for the newest version of Ubuntu

After upgrading Ubuntu 13.10 to 14.04, grub failed to load Ubuntu and threw the error symbol 'grub_term_highlight_color' not found. I followed the solution offered in the Bug Report but this failed ...
3
votes
0answers
2k views

Help with updating to from 13.10 to 14.04 [duplicate]

When I run the following command: sudo apt-get update sudo apt-get dist-upgrade I just get this error: Calculating upgrade... Failed The following packages have unmet dependencies: libcogl15 ...
0
votes
1answer
289 views

Can't upgrade past 11.10 - libc6 dependency errors [closed]

Since upgrading to 11.10 I can't upgrade any further (trying to get my web server to latest version.) I'm aware of How do I resolve unmet dependencies? and have tried up to the point of running this: ...
0
votes
1answer
3k views

Unable to upgrade to 14.04

I am trying to upgrade from Kubuntu 13.10 to 14.04. When I start the distribution upgrade, I get this message after "setting new software channels": An unresolvable problem occurred while ...
0
votes
1answer
1k views

Type '' is not known on line 3 in source list

I found this site where it says all the things I need to do and the commands in Terminal and Everything. So Now I need to type in sudo apt-get update. I get this error: tomi@ubuntu:~$ sudo apt-get ...
4
votes
1answer
2k views

Unmet dependency while installing cnijfilter-mp550series package

I've been using my Canon MP550 printer for some Ubuntu versions now, and installation always worked: $ sudo add-apt-repository ppa:michael-gruz/canon-trunk $ sudo apt-get update $ sudo apt-get ...
0
votes
1answer
631 views

Unable to install mesa-common-dev:i386 on my ubuntu system

I am using Ubuntu(12.04 LTS) x86_64 GNU/Linux. I have to setup my build environment on my Ubuntu system. While trying to instal the mesa-common-dev:i386 package, I am facing the following error. sudo ...
2
votes
0answers
1k views

Broken package problem while installing open source AMD ATI drivers in 14.04

After purging the fglrx* packages, I tried this - ankit@ubuntu:~$ sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx:i386 libgl1-mesa-dri:i386 libgl1-mesa-glx:amd64 ...
2
votes
3answers
26k views

Unable to locate package boot-repair in 14.04 [duplicate]

I've tried to install boot repair and failed sudo add-apt-repository -y ppa:yannubuntu/boot-repair && sudo apt-get update The error is: $ sudo apt-get install -y boot-repair Reading ...
1
vote
1answer
215 views

Pinning package using own repository and apt-get

I created my own repository so I can provide a newer version of a package than the one the Ubuntu repository currently holds. Everything works fine, with the exception that I have to specify the ...
1
vote
3answers
625 views

Why isn't the dist-upgrade showing up in update-manager?

Ubuntu 14.04 was released on 17 April 2014, and today it is already the 18th. Why isn't the distribution showing up in my ubuntu update-manager? (I have set it so it will anounce every new version) ...
0
votes
0answers
33 views

Why is duplicity set on hold automatically? [duplicate]

When I start apt-get upgrade I get the message Reading package lists... Done Building dependency tree Reading state information... Done The following packages have been kept back: ...
11
votes
3answers
8k views

29 packages can be updated - How?

I see the following message when I login: 29 packages can be updated. 6 updates are security updates. How can I perform the updates? I tried apt-get upgrade and some stuff was installed ...
-1
votes
1answer
373 views

Ubuntu 12.04 update error:failed to fetch cd rom [duplicate]

I have been trying to update ubuntu 12.04 but each time i am getting the following error..can anyone help me. W: Failed to fetch cdrom://Ubuntu 12.04.4 LTS _Precise Pangolin_ - Release amd64 ...
14
votes
2answers
1k views

Packages are removed when I use “apt-get install” with a hyphen after the package name

In an attempt to install cuda, I copy-pasted some apt-get install packages. For unknown reasons the line that I got run in the end is the following: sudo apt-get install libgtk2.0- The result was ...
0
votes
2answers
341 views

How can I make the goaccess package available in Lucid (10.04)?

GoAccess is an open source real-time web log analyzer and interactive viewer that runs in a terminal in *nix systems. For some reason, it appears that it is only available in the repos for 12.04 and ...
1
vote
4answers
14k views

How do you fix a gcc compile 127 error? sudo apt-get install g++ doesn't work

*emphasized text*when I try to run a program I get the following error. ubuntu@ubuntu-VirtualBox:~/Desktop$ make g++ -Wall -Wno-switch -I. -g -c -o pass.o pass.cpp make: g++: Command not found ...
1
vote
1answer
2k views

Apt-get crashes with : relocation error: libapt-pkg.so.4.12

After running a simple upgrade I get a crash each time I try to use apt-get. Any command crashes with the same error message : legaliz_me:~$ sudo apt-get apt-get: relocation error: ...
2
votes
1answer
32 views

What are translation entries?

I was looking to speed up the sudo apt-get update Then I found this blog which suggests to remove translation entries What exactly are translation entries? why they exist in the first ...
0
votes
1answer
207 views

mumble-server i386 depends on libqt4-core and libssl0.9.8 [duplicate]

I am trying to use apt-get and i get this error. It also doesnt allow me to install devs. root@ubuntu:~# sudo apt-get install mumble Reading package lists... Done Building dependency tree Reading ...
12
votes
2answers
17k views

Automating apt-get install with --assume-yes

I am trying to write a bash script to install a list of software. I am using --assume-yes to get pass the prompts This following line somehow doesn't work sudo apt-get install ...
1
vote
1answer
1k views

dpkg google-chrome corrupt invalid status

I can't get this to resolve itself, can I get some help? Setting up google-chrome-stable (34.0.1847.116-1) ... update-alternatives: error: /var/lib/dpkg/alternatives/google-chrome corrupt: invalid ...
0
votes
1answer
59 views

What commands go wild with wildcards?

Having read apt-get remove with wildcard removed way more than expected. why? (after making a similar mistake myself), I am significantly more cautious about using * in commands with which I am not ...
0
votes
1answer
205 views

Can't install fancontrol

I am starting to get quite p'ed off as I can't control my fans. I can't download Jupiter. It says can't find and if I try apt-get install fancontrol it says: root@server-17:~# apt-get install ...
1
vote
2answers
79 views

Satisfy dependencies on autoremove

Based on man apt-get for autoremove we got autoremove is used to remove packages that were automatically installed to satisfy dependencies for some package and that are no more needed. Can ...
2
votes
1answer
84 views

how to create a ppa .dep that depends on non-default GCC?

I want to create a .dep package in my PPA. That project however requires a recent GCC 4.8 or Clang 3.4+. I found out, that you can add custom PPA dependencies, so I added ubuntu-toolchain-r/test to ...
1
vote
1answer
372 views

Can't remove package [duplicate]

I guess I removed some files that package jetty required because when I try to remove it with apt-get remove jetty I get this: Removing jetty ... * jetty is not installed invoke-rc.d: initscript ...
9
votes
3answers
849 views

How to list all the packages which are installed from PPAs?

I installed many packages from many PPAs on my system. I want to list all the installed packages which are installed from launchpad PPAs, not repositories. Is this possible through command-line?
0
votes
1answer
508 views

How to remove a package after incorrect installation attempt

I was trying to install PostgreSQL 9.3 from the downloaded installer: postgresql-9.3.4-3-linux-x64.run Still learning the ropes with Linux, I believe I originally installed it using an incorrect ...
3
votes
3answers
3k views

This kernel does not support a non-PAE CPU

I received the error message: The package system is broken and I am not, to my knowledge, using third party repositories. Following some of the recent posts on similar topics, I looked at other posts ...
3
votes
2answers
236 views

Install package from without adding PPA

Is there a way to install a package via a simple URL without having to add a PPA beforehand? Something like apt-get https://url.to.package.deb? Or perhaps some command line options that would add the ...
0
votes
1answer
13k views

In Ubuntu 13.04, cannot install libssl-dev [duplicate]

How can I get around the dependency problem when installing libssl-dev? The problem: $ sudo apt-get install libssl-dev Reading package lists... Done Building dependency tree Reading state ...
2
votes
2answers
6k views

apt-get remove --purge wine* removed everything!

sudo apt-get remove --purge wine* opened the gates of hell and removed many things. I wasn't allowed to paste the output here, too big. I stopped the process, I wanted to save what's left of my ...
14
votes
3answers
1k views

gpg: keyblock resource ‘/etc/apt/trusted.gpg.d//webupd8team-sublime-text-3.gpg’: resource limit

No matter what I do, I get the following error: gpg: keyblock resource ‘/etc/apt/trusted.gpg.d//webupd8team-sublime-text-3.gpg’: resource limit The original error(Dutch) Original Dutch sudo ...
1
vote
1answer
71 views

Which package provides a given jar?

How can I determine which apt package I should install to have a certain jar file? BTW: I'm actually looking to solve XML parser factory has not been configured correctly: Provider ...
0
votes
0answers
27 views

Heartbleed Ubuntu 13.04 stuck on OpenSSL 1.0.1c [duplicate]

Just noticed that my Ubuntu 13.04 install is stuck on an old version of OpenSSL. OpenSSL 1.0.1 14 Mar 2012 The distro is fully to to date, running apt-get update, then apt-get upgrade or apt-get ...
1
vote
1answer
804 views

apt-get update gives bzip2 error on fresh Ubuntu 12.04(LTS) in Virtual Box version 4.2.18

A fresh install of Ubuntu 12.04(LTS) onto Virtual Box 4.2.18 seems to go well, however, I receive a bzip2 related error when trying to update. I was hoping a seasoned Ubuntu expert could help me ...
1
vote
2answers
589 views

The difference between simply installing software & adding to repository [duplicate]

I have a simple question coming from my mind. What is the difference between : sudo add-apt-repository ppa:cwchien/gradle sudo apt-get update sudo apt-get install gradle And simply sudo apt-get ...