Advanced Packaging Tool, the package manager for Debian-based distributions. It is also the most used tool for installing packages in Ubuntu. Questions about using any of the apt tools should use this tag.

learn more… | top users | synonyms (1)

2
votes
1answer
1k views

apt-get abort after I type Y to continue

After I use sudo apt-get update && sudo apt-get upgrade to check for updates via terminal, there's a little problem but weird. After I answer to Y, it must be running to downloading updates ...
0
votes
1answer
33 views

install software package-centre app [duplicate]

I am trying to install the software-centre package on Terminal.. I have entered these commands: sudo apt-get install software-center* I get this: The following package was automatically installed ...
0
votes
2answers
423 views

Cinnamon PPA was not found

I am unable to add Cinnamon PPA on Ubuntu 12.04 LTS. The add-apt-repository can't access the PPA. Also, when I visit PPA URL on https://launchpad.net/~gwendal-lebihan-dev/+archive/cinnamon-stable, I ...
0
votes
1answer
154 views

(12.04 vm/server) Dist-upgrade to 3.2.0-63 wants to remove git (1.9.2) and git-core - is that the correct behavior?

was wondering if anyone knows dist-upgrade wants to remove git. FWIW, this is a pretty simple box, mainly used for web dev. $ uname -a Linux precise64 3.2.0-61-generic #93-Ubuntu SMP Fri May 2 21:31:...
0
votes
1answer
465 views

Xubuntu + Steam != CounterStrike:Source [duplicate]

I recently bought this computer from a used equipment auction. I installed Xubuntu [Ubuntu 14.04 LTS (32 bit)] and decided to try if I can play CounterStrike:Source using Steam here. After ...
2
votes
1answer
13k views

can't run apt-get update [closed]

I'm trying to run apt-get update but there's an error i don't understand. this is the output with the error: Err http://security.ubuntu.com oneiric-security/main Sources 404 Not Found [IP: 91.189....
0
votes
3answers
214 views

How to show how-much data is needed to download while apt-get? [duplicate]

I want to know how-much data is needed to download any package by apt without installing that package. In other words if I run apt-get install xyz then it will download and install packages with ...
1
vote
3answers
4k views

Cannot install Teamviewer_linux.deb package on linux 64bit

I wanted to install teamviewer on linux 64-bit system. What I did was to download teamviewer.deb file and install it as below: sudo dpkg -i install teamviewer.deb Then I wanted to correct ...
-1
votes
2answers
2k views

dpkg: error processing extlinux (--configure)

So I was running apt-get autoremove and the output was: dpkg: error processing extlinux (--configure): subprocess installed post-installation script returned error exit status 1 Errors were ...
5
votes
1answer
361 views

Does pip overwrite packages installed by apt-get?

What happens if I accidentally pip install a package that I already installed using apt-get beforehand? Do I simply get to use the latest version (i.e. probably the one I installed using pip)? What ...
0
votes
2answers
11k views

sudo apt-get install skype? [duplicate]

Running Unbuntu 14.04 LTS, I tryed to install skype. In terminal: sudo sh -c ‘echo “deb http://archive.canonical.com/ubuntu trusty partner” >> /etc/apt/sources.list.d/canonical_partner.list’ ...
0
votes
1answer
5k views

can't install software--can I fix missing dpkg?

New software can't be installed, because there is a problem with the software currently installed. Do you want to repair now? hit Repair Package operation failed The installation or removal of a ...
8
votes
8answers
36k views

Got NODATA issue: 'NODATA' (does the network require authentication?)

I can use my mobile broadband to access Internet with Firefox but when I want to install any package from terminal or make 'apt-get update' command I got the following error: got 'NODATA' (does the ...
0
votes
1answer
1k views

Use system wide proxy in ubuntu 14 lts 64 bit

I want to use a system wide proxy and did the following: Created a file apt.conf in etc/apt/ with Acquire::http::proxy "http://user:pass@proxy.pac:8012/"; (I had to set chmod to 777 to edit it) ...
0
votes
1answer
156 views

Get a list of packages on a fresh install

I want a list of all packages installed, along with versions (if possible) on a clean install of Ubuntu (any version). I can use dpkg -l | grep '^ii' | awk '{print $2" "$3}' on a fresh ...
1
vote
0answers
261 views

I delete duplicate packages but Canonical keeps reinstalling them, Ubuntu 14.04

files at /var/lib/apt/lists W: Duplicate sources.list entry http://us.archive.ubuntu.com/ubuntu/ trusty/multiverse amd64 Packages (/var/lib/apt/lists/us.archive.ubuntu....
-2
votes
1answer
144 views

`apt-get update` doesn't work with GUI or terminal [duplicate]

wassim@wassim-HP-250-G1-Notebook-PC:~$ sudo apt-get update [sudo] password for wassim: E: Malformed line 1 in source list /etc/apt/sources.list.d/google.list (dist parse) E: The list of sources could ...
2
votes
3answers
721 views

List all versions of a package

Is there a equivalent of this command; yum list kernel-headers --showduplicates on Ubuntu with apt-get, apt-cache etc. The above command lists various versions of the kernel-headers rpm available on ...
2
votes
1answer
2k views

Unmet dependencies for libstdc++

When i type: sudo apt-get install libstdc++ i got: The following packages have unmet dependencies: libstdc++-4.8-doc : Conflicts: libstdc++6-4.4-doc but 4.4.7-8ubuntu1 is to be installed ...
0
votes
1answer
6k views

apt-get update error 'E: Malformed line 1 in source list /etc/apt/sources.list.d/google.list (dist parse) E: the list of sources could not be read' [duplicate]

i am using ubuntu 14.04 and in terminal when i run: sudo apt-get update my terminal gives me an error of: E: Malformed line 1 in source list /etc/apt/sources.list.d/google.list (dist parse) E: The ...
0
votes
1answer
835 views

What is proper way to get specific version of package

I am using Ubuntu 14.04 LTS I need to use curl package. But it comes in version 7.35.0 with known SSL bug (already fixed in next version) I either need lower version <= 7.33.0 or higher >= 7....
0
votes
1answer
1k views

Installing a software/Wirehsark on Ubuntu 11.10 [closed]

I'm trying to install wireshark on my Ubuntu 11.10 (kernel 3.0.0-12-generic-pae) via a proxy, but fail. I've tried the usual apt-get: me@MyUbuntuPC:~$ sudo apt-get install wireshark Reading package ...
0
votes
2answers
504 views

How to keep specific old kernel on my next kernel upgrade?

I just updated my Ubuntu 14.04 and got a new kernel. This new kernel is not working properly for me so I booted the previous version. Let's call this good old working version "3.13.0-24.47". Now, I ...
0
votes
1answer
88 views

PPA without upgrades

I just installed smartgithg via ppa:eugenesan/ppa. After an upgrade and restart the whole window style got broken and I can't switch to my preferred keyboard layout. May be some other errors occured ...
0
votes
2answers
60 views

Downgrade to GCC < v3.0

For specific reasons I have to downgrade my GCC to version 2.x using apt-get (not downloading and compiling the source) Is that possible? If yes, how can I find the repository address and install it ...
2
votes
1answer
72 views

Bash script help [closed]

The --print-uris in apt will print the entire output along with the urls to a specified txt file. I need a command which will only select the packges to be installed from the output of print uris and ...
0
votes
0answers
17 views

linux mint parse error [duplicate]

I try too much method but still don't work. asus alis # apt-get update Hit http://linux-mint.froonix.org olivia Release.gpg Hit http://archive.canonical.com raring Release.gpg ...
0
votes
1answer
5k views

Docker install tools/run command on existing container

I'm using Dokku to run some apps on an Ubuntu 14.04 server. Dokku creates the Docker container with all the stuff in them to run. I'd like to connect to the running container somehow and run apt-get ...
2
votes
2answers
1k views

Why cant apt-get install the i386 version of any package?

Why cant apt-get install the i386 version of libpcap-dev? $ sudo apt-get install libpcap-dev:i386 Reading package lists... Done Building dependency tree Reading state information... Done ...
1
vote
2answers
177 views

Updating a package using a .deb?

I´m using ubuntu 12.04 LTS (precise/amd64), I have installed virtualbox-4.3, I was forced to install it with a downloaded package (.deb) because I could not download it normally, I used "Free Download ...
2
votes
0answers
68 views

suppress all interaction while installing apt-fast

I want to ask whether there is any method to suppress any interaction while installing apt-fast using apt-get. I add the ppa source and then use the next command to install apt-fast: sudo apt-get -y ...
0
votes
3answers
272 views

Update Package list in repository after motherboard change

I just installed a new motherboard / microprocessor on my computer, I want to do an update to it using apt-get and I've tried to do it from the GUI as well. the issue is the package list still have ...
1
vote
2answers
30 views

How to get more info while installing an application?

Suppose I want to install an application named aeiou. If I go to software center and look for the application, it gives information about the application and also shows some of the optional plugins ...
1
vote
2answers
1k views

How to change the repository location while installing from live cd?

I am installing 14.04 from a live CD. While installing, it downloads updates from the Internet. I see it is currently downloading from http://in.archive.ubuntu.com/ Is there any way I can change ...
3
votes
4answers
14k views

Not able to uninstall MySQL with apt-get

I had downloaded the generic Linux 64 bit MySQL 5.6.17 TAR archive from http://dev.mysql.com/downloads/mysql/ and installed on my 64 bit Ubuntu 14.04, following the instructions at http://dev.mysql....
1
vote
2answers
199 views

I can't download Java or WINE due to similiar error

I've been trying to download Java Oracle 8 and WINE and I keep getting the same problem. W: Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release Unable to find expected ...
1
vote
1answer
859 views

Deadlock-broken packages during Ubuntu 12.4 update: libjpeg-turbo8:amd64 and libjpeg-turbo8:i386

The problem I have not used my Ubuntu 12.4 (64 bit) netbook for about a year, and yesterday I tried to install one year worth of updates at once. The update did not go smoothly: I had to restart the ...
1
vote
2answers
3k views

How to remove Ruby 1.9.1 keeping Ruby 2.0.0?

I have Ruby 2.0.0 installed on Ununtu 14.04 but I can't remove Ruby 1.9.1. I replaced the /usr/bin/ruby symbolic link to ruby2.0.0, but hhen installing new gems I always get pointed to Ruby 1.9.1. ...
0
votes
1answer
282 views

Error during installing skype , software update and while starting ubuntu

when installing skype on ubuntu 12.04 Lts gets the following error $ sudo dpkg --add-architecture i386 [sudo] password for shailendra: dpkg: error: unknown option --add-architecture Type dpkg --...
0
votes
0answers
22 views

Got a problem with Package Mangement [duplicate]

The last day I got a problem with my package-manager saying that "An error occurred, please run Package Manager form from right-click menu or apt-get in a terminal to see what is wrong. The ...
0
votes
1answer
329 views

Chrome OS and Ubuntu

I started using Ubuntu a few weeks ago, so I decided to install it also on my Chromebook. It feels so nice, but I get this error when I try to update Ubuntu: W: Duplicate sources.list entry http://dl....
1
vote
3answers
395 views

I installed a custom .deb file that provided a package named “python” but now need to remove it [duplicate]

I think I may have botched my system. I have recently installed Ubuntu 14.04 on my computer. One of the first things I did was install python 3.3 from source (using make altinstall); but then I ...
1
vote
1answer
8k views

Ubuntu 12.04 GPG error: http://archive.ubuntu.com precise Release: The following signatures were invalid: NODATA 1 NODATA 2 [duplicate]

I know this is asked often but nothing seems to work for me. Every time I try to update I get the following: sudo apt-get update Get:1 http://archive.ubuntu.com precise Release.gpg Get:2 http://ppa....
0
votes
2answers
39 views

How do I save the name of installed packages on my system in order to restore this state elsewhere? [duplicate]

I have 12.04 and I'm looking for a way to store all the currently installed packages names into a file or archive. Not the packages themselves, but the names. Or the package management's state. I'd ...
0
votes
1answer
99 views

Does apt-get upgrade checksum deb files?

Does apt-get upgrade checksum deb files? If yes then where exactly it checks? After downloading a deb file or while installing it? Does it download the checksum from the repository or is the checksum ...
0
votes
1answer
361 views

Issue installing Software [duplicate]

I just upgraded to Ubuntu 14.04 and I have been trying to fix an error somewhere in the install process. No matter how I install (software center, Terminal) it displays an error message close to this: ...
0
votes
1answer
460 views

How to repair /etc/apt folder

My /etc/apt directory removed from my laptop. How can I rebuild that directory? My os is Ubuntu 14.04
1
vote
0answers
62 views

Can boost 1.54 install with libboost_thread-mt.so like library files using apt-get install libboost-all-dev command [duplicate]

When installing boost in Ubuntu 13.10 I used apt-get install libboost-all-dev command. In this case library files which are ending with -mt.so (such like libboost_thread-mt.so, libboost_system-...
1
vote
1answer
111 views

Unable to locate package ubuntu-after-install

sudo apt-get install ubuntu-after-install does not work. I just installed Ubuntu, so I don't know if there's a problem with my installation..
0
votes
2answers
463 views

Should I forcefully uninstall ubuntu-minimal: Depends: resolvconf as it has unmet dependencies

My ubuntu software center was not working and I was trying to fix it. I ran the following series of commands: sudo apt-get update This one failed and this was the result Err http://extras.ubuntu....