Advanced Packaging Tool, the package manager for Debian-based distributions. It is also the most used tool for installing packages in Ubuntu. Questions about using any of the apt tools should use this tag.

learn more… | top users | synonyms (1)

1
vote
1answer
573 views

Prevent apt-get remove from uninstalling related packages

I uninstalled some packages with apt-get remove. In addition to the selected packages the Okular document viewer was removed, which was running on my computer long before the other packages. Is there ...
1
vote
1answer
806 views

How to keep tor browser bundle updated

I am using Ubuntu 14.04. I decided to install the tor browser bundle today. After some quick research online i discovered this article specifically discouraging users from using the Ubuntu packages as ...
2
votes
1answer
9k views

Error occured when apt-get update run

I tried to run sudo apt-get update on Ubuntu Gnome 14.04. And here is result: Err http://ppa.launchpad.net trusty InRelease Err http://...
2
votes
1answer
279 views

Is it possible to do only the download part of apt-get/aptitude full-upgrade?

When I go to internet cafe, I'd like to take that opportunity to upgrade the system. Sometimes though there is not electrical sockets in the cafe. To conserve batteries I'd like to be able to only do ...
0
votes
1answer
828 views

How can i fix the add-apt-repository hang?

I'm not sure what happened, but add-apt-repository doesn't work anymore. If I try, it just hangs: After "[sudo] password for cyanogenhacker:" and entering the password, it just flashes the cursor ...
0
votes
2answers
323 views

How to uninstall with apt-get? [duplicate]

I ran this command: sudo apt-get install gtk2-engines-murrine:i386 gtk2-engines-pixbuf:i386 sni-qt:i386 But now I want to remove what I've just installed. What's the command?
2
votes
2answers
6k views

Unable to install php5-mcrypt on Ubuntu 14.04

I can't install php5-mcrypt on ubuntu 14.04. I'm doing this: $ sudo apt-get install php5-mcrypt And getting this: Reading package lists... Done Building dependency tree Reading state ...
-1
votes
1answer
186 views

Plug-in Installation Problem

when i am trying to install required plug-ins to play music,the following notice is coming: Failed to fetch http:/bd.archive.ubuntu.com/ubuntu/pool/universe/libd/libdvdread/libdvdread4_4.2.0+20121016-...
1
vote
1answer
3k views

Ignore apt-get postinstall scripts automatically

We have a script we is installing multiple packages, but should skip any actions in postinstall scripts. I tried this: touch /var/lib/dpkg/info/packagename.postinst chmod +x /var/lib/dpkg/info/...
0
votes
1answer
282 views

Cannot update because of Missing packages (12.04 LTS)

I'm not being able to update my Ubuntu 12.04 because of missing packages, how can I solve it? Here's a link of the error I'm getting every time I want to update: Thanks in advance
1
vote
2answers
854 views

Ubuntu 13.10 won't update. apt update and apt upgrade fail

UPDATE: Ive reinstalled libreadline6 to no avail. Im still getting the undefined symbol errors gpg: symbol lookup error: /usr/local/lib/libreadline.so.6: undefined symbol: UP Any help appreciated. ...
-1
votes
1answer
424 views

How do I resolve not fully installed package (python3-setuptools)?

I was trying to install python3-setuptools, and when i run $ sudo apt-get install python3-setuptools I get this error: Reading package lists... Done Building dependency tree Reading state ...
1
vote
1answer
641 views

apt-get -s E: the option « s » in command line [origin -s] is unknown

Near all is in the title, but 14.04. I also tried all the 5 equivalent long (--) options found in man with the same error. -u from man also fails the same way. Please what is this? Thank you.
1
vote
1answer
2k views

sudo apt-get install <multiple packages> cannot read packages

I am trying to setup ruby on rails on a new ubuntu machine. I want to install all the dependencies at once after a sudo apt-get update, but encountered errors saying the packages has no installation ...
0
votes
1answer
223 views

Update/Upgrade to address CVE-2014-0224 does not change build date

Ubuntu reports that updating to libssl1.0.0 and 1.0.1-4ubuntu5.14 will address CVE-2014-0224 (USN-2232-1) That these are the installed libraries can be verified with apt-cache policy openssl: apt-...
2
votes
1answer
704 views

Cannot install any package via apt-get

So my problem is quite easy to describe: I can't install anything in my Ubuntu installation. apt-get stopped working after I tried to fix some other package errors I was getting. Now I'm nowhere. Let ...
1
vote
2answers
45 views

Is there a way to download linux applications from other computers? [duplicate]

In my house there is no internet connection, then I can't use the 'sudo apt-get install' command. I wonder if I can download a package, put it in my computer in a specific folder, and just get the ...
0
votes
4answers
1k views

Error installing ubuntu-restricted-extras

Ubuntu said I needed to install plugins using the following command in terminal: sudo apt-get install ubuntu-restricted-extras But then I got this error: Reading package lists....Done Building ...
0
votes
2answers
920 views

sudo apt-get not working [duplicate]

I just reinstalled Ubuntu 14.04. Whenever I try to install something using sudo apt-get install it says " has no installation candidate". What do I do?
1
vote
1answer
2k views

Ubuntu 14.04 64 bit - Unmet Dependencies (skype, steam, samba)

I can't install many different kinds of packages on my Ubuntu 14.04 64bit system. I have run the command sudo dpkg --add-architecture i386 as many of the related questions have suggested, but when ...
0
votes
1answer
120 views

Trying to build/install patched gtk3-engines-oxygen to test bugfix, get shared changelog.Debian.gz is different from other instances of package

I want to just quickly test the patch in this bug report to gtk3-engines-oxygen so it can go upstream. I could test it either temporarily or permanently; I would just like to do it. I currently have ...
2
votes
1answer
55 views

Is it safe to remove “proposed” from sources.list?

I just realized that one of my production machines has : deb http://us.archive.ubuntu.com/ubuntu/ precise-proposed main restricted universe multiverse enabled inside its apt-get sources.list. ...
-2
votes
1answer
97 views

Problems with update [duplicate]

I have a problem with updates. During update, i receive the following message. Failed to download repository information Check your Internet connection. W:Failed to fetch ppa.launchpad.net/ gwendal-...
3
votes
2answers
53 views

How do I prevent software packages from being downloaded until I know it's safe?

Recently, an update that caused a problem with Gnome session caused me to lose a day's work. The solution was to rollback some packages to a previous version. The update manager is now telling me ...
0
votes
1answer
382 views

Errors were encountered while processing gdk-pixbuf-psd

I'm getting this error whenever I'm installing/removing or anything else using dpkg... Errors were encountered while processing: gdk-pixbuf-psd E: Sub-process /usr/bin/dpkg returned an error code (1)...
-3
votes
0answers
389 views

Unable to locate package [duplicate]

There are many questions about Unable to locate package. For example : if user try to install package by using apt-get then the following error shown. (Here package is used only as example for ...
24
votes
1answer
9k views

What is the difference between sudo apt-get install and sudo apt install

I installed many packages from sudo apt-get install but when I typed sudo apt --help it gave a direct option of doing installation by sudo apt install [package name]... So, what is the difference ...
4
votes
1answer
188 views

Use of PPA to send simple updates

I wish to setup a PPA to send simple changes to several hundreds of ubuntu 12.04 machines in the field. Simple changes mean that bash script changes and configuration file updates and possibly other ...
0
votes
1answer
331 views

Unable to install specific package version with apt-get

I am trying to run the following command to install a specific version of libssl: apt-get install libssl1.0.0=1.0.1-4ubuntu5.13 As of right now, the latest version is 1.0.1-4ubuntu.14, but I want ...
-1
votes
2answers
3k views

Problem with update-manager: No module named 'apt_pkg' in Ubuntu 13.10, having installed Python 3.4 on /usr/local/lib

I'm rather new to Ubuntu and I'm trying to run update-manager on Ubuntu.13.10. I get: jacopo@jacopo-laptop:~$ update-manager Traceback (most recent call last): File "/usr/bin/update-manager", line ...
3
votes
4answers
2k views

apt-get install was interrupted

I am new to Ubuntu. I got the following lines after an interrupted apt-get install. Running depmod. update-initramfs: deferring update (hook will be called later) Examining /etc/kernel/postinst.d. ...
1
vote
1answer
9k views

Update information outdated, “Failed to fetch cdrom” [duplicate]

I have a warning triangle on the top of my screen. When I click on it, it says that my update information is outdated. When I type sudo apt-get update && sudo apt-get upgrade into a terminal, ...
0
votes
3answers
724 views

Why do I always get this error when using 'apt-get' commands?

I am using Ubuntu 14.04(with Unity). Just today(as of the date of this post) I did a sudo apt-get update && sudo apt-get upgrade and at the end of the 'Upgrade' process I got the following ...
0
votes
1answer
142 views

What does it mean it can't access this file? [duplicate]

user@chrubuntu:~$ sudo apt-get update [sudo] password for user: user Sorry, try again. [sudo] password for user: E: Could not get lock /var/lib/apt/lists/lock - open (11: ...
4
votes
2answers
24k views

Can't update my system due to GPG error Clearsigned file isn't valid, got 'NODATA' [duplicate]

I can't update... I have been trying to troubleshoot this problem for a while now... The only way I found is to re-install Ubuntu... sudo apt-get update -o Debug::Acquire::http=true 0% [Connecting ...
5
votes
5answers
1k views

Why is apt-cache so slow?

After upgrade to Trusty (14.04) from Saucy (13.10), all apt operations are very slow. Even those that do not include downloading anything, or connecting to any servers. For example, displaying the apt ...
0
votes
1answer
717 views

Package management system corrupted. Cannot install or remove packages. U12.04LTS

Having read other posts, I believe that this may be less about samba than about update system. Below is the log file of the failed installation of Samba. I have been trying without success to install/...
2
votes
2answers
116 views

How can we add arch specific conflicts tag when building .deb package?

We are trying to build multi-arch supported i386 .deb package. There are two .deb packages build on i386 X1 & X2 (X2 is a subset of X1 binaries). X1 <-> X2 conflict each other when installing . ...
-1
votes
1answer
111 views

Error message while installing any software as “package dependencies can not be resolved” [duplicate]

when i am installing the softwares by all means (via software center, terminal etc) it gives an error message as "Package dependencies cannot be resolved" Can any one help me out to solve the problem??...
2
votes
2answers
1k views

“Unable to connect to 80.112.143.217:80”, why?

After installing a fresh copy of ubuntu 14.04 downloaded from ubuntu.com I am trying to install some packages be it nodejs or apache2 it always says name not found. I searched a bit and found some ...
0
votes
1answer
649 views

What do I do if launchpad repository doesn't exist anymore?

Recently, ubuntu told me that it failed to resynchronize the package index files from their sources. Here's the output of apt-get update: ... W: Failed to fetch http://ppa.launchpad.net/attente/...
4
votes
4answers
9k views

What do I do for dependencies installing wine1.7 on 14.04

user@chrubuntu:~$ sudo apt-get install wine1.7 [sudo] password for user: Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be ...
0
votes
3answers
4k views

I can't install Skype on Ubuntu 14.04 64-bit

I've tried lots of tutorials I found online, but I can't install Skype. apt-get gives me this error: (but Synaptic doesn't report any broken packages) Some packages could not be installed. This may ...
1
vote
2answers
1k views

Unable to run 'sudo apt-get dist-upgrade' due to authentication issues (Plesk repository)

I've just attempted to run sudo apt-get dist-upgrade on my Ubuntu box, but am getting the following error... WARNING: The following packages cannot be authenticated! librdbmspp php5-ioncube-loader ...
0
votes
1answer
224 views

Is is necessary to do apt-get update everytime

I wonder if in debian flavours you should always do a update before apt-get install? What are the disadvantages if I just install without updating?
0
votes
1answer
2k views

apt -get not executing : command line option g (from get) not known

I'm fairly new to Ubuntu and using a Unix shell. I'm working with Ubuntu 14.04 I'm getting an unusual error when I try using the apt get command for any purpose. >>shreya:~$ sudo apt -get ...
1
vote
1answer
567 views

Cannot locate packages for Citrix install

I'm trying to get a Citrix receiver installed on to Ubuntu 14.04 (64 bit) following Ubuntu's docs. The first line of instructions say to get these required packages: sudo apt-get install libmotif4:...
0
votes
0answers
18 views

Additional apt sources folder [duplicate]

I would like to define an additional sources.list.d folder just for my user; something like ~/sources.list.d so that I sync and use these across my machines. Is it possible to do something like this ...
1
vote
0answers
37 views

migrating ubuntu system to a different machine

I wish to migrate my Ubuntu system, the source system to an existing Ubuntu system, the target system. They run 12.04 and 14.04 respectively. Basically, I want all (or most if that is the best we can ...
2
votes
1answer
1k views

apt-get abort after I type Y to continue

After I use sudo apt-get update && sudo apt-get upgrade to check for updates via terminal, there's a little problem but weird. After I answer to Y, it must be running to downloading updates ...