Advanced Packaging Tool, the package manager for Debian-based distributions. It is also the most used tool for installing packages in Ubuntu. Questions about using any of the apt tools should use this tag.

learn more… | top users | synonyms (1)

1
vote
1answer
2k views

Cannot install lubuntu-desktop

I am trying to install the lubuntu-desktop package. user@host:~$ sudo apt-get install lubuntu-desktop fails with this error: The following packages have unmet dependencies. lubuntu-desktop : ...
1
vote
1answer
346 views

apt-get autoremove “Before uninstall, this module version was ACTIVE on this kernel”

When running apt-get autoremove (or dry run with -s switch), what does the following message mean? Status: Before uninstall, this module version was ACTIVE on this kernel. And what should I do to ...
1
vote
0answers
22 views

E: Unable to parse package [duplicate]

When I do an apt-get update, I get this message at the end: E: Unable to parse package file /var/lib/apt/lists/archive.ubuntu.com_ubuntu_dists_trusty_universe_i18n_Translation-en (1) E: Problem ...
0
votes
1answer
1k views

Unable to install ntfs-config

I have recently installed Ubuntu 14.04 LTS. I ran the command sudo apt-get install ntfs-config, but it displays the following line: Unable to locate package ntfs-config What should i do now to ...
1
vote
1answer
1k views

apt-mirror -error?

I have successfully set up an Ubuntu repository for 14.04 locally using apt-mirror. But at the first in the sources.list I have given deb-amd64 to download 64-bit repository and after completing it I ...
0
votes
1answer
1k views

Is there a way to downgrade or upgrade Samba in Trusty?

Logged a bug here: https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1318840 "Excel Mac open files as read-only on Samba 4.1.6-ubuntu" We didn't have this problem in Precise. I'd either like to: ...
2
votes
2answers
1k views

How do you force apt-get source to get the package you ask for

$ apt-get source libtiff4 Reading package lists... Done Building dependency tree Reading state information... Done Picking 'tiff3' as source package instead of 'libtiff4' E: Unable to find a ...
2
votes
2answers
148 views

apt-get: how to make it keep old archives locally when upgrading packages

I know I can't install previous version without a local copy of the archive of needed version. But today I found out something surprising: I was sure that all previous archives are stored in cache. ...
0
votes
0answers
73 views

Error untrusted packages Ubuntu Software [duplicate]

Good morning: Im new in Ubuntu and i have a problem with he ubuntu software. I've Ubuntu 11.10 whats happens is that when i try to download a program from ubuntu software, the problem (Require ...
1
vote
0answers
283 views

Issue when runing apt-update with Ubuntu 14.04 LTS

I just installed fresh Ubuntu 14.04 LTS. When I run apt-get with root user, I get following error shown below. Any idea how this can be fixed? Please advice. ********Error*********** apt-get ...
0
votes
1answer
306 views

libmotif-common (= 2.3.4-5) error [duplicate]

Which ever software i am trying to install i am getting the below error ramesh@ramesh-K56CA:~/cpract$ sudo apt-get install tlp tlp-rdw Reading package lists... Done Building dependency tree ...
1
vote
2answers
1k views

Adding apt-get to sudoers file

I've grown tired of always invoking apt-get update and apt-get upgrade under sudo and typing my password, so I have added the following line to my /etc/sudoers file using visudo: <myusername> ...
0
votes
2answers
77 views

What Does The Installer Download During The Installation Process?

"Connecting this computer to a wi-fi network allows you to install third party software, download updates, automatically detect your timezone, and install full support for your language." -The ...
0
votes
0answers
25 views

Having a bunch of errors relating to duplicate repositories [duplicate]

I upgraded from 12.04 to 14.04 by downloading the new packages using update-manager -d There are many duplicate repositories and I cannot update packages or anything else. I get these errors: W: ...
1
vote
1answer
599 views

warning when piping apt and grep

I'm running Ubuntu 14.04, with apt 1.0.1ubuntu2 for amd64. I noticed that running: sudo apt search lib | grep nss this warning message is returned: WARNING: apt does not have a stable CLI ...
1
vote
1answer
461 views

“gnutls_handshake() failed” while downloading software

I recently upgraded to Ubuntu 14.04 from 12.04. Now I am facing some problems while trying to install new software (tried via synaptic package manager and apt-get). This is the error I am getting in ...
0
votes
1answer
2k views

Cannot uninstall TrueCrypt

I installed TrueCrypt from their website (.tar.gz file) extracted through the archive manager to /usr/share/truecrypt. I no longer need the app but I cannot uninstall it through sudo apt-get remove ...
0
votes
1answer
6k views

Switch from Ubuntu to Kubuntu — 14.04

What is the command to remove all Ubuntu apps from a Kubuntu desktop, and vice versa, in Ubuntu 14.04? I want to keep the new Unity Locker, but remove everything else :)
0
votes
1answer
104 views

Unable to apt-get update, Synaptic for apt and muon does not start, no way even using a terminal

I am pretty new using Linux and use to mess up my system testing and trying. So, synaptic does not start as all I have to get packets and updates. Here is error's message I had (English isn't my ...
0
votes
2answers
484 views

Packages 404 not found [duplicate]

I know there are many questions like this but this is not the same details. When I use sudo apt-get upgrade or sudo apt-get update command in terminal, this is what I get: W: Failed to fetch ...
2
votes
1answer
3k views

How to find packages when updating Ubuntu and creating standard source.list file

I just upgrade to Ubuntu 14.04 LTS, amd64. I'm trying to install some software and it says for Ubuntu 13.10 and above, the following libraries need to be installed for 32-bit compatibility ...
2
votes
2answers
2k views

Installed 14.04 on a non-PAE (Pentium-M), but now I can't update (“This kernel does not support a non-PAE CPU.”)

Here is what I'm looking at. This isn't my computer. I repair PC's and I had an end user with this low powered laptop running XP so I decided to let him try out lubuntu. The install went smoothly with ...
-1
votes
1answer
98 views

“Failed to fetch liborbit2_2.14.19-0.2_amd64.deb” when installing Java [duplicate]

When I try to install openjdk-7-jdk, I get the following message: Failed to fetch http://in.archive.ubuntu.com/ubuntu/pool/main/o/orbit2/liborbit2_2.14.19-0.2_amd64.deb Size mismatch E: Unable to ...
8
votes
4answers
13k views

Difference between apt-get -d install & apt-get download

Apt (Advanced Packaging Tool) has option to download only package by apt-get -d install [pkg-name]. I have also find apt-get download [pkg-name] to download packages. Then what is the difference ...
1
vote
1answer
128 views

Which version of Banshee in repos with Ubuntu 14.04

I need to know which version of Banshee is the one in repos of Ubuntu 14.04 According to http://packages.ubuntu.com/trusty/sound/banshee It is 2.9.0+really2.6.2-2ubuntu2, so its is 2.9.0 OR 2.6.2?? ...
1
vote
1answer
122 views

Force PPA package to satisfy distro meta-package dependency

I am building a package for my ppa that requires a newer implementation of libboost than what is provided in my target distro (precise). I've copied libboost1.55 from the boost ppa into my ppa. I'm ...
1
vote
4answers
2k views

Ubuntu Server 14.04 - Broken dependancies for Clam AV

Tried to install CLAMAV via command line for Ubuntu Server 14.04. Got the following error: groot:/home/carlo# apt-get install clamav-freshclam Reading package lists... Done Building dependency tree ...
3
votes
2answers
597 views

Saucy: Boost shared libs contain no symbols

I need to link with some of Boost's shared library (.so) files. I have installed boost by running sudo apt-get install libboost-all-dev The header files and static libraries are installed ...
1
vote
0answers
98 views

apt-get update/upgrade not finding latest version of Percona server

I've got Percona DB 5.6 on several 12.04 servers. On a few of them, I've been able to successfully upgrade to the latest version (5.6.17) using apt-get update apt-get upgrade On several others, ...
-1
votes
2answers
224 views

Package manager errors on my ubuntu [duplicate]

I have this issues with my ubuntu apt-get update http://pastebin.com/embed_js.php?i=Ex18v2Ku ubilli@ubilli-pc ~> sudo apt-get update [sudo] password for ubilli: Ign http://ppa.launchpad.net ...
7
votes
3answers
6k views

How to conveniently install cx_Freeze for Python 3?

I want to install cx_Freeze for Python 3. My Ubuntu 14.04 has Python 2.7 and Python 3.4. For Python 2 I could install cx_Freeze very conveniently using: sudo apt install cx-freeze However this only ...
1
vote
0answers
110 views

What is a good workflow to develop/test/release packages via apt repositories?

We are currently looking for a workflow to manage Ubuntu packages and releases within apt repositories. Until now our small team did the development in git. One occasionally used the master branch to ...
16
votes
1answer
71k views

What does apt-get --fix-missing do and when is it useful?

From the man page: -m, --ignore-missing, --fix-missing Ignore missing packages; if packages cannot be retrieved or fail the integrity check after retrieval (corrupted package files), hold back ...
3
votes
1answer
374 views

How to get a summary of installed packages by repository and see differences from clean install?

I just upgraded several PC to Ubuntu Trusty 14.04. For this, I used to install everything from scratch to get a clean system, keeping only /home (and /etc for reference). This time however I upgraded ...
0
votes
0answers
41 views

Installing Wine on Ubuntu 14.04 [duplicate]

Tried several times to install Wine, see the terminal output below: ray@ray-Aspire-5735:~$ sudo add-apt-repository ppa:ubuntu-wine/ppa Welcome to the Wine Team PPA. Here you can get the latest ...
1
vote
1answer
168 views

No packages are installing

I am trying to install MyUnity, but it won't install by apt-get install myunity. I get the following error: sudo apt-get install myunity [sudo] password for savageowl: Reading package lists... Done ...
0
votes
1answer
269 views

can't install Tor. Now I can't use apt-get

You might want to run ‘apt-get -f install’ to correct these. The following packages have unmet dependencies. tor-geoipdb : Depends: tor (>= 0.2.4.21-1~saucy+1) but it is not installed E: Unmet ...
0
votes
2answers
40 views

What does “reduce delta to ubuntu” mean?

In Accepted apt 1.0.3 (source all amd64), this appears: Changes: apt (1.0.3) unstable; urgency=medium . [ Michael Vogt ] * reduce delta to ubuntu * provide support for vendor specific ...
4
votes
2answers
3k views

unable to to locate package apt-fast

This is what I tried: $ sudo add-apt-repository ppa:apt-fast/stable $ sudo apt-get update ..........something something......... ................................................................. ...
4
votes
1answer
726 views

Missing dependency when installing Canon Pixma MX330 drivers from michael-gruz PPA [duplicate]

I am attempting to install a canon pixma mx330 (multi-function) all-in-one on Ubuntu 14.04. I found a page with instructions for installing canon printers, and I have followed the instructions to ...
3
votes
2answers
1k views

Trusty Software Updater does not propose updates from trusty-updates

I have since one week upgraded several PC to Ubuntu 14.04 Trusty Tahr. I got several updates via the Software Updater, but I don't get updates from trusty-updates, although this repository is ...
1
vote
2answers
58 views

Is apt-cacher capable of managing packages which are being requested by clients ?

I'm currently experimenting with building a repository for our company. Our only need is ability to control which specific packages are beeing pushed to clients. We agreed on apt-cacher. My question ...
-1
votes
1answer
231 views

Can I install two versions of libbullet?

I use ubuntu 12.04 My error msg: sam@sam:~/code/pcl_standalone/vfh_dir$ sudo apt-get -f install Reading package lists... Done Building dependency tree Reading state information... Done ...
1
vote
1answer
5k views

Unable to install libssl1.0.0:i386 due to “unmet dependencies”?

I have read and followed the advice in this question to no avail. I am attempting to install libssl1.0.0:i386 on my 14.04 box (amd64), but when I try to do this via APT, I receive the following error ...
1
vote
2answers
189 views

apt-get does not install any programs or update after upgrade from 11.04 to 14.04 (LTS)

I've upgraded from 11.04 to 14.04 and I have some issues when using apt-get. Below is an example of what I get when trying to install mysql-server (same issue for any package installation): ~$: sudo ...
1
vote
1answer
172 views

Switching Java version through apt?

(Apologies in advance if my formatting is off, this is my first post, please feel free to correct me). Normally, when I want to find out what version of java I'm using, I run: java -version java ...
0
votes
0answers
39 views

sudo apt-get -f intall -> E: Sub-process /usr/bin/dpkg returned an error code (1) [duplicate]

i want to install "ghostview" by using Ubuntu software center. however, the error message occurs and I type as sudo apt-get -f install after that, I can get this result Reading package lists... ...
1
vote
0answers
24 views

Cannot Update the system : E:Malformed line 1 in source list /etc/apt/sources.list (dist parse) [duplicate]

This is my problem I was changing ubuntu 12.04 to 12.10. All the downloads and installations were OK. Then after the restart, my touchpad and my wireless card were unable to use. I could solve the ...
1
vote
1answer
682 views

BOTH available-old & available missing from dpkg - “dpkg: error: failed to open package info file `/var/lib/dpkg/available' for reading”

Issue : Many threads try to solve the broken packages problem using the options as below. However my main problem is that BOTH the available & available-old do not exist . I have no clue how I ...
0
votes
2answers
5k views

Installing OpenFOAM 2.3 on Ubuntu 14.04

There is currently no package for Ubuntu 14.04 Trusty at http://www.openfoam.org/download/ubuntu.php. If I try to use the package for 13.10 Saucy aptitude gives me an error when I try sudo aptitude ...