Advanced Packaging Tool, the package manager for Debian-based distributions. It is also the most used tool for installing packages in Ubuntu. Questions about using any of the apt tools should use this tag.

learn more… | top users | synonyms (1)

0
votes
0answers
32 views

Try to delete the linux-image

try to delete the Linux image in the boot sector because the disk space is full but I'm not allowed because I have to install a new image first, someone who can help, I'm not allowed to install any ...
0
votes
0answers
33 views

how to downgrade related packages together?

Related Question : downgrade a package The situation is a bit different, I have a group of packages say aaa-*.deb which was involved in the down grade. obviously I don't want to deal with them one ...
0
votes
0answers
58 views

Is there an easier way to install Bugzilla manually in Ubuntu Server?

Is there an easier way to install Bugzilla manually in Ubuntu Server? While installing Bugzilla I get different problems with the modules. All the modules don't get installed that easily. Right now I ...
0
votes
0answers
42 views

problem Install openFOAM on Ubuntu 12.04

Followed the installation guide from openFOAM: $ VERS=$(lsb_release -cs) $ sudo sh -c "echo deb http://www.openfoam.org/download/ubuntu $VERS main > /etc/apt/sources.list.d/openfoam.list" ...
0
votes
0answers
13 views

Internal package repository

I have a Raspberry Pi with the Raspbian OS installed. I developed multiple applications that I manually installed on it. I would like to use the standard package manager to install those applications ...
0
votes
0answers
29 views

Getting no valid OpenPGP data when importing apt key

I am having trouble adding a Release.gpg public key to my apt-key keyring. I downloaded the Release.gpg file which looks like this: -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.4.11 (GNU/Linux) ...
0
votes
0answers
47 views

Problem in updating ubuntu?

The following packages will be upgraded: cups-common libpam-systemd libpoppler46 libsystemd-daemon0 libsystemd-journal0 systemd 6 upgraded, 0 newly installed, 0 to remove and 342 not upgraded. ...
0
votes
0answers
245 views

dpkg: error processing package libapache2-mod-php5

I have a problem at moment of use my apt-get/aptitude package manager When I want install some packages I get the following output: sudo aptitude install libxslt1.1 libxml2 The following partially ...
0
votes
0answers
47 views

Installing Git on Ubuntu, packet not found

I can't connect to my WLAN (Broadcom e4313). I searched online for a Solution and found a brmcsmac package which I should install with git. Now I wanted to install git with: sudo apt-get install git ...
0
votes
0answers
123 views

aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template with 12.04.5

I have an issue similar to this one but answer given there does not help. Here's how my sources.list looks like: ############################################################# ################### ...
0
votes
0answers
39 views

ubuntu 12.04 LTS failed to update error for sudo apt-get update

I m trying to update Ubuntu. I m very new to Linux platform and require detailed help in doing it. I am a student and they provide me proxy for using the network . I m not able to update as in ...
0
votes
0answers
127 views

Another “Some index files failed to download”-error, but there's no 404 error

everyone. I know that there have been other error reports similar to this one, but none with quite my same experience. I'm running Ubuntu 14.04 (32-bit) on an Acer AspireOne with 2 GB RAM, an ...
0
votes
0answers
152 views

Problems in update ubuntu 14.04

I am using Ubuntu 14.04 alongside Windows 7 in my Sony laptop. I tried to update using sudo apt-get update but the following errors occurred while updating Err http://ppa.launchpad.net trusty/main ...
0
votes
0answers
86 views

How to make apt update everything with cron-apt?

For my 14.04 server, I've set up cron-apt to update every day at 4'o clock. Today I've reviewed /var/log/cron-apt/log to make sure it has updated bash to fix shellshock. And indeed, it has updated ...
0
votes
0answers
42 views

Networking issue in IBM x3650 after install Ubuntu 14.04.1

I have a problem making TCP connections after a fresh Ubuntu 14.04 installation. First of all, after booting the interface is always off, in my case em2(manually configured), so I turn it on using ...
0
votes
0answers
202 views

How to install drivers for NVIDIA GT210?

I've spent several hours on making my videocard work after upgrading Ubuntu to 12.04. Nothing worked. The latest attempts were: Installing the 'official' driver ...
0
votes
0answers
95 views

Errors while installing wine on ubuntu 14.04

I tried to install wine through ppa and got unmet dependencies. Now I am trying to install wine through source. sudo apt-get install flex bison qt4-qmake sudo apt-get install flex bison qt3-dev-tools ...
0
votes
0answers
82 views

Unable to install GCDemu in Trusty Tahr

After trying to install gcdemu from ppa I always get this error and im unable to install it I get this error (synaptic:6595): GLib-CRITICAL **: g_child_watch_add_full: assertion 'pid > 0' failed ...
0
votes
0answers
27 views

Computer temporarily freezes on 97% evertime apt-get is run?

When I run apt-get on my computer it temporarily freezes for a few seconds sometimes ranging to a minute with the system completely unresponsive. Can anyone help me clarify the source of this problem ...
0
votes
0answers
70 views

getting error while trying to install ubuntu-tv in ubuntu 14.04 LTS

Im trying to install Ubuntu-TV and I ran apt-get install unity-lens-video and it returned This error: Selecting previously unselected package unity-scope-video-remote. Preparing to unpack ...
0
votes
0answers
29 views

Desktop wallpaper is reset whenever I update my system?

I am running Ubuntu 14.04 and whenever I run $ apt-get upgrade in my Terminal, other users on the system complain their desktop wallpaper is reset to the default Ubuntu 14.04 wallpaper. I haven't ...
0
votes
0answers
106 views

Unmet dependencies when install program 32 bits version on 64 bits

I am trying to install some libraries 32 bits version on my ubuntu 14.04 LTS 64 bits. I know ubuntu 14.04 LTS support multiarch. I attempt install via apt-get but I get some umet dependencies: sudo ...
0
votes
0answers
97 views

I can't install unity8-desktop-session-mir

I try to install unity 8 on ubuntu trusty but when I type this command sudo apt-get install unity8-desktop-session-mir , it not work and return this error: Reading package lists... Done Building ...
0
votes
0answers
78 views

Can't remove the libpcap0.8 package or install any other package

I have a similar question to this question. Playing around with reaver was a bad idea. Upon running the command in the answer I get the following: joe@biden:~$ sudo apt-get -f remove libpcap-dev ...
0
votes
0answers
25 views

Simple instructions for creating a pacakge

I am about to give up creating a package for Ubuntu even though it is my development platform. I have a GPL app based on Qt, it has several sharelib to include and a few lib dependencies. I have ...
0
votes
0answers
51 views

anki issues how to make work

Hi further to my question ealrier Below is the error message I get from my computer when I try to use Anki (2.0.28) Today, I have ascertained that it is my computer and not the files for anki which ...
0
votes
0answers
118 views

How can I correct a 502 Proxy Error for a single source when updating sources on Ubuntu 14.04?

I am behind a proxy on Ubuntu 14.04 Trusty and need to add the source for MakerBot software and install the makerware software. When I add the source and run the command to update package lists, I get ...
0
votes
0answers
191 views

Apt-get unmet dependencies

I´m using Ubuntu Server 12.04 and MySQL 5.5. When I try to install libsml2-dev I get the following message : root@myserver:/usr/local/php5516/php-5.5.16# apt-get install libxml2-dev Reading package ...
0
votes
0answers
21 views

determine which package(s) were installed from a particular source

Some time ago, I installed a package from a qantal ppt source - at the time, it was only available in the quantal (12.10) repos; I'm running precise (12.04). The qantal repo has now been removed from ...
0
votes
0answers
260 views

Nvidia update video driver

This is a really quick question. I tried looking around, but couldn't find a definite yes or no answer. In order to update my video card driver from 331.38 to 340 or higher, do I have to remove or ...
0
votes
0answers
212 views

How to change gcc-4.9-base version without removing dependecies?

I have a freshly installed Ubuntu 14.04.1 but cannot install nvidia-331 driver because of dependencies conflict: lib32gcc1 should be installed but it conflicts with already installed gcc-4.9-base ...
0
votes
0answers
136 views

I can't use proprietary drivers for AMD 8970M (14.04)

I have checked in the additional drivers section but it says I am using manual drivers. I try clicking on trying to use the proprietary drivers but cant select that option. I have tried: sudo apt-get ...
0
votes
0answers
123 views

Unable to find expected entry 'main/source/Sources' in Release file

I have few packages on my remote server. I have packages for both precise and trusty. Well, since apt repo of precise does not have ruby-2.0.0, I had to manually put it up. I use aptly and publish the ...
0
votes
0answers
131 views

When trying to upgrade to Ubuntu 14.04, libc6 breaks, why and how to solve this problem?

$ sudo apt-get install -f Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... Done The following packages were automatically ...
0
votes
0answers
23 views

How to block installing grub into MBR while upgrade?

I have a problem with blocking installing GRUB into MBR. I have to block it in ubuntu and debian template to not let users "destroy" their XenServers (with GRUB in MBR they wont boot). Ubuntu ask for ...
0
votes
0answers
166 views

error: parsing file '/var/lib/dpkg/updates/0001' near line 0: newline in field name `#padding'

I was try to install mono using the following command: sudo apt-get install mono-* I closed the terminal while it was installing. I restarted the install, and I got the error message: Could not ...
0
votes
0answers
223 views

cannot update or install new packages Kubuntu 14.04.1 after upgrade from 12.04.5

I upgraded my 12.04.5 Kubuntu installation to Kubuntu 14.04.1, but during the installation of packages, two things went wrong. First was a long-named deb package that had "all" at the end of it, which ...
0
votes
0answers
47 views

“php-clamav: depends on: phpapi-20090626+lfs but it is not going to be installed”

I want to install "php-clamav" . But... msy@msy-Inspiron-One-2020:~$ sudo apt-get install -f php-clamav 正在读取软件包列表... 完成 正在分析软件包的依赖关系树 正在读取状态信息... 完成 有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是 ...
0
votes
0answers
69 views

apt-get install nfs-common does not create an idmapd

I am trying to get NFSv4 client to work with idmapd and I try sudo apt-get install nfs-common Unfortunately, this installs the expected files /etc/default/nfs-common, /etc/idmapd.conf etc., but ...
0
votes
0answers
20 views

How to install vagrant if ruby is already installed in the system?

I had installed ruby via rbenv and installed the latest stable version from their repository. I have also configured ruby for all the users. Now, when I am trying to install vagrant via apt-get it ...
0
votes
0answers
42 views

Running apt-get past a proxy?

Ok so I know there are a lot of similar questions to this already, and I'm a noob when it comes to Linux btw. But I really need to know how to run sudo apt-get install PROGRAM (in this case a word ...
0
votes
0answers
53 views

Sound is not working after fresh reinstallation on ubuntu 14.04

I'm trying to fix this issue using SoundTroubleshooting guide I figured out (w/ its help) that the sound modules are not installed, so I issues the following command to install it:sudo apt-get install ...
0
votes
0answers
25 views

ubuntu 14.04 apache2 how do I restrict some directories to localhost only

after upgrade from 12.04 to 14.04, my old modified apache2.conf files are in place. I would like to start my configuration over using the default 2.4.7 config files - but I don't want to overwrite ...
0
votes
0answers
220 views

Not able to upgrade 12.04 to 14.04.1

I want to upgrade 12.04.5 to 14.04.1. I have already have Windows 8 and 14.04 on this computer - just wanted to upgrade the 12.04.5, too. When I try to upgrade it (using both GI and terminal) I get ...
0
votes
0answers
122 views

Reinstalling X11 drivers in Ubuntu 14.04

I've recently upgraded from Ubuntu 12.04 to 14.04. Now, I am unable to launch xserver. The following error is shown: (EE) module ABI major version (6) doesn't match the server's version (8) xinit: ...
0
votes
0answers
5 views

Error (5:input/output) warning coming from status bar

I'm attempting to install Ubuntu 14.04 on an Acer Aspire-5734Z laptop. I've had issues in the past with failed attempts at installing Ubuntu on this machine so now I'm turning to here for help. I'm ...
0
votes
0answers
128 views

Cannot Install Airtime

I tried to install Airtime 2.5.1 on ubuntu 13.04 and on ububtu 14.04 and both times I got this message in terminal: Setting up airtime (2.5.1-3) ... Setting up apache2... Site airtime-vhost already ...
0
votes
0answers
30 views

Patch a package by adding new files to it?

I'm trying to patch an existing package, and my patch is supposed to change some files and add some files and directories to the package. All seems to work, the .patch file in debian/patches looks ...
0
votes
0answers
38 views

Not able to get the KDE desktop after upgrading from 10.04 to 14.04

I upgraded my laptop from Kubuntu 10.04LTS to 14.04LTS. After upgrade I am not able to get the launchbar, I only see desktop items. After google-ing I tried to re-install unity/compiz but I got this ...
0
votes
0answers
105 views

Apt-get and dpkg not working due to mono-complete

After installing the mono-complete package, no matter what I do in apt-get and dpkg, even apt-get -f install and the likes, except for apt-get update, I ALWAYS get the following errors: Setting ...