Advanced Packaging Tool, the package manager for Debian-based distributions. It is also the most used tool for installing packages in Ubuntu. Questions about using any of the apt tools should use this tag.

learn more… | top users | synonyms (1)

15
votes
2answers
21k views

What's the difference between apt-get install and apt-get build-dep?

On the apt-get man's page, one can find this: install pkg(s) This option is followed by one or more packages desired for installation. Each package is a package name, not a fully qualified ...
15
votes
1answer
774 views

How do the various APT package removal commands differ?

What's the difference between these commands? sudo apt-get autoremove --purge packagenames sudo apt-get remove --purge packagenames sudo apt-get purge purge packagenmaes sudo apt-get remove ...
15
votes
2answers
2k views

What is apt-fast and should I use it?

Several times over the past couple years, I've heard of people using apt-fast for updating and installing packages, but I'm not really sure what it does. I think I've traced its origin to this forum ...
15
votes
1answer
12k views

How to solve “Extra junk at end of file” when using apt?

I'm trying to configure some proxies for a guest virtual machine and now I'm getting: sudo apt-get update E: Syntax error /etc/apt/apt.conf.d/95proxy:4: Extra junk at end of file The content of the ...
15
votes
3answers
14k views

/var/lib/apt/lists huge in 12.04

I noticed that /var/lib/apt/lists is HUGE. It's as large as 86MB. Which seems a little too big. Is this normal, if not. What should I do? Thanks
15
votes
1answer
56k views

What does apt-get --fix-missing do and when is it useful?

From the man page: -m, --ignore-missing, --fix-missing Ignore missing packages; if packages cannot be retrieved or fail the integrity check after retrieval (corrupted package files), hold back ...
15
votes
3answers
639 views

How are packages suggested and what is the difference between extra and new packages?

When installing a new package via "apt-get install", I usually just tick yes if it is a program I need/want, but, I read through it, and, I am a little curious as to what the sections actually mean. ...
14
votes
4answers
5k views

How can I run “apt-get install” in the background?

When I try to install a package, for instance nsnake, with the command sudo apt-get install nsnake &, the process immediately stops. I can bring it to the foreground and enter my sudo password, ...
14
votes
6answers
67k views

Permission denied, are you root?

I get this error whenever I try to install programs using the terminal: home@ubuntu:~$ apt-get install myunity E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied) E: Unable ...
14
votes
3answers
4k views

Why do some packages conflict with themselves?

After an upgrade to Oneiric I have had some troubles with the package manager (it wanted to remove half of my system, including libc6, zlib1g packages etc). During the fight with aptitude I've noticed ...
14
votes
4answers
45k views

Can't find boot-repair package for the newest version of Ubuntu

After upgrading Ubuntu 13.10 to 14.04, grub failed to load Ubuntu and threw the error symbol 'grub_term_highlight_color' not found. I followed the solution offered in the Bug Report but this failed ...
14
votes
5answers
24k views

Steam Install Error on 14.04 Ubuntu 64bit

I have tried some of the solutions posted elsewhere in the support forum, one seemed like it worked but after a steam update i found myself back at square one I am a new Linux user and am already at ...
14
votes
2answers
967 views

Packages are removed when I use “apt-get install” with a hyphen after the package name

In an attempt to install cuda, I copy-pasted some apt-get install packages. For unknown reasons the line that I got run in the end is the following: sudo apt-get install libgtk2.0- The result was ...
14
votes
4answers
44k views

Installing latest version of R-base

I have been unsuccessfully trying to install the latest version (2.15.2) of r-base. Apparently, R package Rcpp would not install for R version 2.14.1 - the version that installs for me. I am not ...
14
votes
2answers
15k views

How do I get details about a package which isn't installed?

How can I get some details about a package without installing it, (eg. the description and version number) like in Synaptic or Aptitude. The command dpkg -s PACKAGE does not work, with this error. ...
14
votes
3answers
496 views

How can I know what programs does some apt-get package contains?

I would like to know what does some specific package install, for example, when installing ncurses, I have found that TAB key expands: sudo apt-get install ncurses- to show: ncurses-base ...
14
votes
8answers
80k views

How to fix a broken package, when “apt-get install -f” does not work? [duplicate]

I tried to install Scala with the typesafe stack and got into trouble. Now I cannot do much with apt (except update), the broken package seems to be impossible to remove/clean: Here's the result of ...
14
votes
1answer
4k views

How do I ignore a proxy if not available?

Following the instructions in Best way to cache apt downloads on a LAN?, I've set up a caching proxy in my local network. Since that machine is not always up, I'd like to be able to refresh the ...
14
votes
3answers
6k views

Reading package list takes forever

I've been trying to update my stuff on my machine, and it seems like it can't read my package list. It seems like every time i do the sudo apt-get install *something* && sudo apt-get update it ...
14
votes
1answer
10k views

What is the advantage of using sudo apt-get autoremove over a cleaner app?

I'm not overly sure what sudo apt-get autoremove does, but have read that you should use this to remove any unnecessary packages. One of the processes I saw was to use sudo apt-get autoremove and ...
14
votes
3answers
3k views

oracle-java8-installer results in “apt” removal? [closed]

I have been been running trusty since the first alpha release, pulling daily updates. I also installed the oracle-java7-installer from the WebUpd8 PPA. Today I noticed during a dist-upgrade that ...
14
votes
4answers
16k views

Why does “tasksel” give an “aptitude failed” error?

The problem started in the following way. I was using tasksel from the terminal menu that it shows when I simply do sudo tasksel. I select Lamp Server from the list and started to install all packages ...
14
votes
1answer
11k views

How do I check only security updates from the command-line?

Is there a way to quickly check for the availability of security updates from the command line? On my 12.04 system running apt-get update fetches 20MB of data about available packages every time I ...
14
votes
2answers
269 views

Why do some commercial apps have a section called 'also requires' and free apps don't?

In the Ubuntu Software Center paid (commercial) applications get a section called 'Also requires' which is quite neat. Why don't the free applications get this feature? For example Amnesia: The Dark ...
14
votes
3answers
2k views

How to prevent so many instances of apt-check running?

I have an Ubuntu 12.04 server that just crashed because of a very obvious cause: 30+ of apt-check processes consuming all memory, the OOM killer kicking in, killing vital services. I'm not sure where ...
14
votes
3answers
1k views

gpg: keyblock resource ‘/etc/apt/trusted.gpg.d//webupd8team-sublime-text-3.gpg’: resource limit

No matter what I do, I get the following error: gpg: keyblock resource ‘/etc/apt/trusted.gpg.d//webupd8team-sublime-text-3.gpg’: resource limit The original error(Dutch) Original Dutch sudo ...
13
votes
8answers
14k views

Failed to download repository information due to missing CDROM

When updating I got this error message: W:Failed to fetch cdrom://Ubuntu 11.10 _Oneiric Ocelot_ - Release amd64 (20111012)/dists/oneiric/main/binary-i386/Packages Please use apt-cdrom to make this ...
13
votes
4answers
20k views

where are apt-get files stored?

i have an ubuntu with three virtual machines running inside running ubuntu also i update the host using apt-get update but i can update VM's, it takes a long time + uses a lot of bandwith which ...
13
votes
4answers
878 views

How do I find add-ons for packages when using the command line?

My question is a little bit different from others already asked, I guess. I've already searched for answers, but I didn't find anything related. For example, I've always installed K3B via Terminal ...
13
votes
2answers
41k views

Updating ubuntu server apt-get gives me - 404 Not Found [duplicate]

I'm trying to update a Ubuntu server and when I run apt-get update I get a number of errors like the examples below (note I added some space after http). Err http ://no.archive.ubuntu.com natty/main ...
13
votes
3answers
6k views

apt-get or aptitude equivalent to yum whatprovides

Is there an equivalent to the yum "whatprovides" option in apt-get? For example on CentOS yum whatprovides /usr/share/gdm/themes/TreeFlower/background.png Tells me ...
13
votes
1answer
18k views

Force apt-get to overwrite file installed by another package

(I realize a similar question was asked before but the answers there don't handle these details) I'm on Ubuntu 10.10 and need both python2.5 (coming from deadnsakes -- ...
13
votes
4answers
42k views

Do Dpkg and apt-get install dependencies?

I've been wondering, is there a way to tell dpkg or apt-get that when I want to install a package also install all the dependencies it requires? I installed a package using dpkg but it complained ...
13
votes
1answer
6k views

How do I install the latest version of Git with apt?

I read about a security flaw in Git, which was fixed in version 2.2.1. I currently have Git 2.1.0 on my system (Ubuntu 14.10), and tried to reinstall it with apt. However, apt told me that I currently ...
13
votes
4answers
12k views

Why does apt-get fail when automated with cron?

I'm trying to use cron to automate my system updates. You can see my crontab, commands, and resulting errors below. When I run upgrades.sh as root, the script runs fine. When cron runs it, apt-get -y ...
13
votes
2answers
11k views

apt changelog for to-be installed packages [duplicate]

GUI update-manager is able to show the "changelog" of packages to-be installed (not downloaded yet). I also found out how to provide the .changelog files in the right place for update-manager to show ...
13
votes
2answers
31k views

How to upgrade PHP version to the latest stable released version? Let's say how to upgrade from PHP 5.5.19 to PHP 5.5.20?

I'm using a system running on Ubuntu 12.04 LTS 64-bit OS. I'm currently using following PHP version on this machine: Command used to get the below info at terminal : php -v Details I got are as ...
13
votes
1answer
39k views

How to solve configure: error: readline library not found?

I have an Ubuntu 10.04 LTS server with a minimal install that I want to compile postgres on. With the minimal install the server did not have gcc so I had to do an apt-get install gcc but now I keep ...
13
votes
1answer
17k views

Where do packages installed/upgraded with APT get stored?

As time goes by we tend to do apt-get install and add or replace software. Are these archived in some form or do they get auto-cleared after installation? And if it doesn't get auto-cleared, it would ...
13
votes
5answers
198k views

Apt-Get Update: failure to fetch; can't connect to any sources

I realize there are dozens of "apt-get update: failure to fetch" questions (I read through all I could find), but my present circumstance is unique to 12.04 and it affects all sources; not just ...
13
votes
3answers
8k views

Why does update-mime-database complain about uri/rtspt and other unusual types?

When running update-mime-database - usually automatically launched by apt-get - why do I reliably get complaints like: Unknown media type in type 'all/all' Unknown media type in type 'all/allfiles' ...
13
votes
2answers
6k views

How to forbid a specific package to be installed?

Can I configure Ubuntu to never install a specific package even if it is required by another package I install?
13
votes
4answers
5k views

downgrade ppa packages to versions available at a previous point in time

The backstory is that the normal Intel GPU drivers don't do the various OpenGL extensions that my hobby coding and some games want. So I have to install xorg-edgers and then its happy. However, last ...
13
votes
2answers
24k views

“The package lists or status file could not be parsed or opened”

Everytime I sudo apt-get update it always not complete and will say in the end E: Read error - read (5: Input/output error) E: The package lists or status file could not be parsed or opened. Same ...
13
votes
1answer
6k views

Hold packages back from updates without APT Pin?

I know about pinning packages with Apt. That's not what I want to do. Other questions have been answered with either using pinning or by using pins temporarily. I don't want to do this. What I want ...
13
votes
1answer
32k views

apt-get update not working (Not Found [IP: 91.189.92.201 80]) [closed]

When I try to run apt-get update I get the following error messages: I am using: Distributor ID: Ubuntu Description: Ubuntu 11.04 Release: 11.04 Codename: natty W: Failed to fetch ...
13
votes
5answers
32k views

What is the command line equivalent for the update manager?

When I do sudo apt-get update sudo apt-get upgrade Sometimes the Ubuntu GUI Update Manager will still have some items left. e.g. “Complete Generic Linuux kernel”. I know there's also sudo apt-get ...
13
votes
1answer
69k views

remove package with apt-get or dpkg [duplicate]

I am just wondering if I want to remove a package from my system say google-chome-stable, i have two ways of doing it: sudo apt-get remove google-chrome-stable and dpkg -r google-chrome-stable ...
13
votes
2answers
17k views

Installing packages into local directory?

I'd like to install software packages, similar to apt-get install <foo> but: Without sudo, and Into a local directory The purpose of this exercise is to isolate independent builds in my ...
13
votes
1answer
366 views

What the meaning of package version number with word 'really' in the middle?

Command apt-cache show postgresql will listed this information in my machine (Saucy Salamander 13.10): $ apt-cache show postgresql Package: postgresql Priority: optional Section: database ...