Advanced Packaging Tool, the package manager for Debian-based distributions. It is also the most used tool for installing packages in Ubuntu. Questions about using any of the apt tools should use this tag.

learn more… | top users | synonyms (1)

0
votes
0answers
29 views

When I want to install anything in Ubuntu Software Center or through sudo apt-get, I am facing issues

My problem is exactly same as stated at the link Ubuntu Software Center not working; says the package catalog needs repair Though according to the solution provided at that place does not work for ...
0
votes
1answer
17 views

where are the apt indexes stored and can they be removed?

I am performing an apt-get update prior to installing some packages: Get:1 http://archive.ubuntu.com trusty Release.gpg [933 B] Get:2 http://archive.ubuntu.com trusty-updates Release.gpg [933 B] ... ...
0
votes
1answer
23 views

Trouble with the Cache [duplicate]

I am using a ubuntu 12.04 LTS 32-bit The little red ball on my toolbar says: 'Error: Opening the cache' (E:Encountered a section with no Package; header, E. Problem with ...
1
vote
2answers
377 views

How do I re-run boot loader?

Running sudo apt-get -f install said that The link /vmlinuz.old is a damaged link and: you may need to re-run your boot loader[grub] Here's the full output: user@chrubuntu:~$ sudo apt-get -f ...
0
votes
0answers
4 views

Error (5:input/output) warning coming from status bar

I'm attempting to install Ubuntu 14.04 on an Acer Aspire-5734Z laptop. I've had issues in the past with failed attempts at installing Ubuntu on this machine so now I'm turning to here for help. I'm ...
-1
votes
0answers
39 views

Ubuntu Software Center Just opens then closes [duplicate]

Ubuntu Software Center Just opens then closes. when i click on the icon it just opens up freezes then closes. nothing pops up and it doesnt say anything at all. does anyone know what could be the ...
0
votes
1answer
253 views

Ubuntu server 14.04.1 LTS wont install any packages after reboot

I just installed Ubuntu server 14.04.1 LTS on my old gaming pc to run a file server on. I got it all installed on the PC and was able to apt-get update and apt-get upgrade and install samba, ...
0
votes
2answers
25 views

Does purging an application prevent its reinstallation?

If I'm using purge to remove something, will I be able to reinstall that thing after if I want or it's somehow blocks that option in the future?
0
votes
0answers
60 views

unattended-upgrades error: “/etc/cron.daily/apt: DB Update failed, database locked”

Ubuntu 14.04.1 LTS Since installing unattended-upgrades, the following error message is received daily: From root@xxxxx Thu Aug 28 06:36:06 2014 X-Original-To: root From: root@xxxxx (Cron Daemon) ...
0
votes
0answers
50 views

Cannot Install Airtime

I tried to install Airtime 2.5.1 on ubuntu 13.04 and on ububtu 14.04 and both times I got this message in terminal: Setting up airtime (2.5.1-3) ... Setting up apache2... Site airtime-vhost already ...
0
votes
1answer
33 views

Stuck in a mess

I'm stuck in mess. I recently blanked my administrative password. When I try to do anything that requires a password, I don't have one. Also installing software from the networking bash console(to ...
1
vote
1answer
147 views

After removing the latest kernel, how can I be notified of kernel updates again?

Yesterday, I updated all packages through the software updater. It installed kernel 3.13.0-35. When I rebooted, I would get a completely unresponsive blank screen, so I went back to the Grub menu ...
0
votes
1answer
83 views

problem installing package

I've faced following problems while installing packages- installArchives() failed: E: Cannot get debconf version. Is debconf installed? debconf: apt-extracttemplates failed: No such file or directory ...
1
vote
1answer
868 views

dpkg: error processing package linux-image-generic (--configure): dependency problems - leaving unconfigured

dpkg --configure -a Setting up linux-image-3.13.0-35-generic (3.13.0-35.62) ... Running depmod. update-initramfs: deferring update (hook will be called later) The link /initrd.img is a dangling ...
0
votes
0answers
17 views

Patch a package by adding new files to it?

I'm trying to patch an existing package, and my patch is supposed to change some files and add some files and directories to the package. All seems to work, the .patch file in debian/patches looks ...
2
votes
1answer
21 views

Where can I find statistics on package downloads and dependencies?

Is there a site that lists (or ranks) Ubuntu/Debian packages by downloads or dependency count? The Node.js package manager npm has leaderboards, as does PyPI (unofficially). It'd be interesting to see ...
0
votes
1answer
62 views

Java is installed but not recognized

austin@HP-ENVY-m6-Notebook-PC:~$ java -version The program 'java' can be found in the following packages: * default-jre * gcj-4.8-jre-headless * openjdk-7-jre-headless * gcj-4.6-jre-headless * ...
0
votes
1answer
63 views

Unable to get exclusive lock, apt-get busy

Whenever I try a command, I get an error saying: Unable to get exclusive lock Also apt-get is busy, but I am not even running any other application.
1
vote
0answers
32 views

“Depends: ___ but ___-saucy is to be installed” type broken dependencies after Trusty upgrade

The installer threw an error near the end of the 14.04 Trusty upgrade. unity-control-center is not installed and upon trying to install it I now have a chain of broken dependencies which, after going ...
0
votes
2answers
91 views

Why am I getting Error: need a single repository as argument for sudo add-apt-repository ppa: paolorotolo / android-studio

I am executing the following command as per the instructions in the link. sudo add-apt-repository ppa: paolorotolo / android-studio I am getting the error - Error: need a single repository as ...
-1
votes
0answers
83 views

Error occurring while updating the repo

I'm using ubuntu 12.04 LTS and getting this error while updating the repo. How to resolve this GPG error? W: A error occurred during the signature verification. The repository is not updated ...
0
votes
1answer
50 views

Error installing ubuntu-desktop on 14.04

I am trying to install ubuntu-desktop on 14.04 but when I run apt-get install ubuntu-desktop it gives error: Some packages could not be installed. This may mean that you have requested an ...
0
votes
1answer
80 views

Installing FOG on Ubuntu 12.04

I am trying to install FOG on 12.04 Server LTS. I have downloaded the latest version from SF, but when I try to install it, it fails when trying to install MySQL, specifically with: The following ...
1
vote
3answers
49 views

Problem installing gcc compiler

I tried to install gcc compiler because I want to learn programming I have an old computer 1gb ram so I installed an older version of Ubuntu (10.04) and its working faster than before but when I try ...
0
votes
1answer
46 views

apt-get remove does not remove

After I install, then remove a package, the application is still present: $ sudo apt-get install dhcp3-server Reading package lists... Done Building dependency tree Reading state ...
0
votes
0answers
20 views

Not able to get the KDE desktop after upgrading from 10.04 to 14.04

I upgraded my laptop from Kubuntu 10.04LTS to 14.04LTS. After upgrade I am not able to get the launchbar, I only see desktop items. After google-ing I tried to re-install unity/compiz but I got this ...
0
votes
1answer
51 views

install phpmyadmin error

I want to install phpmyadmin on Ubuntu 14.04 LTS and type the following commands, but I get the following error message on either one of the following command. Anything I can check the configuration ...
1
vote
0answers
20 views

The package information displayed by Ubuntu Software-Center is 17 days back and counting

While re-opening my Ubuntu 12.04 machine after a 2 weeks vacations, and successfully using the Update Manager to update my applications I see that The package information was last updated 17 days ...
0
votes
1answer
24 views

Frostwire Installation Problem

I've been using Ubuntu for a while now but am not very proficient with some of the more technical stuff. Recently I have had trouble with Skype and Frostwire, two programmes that used to work ...
2
votes
2answers
30 views

Maximum space required for ubuntu repository

I am using Ubuntu 12.10 (Quantal) version and it is at EOL. The repositories for older releases that are not supported get moved to an archive server. These repositories are available at ...
1
vote
0answers
22 views

Upgrade from 13.10 to 14.04 “rolled back”

I've tried to upgrade my Kubuntu from 13.10 to 14.04, through the notification popup appeared in my taskbar. The upgrade process started, it begun to download about 1800 packages, it downloaded ...
0
votes
1answer
34 views

Malformed Line 59 [duplicate]

I've seen a bunch of post about malformed line but I can't understand how they are resolved or what needs to be changed and now I'm getting another error message: (gedit:2708): Gtk-WARNING **: ...
0
votes
1answer
22 views

No Sound on Saved Media Playback

The sound works when playing streaming videos. However, there is no sound when playing saved/downloaded videos using media player or VLC. It started after I ran apt-get upgrade. The system is not ...
0
votes
0answers
48 views

Apt-get and dpkg not working due to mono-complete

After installing the mono-complete package, no matter what I do in apt-get and dpkg, even apt-get -f install and the likes, except for apt-get update, I ALWAYS get the following errors: Setting ...
1
vote
1answer
34 views

apt-get upgrade complains about authentication of packages

I am currently using Ubuntu 14.04.1 server. When issuing a: sudo apt-get upgrade apt-get says: WARNING: The following packages cannot be authenticated This is a fresh install from an ISO that ...
0
votes
0answers
18 views

Encountered a section with no package [duplicate]

I've recently installed ubuntu 14.04. I was quit satisfied with it till yesterday when I couldn't open ubuntu software center. I've received a notification like this: E:Encountered a section with no ...
0
votes
1answer
27 views

The following packages were automatically installed and are no longer required with important libs

The following packages were automatically installed and are no longer required: libopenal1:i386 libsdl-ttf2.0-0:i386 libgconf-2-4:i386 libatk1.0-0:i386 libstdc++5:i386 libpam-winbind ttf-umefont ...
0
votes
1answer
42 views

Dist-Upgrade - LibreOffice dependencies later than required

When I try to update my Ubuntu box, I get this error : dpkg: dependency problems prevent configuration of libreoffice-base: libreoffice-base depends on libreoffice-base-core (= ...
1
vote
0answers
31 views

404 Error for extras.ubuntu [closed]

sudo apt-get install and sudo apt-get update show 404 Error not found. So I checked the file /etc/apt/sources.list and replaced all (xx.)archive.ubuntu with old-releases.ubuntu. Everything works ...
-1
votes
1answer
34 views

Problems compiling scangearmp

I have already installed some missing packages, but i still get that error. Can anyone help me identify what is missing ? Thanks a lot ...
0
votes
0answers
48 views

Unable to install bsddb185, Python library for opening Berkeley DB version 1.85 files on Ubuntu

I am writing a python program that makes use of some legacy Berkeley DB 1.85 files. Unfortunately I am unable to install the bsddb185 Python package, either for Python version 2.x and for Python 3. ...
0
votes
3answers
97 views

dpkg error when using apt-get install

I upgraded to Ubuntu 14.04 from 12.04 and every time I use apt-get install for any package it ends with a bunch of errors about processing some of my latex packages. Including a snippet below: ...
0
votes
0answers
178 views

sudo apt-get update command not working

I'm on Ubuntu 14.04 and I tried running sudo apt-get update but I get the below error: W: Failed to fetch http://ubuntu.tuxuri.com/ubuntu/dists/trusty-security/InRelease W: Failed to fetch ...
0
votes
0answers
51 views

403 forbidden error when I attempt to install an ssh server

I have a problem when I try installing ssh-server on ubuntu 14.04 lts. What I've done: sudo apt-get update ==> succeed. sudo apt-get upgrade ==> succeed. sudo apt-get install ssh ==> failed. ...
0
votes
1answer
23 views

How to write Makefile to package a .so dynamic library that will install all required links

I need help in writing a Makefile that installs my library on Linux FHS. https://www.debian.org/doc/debian-policy/ch-sharedlibs.html#s-sharedlibs-dev says that there should be a link from .so to ...
0
votes
2answers
131 views

Recovering from apt-get upgrade gone wrong due to a full disk

I was performing an apt-get upgrade on an Ubuntu 12.04.5 LTS box that hadn't been updated in a little while and the upgrade failed due to 'No space left on device'. After a little while I worked out ...
2
votes
1answer
36 views

apt-get and aptitude seem to disagree — do I really have broken packages?

If I do aptitude search ~b I get a list of 78 broken packages. But 76 of them aren't even installed (they have a status of pB). How can an installed package be considered broken?? But if I do ...
1
vote
1answer
154 views

Problems with 12.04 LTS to 14.04 LTS upgrade

I decided to upgrade from 12.04 LTS to 14.04 LTS. I used do-release-upgrade. Everything worked. When I run lsb_release -a I get : Description : Ubuntu 14.04.1 LTS Release : 14.04 Codename : ...
0
votes
1answer
35 views

No package 'ncurses' found [duplicate]

I'm trying to install XWiimote and they tell me to run ./autogen.sh in the installation notes . This is the output: zorin@Samsung-NP300E4Z-S03TH:~/Downloads/xwiimote-master$ ./autogen.shlibtoolize: ...
0
votes
1answer
38 views

unmet dependencies when using apt-get, how can I solve it? [duplicate]

When I try to install packages I get this error, what is wrong and how can I fix it? dpkg: aviso: Arquivos da lista de arquivos para o pacote `libisccc60' faltando, assumindo que o pacote não possui ...