Advanced Packaging Tool, the package manager for Debian-based distributions. It is also the most used tool for installing packages in Ubuntu. Questions about using any of the apt tools should use this tag.

learn more… | top users | synonyms (1)

0
votes
0answers
16 views

Prevent vendor change of packages

When you add another repository it can potentially “update” packages of your system with malicious software. On openSUSE I saw that Zypper warns you about “vendor changes” and can effectively prevent ...
0
votes
0answers
24 views

command for re-installing uninstalled packages?

I just removed a package with synaptic. Many additional (30-40) packages got also removed, because they had dependencies to the main package. Now I reinstalled the main package and I simply want to ...
0
votes
1answer
355 views

in Ubuntu 14.04.3 UCK tool,I can't install wine 1.6 or wine1.7 [duplicate]

I can install wine1.7 successfully by following commond,but can't install in uck tool Why is this happening and how can I fix it? $ sudo add-apt-repository ppa:ubuntu-wine/ppa $ sudo apt-get update ...
0
votes
0answers
83 views

Brother MFC 9700 brscan and mfc9700lpr dpkg returned an error code (1) 14.04

I have an Brother MFC9700 and I want to make it scan in ubuntu 14.04. I am able to print to this device (with MFC 9600 driver) but cannot scan. I downloaded and installed the drives below from ...
0
votes
1answer
88 views

Syanptic: Could not download all respository indexes

I've been trying on and off to fix this and I have come to the point where I need to ask for help. The last thing I did was visit here (Update manager: "Could not download all repository ...
0
votes
1answer
40 views

error installing vlc through terminal [duplicate]

E: Could not get lock /var/lib/apt/lists/lock - open (11: Resource temporarily unavailable) E: Unable to lock directory /var/lib/apt/lists/ E: Could not get lock /var/lib/dpkg/lock - open (11: ...
0
votes
0answers
50 views

Trouble with apt-get closing socket prematurely

When running apt-get update the command seem to run without errors, but still the package manager then still can't find packages I want to install, specifically those in the universe part. The same ...
0
votes
1answer
101 views

Apt-get Issues (and random crashes)

I'm running Ubuntu 15.04 (x64, i7, etc.). Everything has been working perfectly for a long time. However, this morning I was watching some videos online (YouTube) when Firefox crashed. I tried running ...
1
vote
1answer
137 views

Problem with libmyodbc - segfault error

I have an issue with libmyodbc as I am not able to connect to the MySQL database that it is pointing to. When I try from isql I get a "Floating point exception (core dumped)" error, and when I try ...
-3
votes
2answers
105 views

Terminal cannot install anything

I hav been using Ubuntu for quite sum time. yesterday i accidentally deleted the ubuntu partition (from windows) and again installed it. im having the following problems I tried 2 install Google ...
1
vote
0answers
90 views

install crashdump on ubuntu 1404

I am following [here] to install crash dump on Ubuntu 1404: sudo apt-get install linux-crashdump However, it throws exception as below: ... unmet dependencies linux-crashdump : Depends: ...
0
votes
1answer
412 views

Unable to locate package libjpeg-dev

I am trying to install libjpeg-dev through the sudo apt-get install libjpeg-dev command on my Ubuntu machine, but keep getting the following error: Reading package lists... Done Building dependency ...
0
votes
0answers
101 views

apt-get update downloads 88+ GB's

So I installed a new Ubuntu 15.04 system. First thing I did was apt-get update user@user-desktop:~$ sudo apt-get update Ign http://us.archive.ubuntu.com vivid InRelease Ign http://security.ubuntu.com ...
1
vote
2answers
187 views

How to tell if a certain package exists in the apt repos? [duplicate]

I am specifically interested in determining whether a 32-bit version of OpenJDK 8 exists in the apt/Ubuntu repos. According to this answer, you can install the 32-bit version of the Open JDK 7 ...
1
vote
1answer
81 views

How to install Brosix secure instant messaging on an Aquaris E5 Ubuntu phone

I have already installed the Brosix .deb app on my Kubuntu 15.04 laptop without any problems. I copied the app to the downloads folder on my Aquaris E5 Ubuntu touch phone, downloaded the terminal from ...
0
votes
0answers
13 views

Update nautilus only? [duplicate]

Can I update only Nautilus in my Ubuntu 14.04? It is really buggy and I've seen that there has been some fixes released to these bugs (eg the copy/paste bug). I'm really reluctant towards doing ...
0
votes
1answer
304 views

How to install bimp for gimp 2.8 on ubuntu?

$ sudo apt-get install libgimp2.0-dev Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have ...
1
vote
0answers
22 views

Error while updating Ubuntu 15.04 [duplicate]

W: Failed to fetch cdrom://Ubuntu 14.04.2 LTS _Trusty Tahr_ - Release i386 (20150218.1)/dists/trusty/main/binary-i386/Packages Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get ...
0
votes
1answer
167 views

Package libgeotiff-epsg is not available and has no installation candidate

I am installing openstreet server on Ubuntu and for that I need to install libgeotiff-epsg package. When I do sudo apt-get install libgeotiff-epsg, it it returning that Package libgeotiff-epsg is ...
1
vote
2answers
151 views

I managed to get stuck with my Nexus 4 Ubuntu Phone, I can't reflash it back to the original ubuntu phone image?

I'm researching development on this phone and downloaded a number of packages using apt-get. It ran out of space and stopped. I can't do an apt-get purge because there is no space left ... I tried ...
-1
votes
1answer
980 views

Can not install steam: E: Unable to locate package

I've ran update and upgrade and are working fine. But when I try sudo apt-get install steam all i get is Reading package lists... Done Building dependency tree Reading state information... ...
0
votes
0answers
298 views

Problem in Installing GFortran in Ubuntu 15.04

I really need to install Fortran compiler for my current work. I decided to install gfortran package in Ubuntu 15.04 by following the steps on this link: ...
0
votes
0answers
6 views

When I try to install an app from the software center I get an error message [duplicate]

Hello Ubuntu community! So ever since I updated Unity to 14.04 I have not been able to install any of the apps from the store. After I click the install button a message pops up that says "you are ...
0
votes
0answers
28 views

Is it possible to exclude a specific source from “apt-get update” command?

It might not seem like an important problem to you, but it is a serious problem to me! The problem is that every time I run apt-get update command, it can't be successfully done because one of the ...
2
votes
0answers
204 views

Error installing Steam on 14.04.03 (missing 32-bit libraries)

I have the Steam Launcher installed (installed via Software Center), when double-clicking the launcher the following is executed in the command window: Steam needs to install these additional ...
0
votes
1answer
135 views

open lock file /var/lib/dpkg/lock - open (21: Is a directory)

When ever i install a new application using terminal command, i get this error E: Could not open lock file /var/lib/dpkg/lock - open (21: Is a directory) E: Unable to lock the administration ...
3
votes
2answers
3k views

Package 'ttf-mscorefonts-installer' has no installation candidate

I am having a Java based web application running in Amazon EC2 Ubuntu server. I use Jasper reports to generate some reports in PDF format. I built these reports using 'Jaspersoft Studio' Now, when I ...
1
vote
0answers
208 views

xz-utils 5.2.1 on trusty: how to compile and re-package? Or ppa available?

I want to compile and use a newer version of xz-utils, in this case version 5.2 as well as create deb-packages to be distributed on different ubuntu (14.04) machines. The recent changes to xz were ...
0
votes
0answers
304 views

Upgrading KUbuntu 14.04.02 to 14.04.03 - Odd error

I'm trying to upgrade an install of Kubuntu 14.04.02 to 14.04.03, but I keep getting the following error that kills the upgrade. I get it both via apt-get upgrade or when doing it from Synaptic. The ...
0
votes
0answers
79 views

I accidently deleted /var folder

I was using terminal and accidently typed sudo rm -r /var. I stopped it, when had noticed, and can not see any errors in daily using. But when I want to install apache, nginx or something else. I got ...
1
vote
1answer
148 views

Skip updating certain updates in apt-get

A couple of months ago I started following tutorials about updating to the latest stable version of the Linux kernel for Ubuntu -which is currently 4.0.9. The updates where flawless and I noticed my ...
0
votes
0answers
200 views

Error while installing packages (for Virtual Box builds)

I am trying to install the following packages - Linux Packages (Website is down for some reasons. Here is the PDF copy of the website - Virtual Box Build Instructions) Here is the code I'm trying to ...
2
votes
0answers
533 views

Install packages from LTS Hardware Enablement Stack for Ubuntu 14.04.3 has unmet dependancies

I was able to install the new kernel,3.19, however, when I try to get the new packages for the hardware enablement stack and attempt this command sudo apt-get install --install-recommends ...
1
vote
0answers
152 views

apt-get and Software Center tries to remove core packages

Recently(before I got Ethernet wired on 12.04.01) I tried to install build-essentials and its dependences through .deb files, and failed ultimately so I gave up. Now, I tried to apt-get it now that I ...
1
vote
1answer
200 views

Graphics Driver installation problem

I have Ubuntu 14.04.02 installed on my computer. I wanted to install AMD graphics driver file fglrx_15.200-0ubuntu1_amd64_ub_14.01.deb and i tried the command : sudo dpkg -i ...
1
vote
1answer
134 views

Problem updating i3

I have a problem with updating i3-wm When I type i3 --moreversion 2>&- || i3 --version I get Binary i3 version: 4.7.2 (2014-01-23, branch "tags/4.7.2") © 2009-2013 Michael Stapelberg ...
0
votes
1answer
226 views

can't install wine ubuntu 14.04.2 64 bit

First, sorry because my bad English. I try many ways to install wine on my laptop but have no luck Here is my error log The following packages have unmet dependencies: ...
0
votes
0answers
23 views

Polarssl/sha1 excist failed

Running ubuntu 14.04 on virtual box. Trying to build this oonf git and I got this error when doing the 'cmake ..' command. Have already installed the libtomcrypt-dev so I do not know where this ...
0
votes
1answer
343 views

dpkg: error processing archive with texmaker

I am trying to install the latest version of texmaker, by following this answer. It failed and I tried some solutions posted on the internet like this, but with no luck! Check my output: ...
1
vote
2answers
159 views

Unable to locate package libtomcrypt-dev

I can't seem to find this package when doing a simple apt-get install libtomcrypt-dev, the error I get is unable to find the package libtomcryp-dev. Version I use is 14.04.02 I need it for my build, ...
1
vote
1answer
77 views

Apt-get upgraded package from 32bit to unsupported 64bit - why and how to revert?

Recently the repository of qtox had to change its domain and the new one only contains only 64bit builds at the moment. However, I'm on 15.04 32bit and can't run any 64bit software. Now when I last ...
3
votes
1answer
1k views

“E: Unable to correct problems, you have held broken packages” when trying to install a package. Nothing has worked from other threads

The Problem I am trying to install Dolphin Emulator but every time I try it gives me an error. Anything I try doesn't work including many other thread's solutions. sudo apt-get install dolphin-emu ...
0
votes
0answers
188 views

How to safely remove the gnome desktop and return to Unity?

I've installed the gnome desktop env on my ubuntu 15.04 version. Now I want to remove it completely! Can someone give me the list of items to be removed using apt-get remove to remove gnome? I used ...
0
votes
1answer
435 views

407 Proxy Authentication Required when trying to install a package but there's no proxy

Following these instructions http://docs.mongodb.org/master/tutorial/install-mongodb-on-ubuntu/ of how to install mongodb, I got an error: $ sudo apt-get install mongodb-org [sudo] password for ...
2
votes
1answer
58 views

When trying to build the OONF package for DLEP implementation there occurs a error with tomcrypt.sh not being found, how do I install tomcrypt?

When trying to build the OONF package onto my ubuntu for the latest dlep implementation it give me this error: #include polarssl/sha1.h it reffers to the tomcrypt.h who isn't there, I can't seem to ...
2
votes
0answers
63 views

How should I arrange a test and production mirror of Ubuntu package repositories?

I want to be able to closely standardise my Ubuntu 14.04 installations, there's a likelihood that the number of installations I have to complete will rise dramatically soon. I also want to be able to ...
0
votes
2answers
604 views

What does status pi of package mean in aptitude?

Packages can be searched and listed using the command aptitude search foo. The status of these packages are listed in the leftmost column. The values of these status is explained in the Aptitude ...
1
vote
0answers
189 views

“Unable to correct problems, you have held broken packages” and downgrading packages?

I'm trying to install M64Py for Mupen64Plus, but this is the result: ➜ ~ sudo apt-get install M64Py Reading package lists... Done Building dependency tree Reading state information... Done Some ...
1
vote
2answers
744 views

What is wrong with apt-get?

I can see and apt-get in /usr/bin/: gradinafrica@host:/usr/bin$ ls -l apt-get -rwxr-xr-x 1 root root 178608 Apr 20 2012 apt-get But when I try to run it, I get gradinafrica@host:/usr/bin$ apt-get ...
0
votes
3answers
294 views

How do I clear the apt-get remove list?

apt-get upgrade shows that a package is supposed to be removed: gradinafrica@host:~$ sudo apt-get upgrade [sudo] password for gradinafrica: Reading package lists... Done Building dependency tree... ...