Advanced Packaging Tool, the package manager for Debian-based distributions. It is also the most used tool for installing packages in Ubuntu. Questions about using any of the apt tools should use this tag.

learn more… | top users | synonyms (1)

1
vote
0answers
134 views

Unable to install VLC on Ubuntu 15.10

I upgraded to 15.10 from 14 a month or so ago and ended up losing VLC in the process. Now when I attempt to install VLC $ sudo apt-get install vlc Reading package lists... Done Building dependency ...
1
vote
0answers
38 views

Apt-get cannot find version firefox=41.0+build3-0ubuntu0.14.04.1

In another box I have firefox 41.0+build3-0ubuntu0.14.04.1 installed: apt-cache policy firefox firefox: Installed: 41.0+build3-0ubuntu0.14.04.1 I'm trying to mirror the environment so I tiried ...
1
vote
0answers
100 views

Updated kernel to mainline (4.3.3), but apt-get upgrade keeps downloading headers & image for 4.2

I have a Surface Pro 2 running ubuntu, and prior to kernel 4.x it's been quite problematic (wifi/trackpad/screen etc). I've been updating my kernel to mainline, first 4.0, then 4.2 and more recently ...
1
vote
0answers
63 views

Ubuntu Software Center disappeared. Reinstalling it doesn't work

I'm a newbie to Ubuntu, I have 15.10 installed but Software Center disappeared. I tried to run this in terminal: sudo apt-get install software-center But Im getting this error:
1
vote
0answers
64 views

Unable to fix unmet dependencies ubuntu server

i am not able to install some packages, i got this error, i already tried all clean and -f options with apt-get. also tried this Unable to fix unmet dependencies but it did not work for me. Running ...
1
vote
0answers
47 views

Remove specific packages from internal apt repository

I have created an internal apt repository using apt-mirror. I need to remove only certain packages (source, lucid) from the repo. I have attempted to use the clean.sh script to do this, but it only ...
1
vote
0answers
578 views

What is wrong with my apt-get update?

I am trying to install libssl-dev but when I use apt-get update it throw a bunch of erros in some links. Can someone help me? How can I fix this? I installed ubuntu 15.04 and update it to 15.10. Ign ...
1
vote
0answers
88 views

What does dpkg --auto-deconfigure actually do?

I'm trying to replace Nginx with a version that has the PageSpeed module compiled in, and I've made my own .deb file for this. The first step is to uninstall the old nginx. However, when I try apt-get ...
1
vote
0answers
602 views

Install bluetooth or bluez-utils packages fails using bluez-5.37 (or bluez-4.101)

I have compiled bluez 5.37 from sources, and installed it. I would like to install the package bluez-utils, which depends on bluez. sudo apt-get install bluez-utils Reading package lists... Done ...
1
vote
0answers
46 views

apt-get update: “GPG error: Clearsigned file isn't valid, got 'NODATA'”

after running 'sudo apt-get update' I see this in terminal:
1
vote
0answers
29 views

How do I fix/undo sudo aptitude safe-upgrade

So I'm fighting with NodeBB -- and found that nginx was advised. However I thought I needed the most updated version (when in fact 1.4.x is recommended). I couldn't get the rerouting working on 1.8 ...
1
vote
0answers
44 views

apt-get update is not working : non of answer is able to solve issue

Last two days I struggling to install VIM or build kernel. But hard luck. Issue is apt-get update not working. I had read almost all post on this website but nothing is working. I had done many ...
1
vote
0answers
56 views

Broken apt-get upgrade

I am running Ubuntu 14.04 and attempting a apt-get upgrade which is currently failing with the below error. I am alittle bit stuck. Processing triggers for initramfs-tools (0.103ubuntu4.2) ... ...
1
vote
0answers
30 views

How to recover from apt-get remove ubuntu-desktop^?

I was trying to convert ubuntu desktop to ubuntu server and did: sudo apt-get purge ubuntu-dektop^ The system startted to remove packages and hanged at the following messages: Removing ...
1
vote
0answers
58 views

Apt-get commands won't work

On my ubuntu 15.04 server the apt-get command won't work. I think it has something to do with perl. Does anyone know how to fix it? I've already tried apt-get -f install, but that outputs the same ...
1
vote
0answers
1k views

Python - pip pip2 pip3 pip3.5 packages are installed but cannot be imported in any Python session

As I am using Xubuntu I thought perhaps this was a better forum than Stackexchange for some questions relating to pip and Python Today I have encountered troubles with pip and Python. For some reason ...
1
vote
0answers
228 views

unmet dependencies while trying to install phpmyadmin on LAMP stack

I am trying to install phpmyadmin along with LAMP stack but when I write to the terminal sudo apt-get install phpmyadmin I get this errors : Some packages could not be installed. This may mean that ...
1
vote
0answers
67 views

Unmet Dependencies: libapache2-mod-passenger

I need to insatll libapache2-mod-passenger on apache2.4 root@server:~# apt-get install libapache2-mod-passenger Some packages could not be installed. This may mean that you have ...... The following ...
1
vote
0answers
56 views

Package gvfs-common is not configured yet?

I am having trouble getting into Synaptic Package Manager. When I run sudo dpkg --configure -a as it suggests I get: dpkg: error processing package gvfs-common (--configure): package is in a very ...
1
vote
0answers
61 views

Not able to ping google and cannot get apt-get update

I have set my network to NAT because this is my home internet that I am using. I am not able to access my college internet to get the apt-get update package hence using home internet. Below is my ...
1
vote
0answers
74 views

libldap & dpkg errors

I seem to have a problem with my install after removing Wine 1.8: [installArchives() failed: (Reading database ... (Reading database ... 5% (Reading database ... 10% (Reading database ... 15% ...
1
vote
0answers
149 views

apt-get fails behind corporate firewall - Does the network require authentication

I am trying update and install additional packages to my new Ubuntu Server 14.04 - This is installed on a VM environment inside a corporate firewall. However I cannot get apt-get to work. Here is what ...
1
vote
0answers
62 views

gvfs-backends unmet dependency

I by mistake un-installed ubuntu software center and gvf packages, when i am trying to install gvf packages i get this error. I ran sudo apt-get install gvfs-backends Reading package lists... Done ...
1
vote
0answers
43 views

How do I resolve the issue: E: Package 'openrc' has no installation candidate?

I'm getting the following error when I try apt-get install openrc Package openrc is not available, but is referred to by another package. This may mean that the package is missing, has been ...
1
vote
0answers
51 views

UBUNTU: sudo apt-get update HTTPS redirect

The sudo apt-get update command is failing because the URL present in /etc/apt/sources.list.d/cloudera-cdh5.list is having https instead of http. So I have introduced a command to replace the https ...
1
vote
0answers
30 views

How to properly manage PPAs just from the command-line

What are the recommendations for managing other repositories and PPAs without the help of Software and Updates GUI. How to know if a repository/PPA already, - exist - enabled or - disabled ? How to ...
1
vote
0answers
28 views

Installed gnome-shell and then removed it and went back to unity, running apt-get autoremove threatens to uninstall these packages.

At first I accidentally ran sudo apt-get remove gnome instead of gnome-shell. This made the computer run into a boot loop. I got it fixed by installing gnome-desktop again. I removed the gnome-shell ...
1
vote
0answers
14 views

Problem with apt daemon. Apps disappeared, can't run any application, how do I fix it?

When a run synaptics package manager for example, I get W: Not using locking for read only lock file /var/lib/apt/lists/lock W: Not using locking for read only lock file /var/lib/dpkg/lock E: ...
1
vote
0answers
82 views

apt-get dist-upgrade problem

When i try to "apt-get dist-upgrade" i always receive the following error: The following packages have unmet dependencies: linux-virtual : Depends: linux-image-virtual (= 3.2.0.87.101) but ...
1
vote
0answers
40 views

Apt-get/Terminal can't detect CD in drive when trying to install

I can't find anything online that is relevant to my issue! I've checked around the answers here, and have referenced google and other ubuntu help sites, and can't find this specific problem or ...
1
vote
0answers
311 views

Mysql 5.6 not installing/removing/running on 15.10

I have tried to purge mysql and then reinstall it (sudo apt-get purge mysql-server mysql-client mysql-common mysql-server-5.6 ), but it does not work. It looks like a dependency issue. Here is the ...
1
vote
0answers
201 views

Ubuntu 15.10 The installation or removal of a software package failed

I'm using ubuntu 15.10 and when I try to install application from software center after installation I got this error.when I click Ok I can see that application on my pc but I can't open it.Help me ...
1
vote
0answers
99 views

“Error: BrokenCount > 0” after upgrading packages

After just running: sudo apt-get dist-upgrade Obviously running the update one first, I got this output: Reading package lists... Done Building dependency tree Reading state information... ...
1
vote
0answers
220 views

unable to get “sudo apt-get update” to work

I am very new to ubuntu.I am behind secure proxy too. when i try to run sudo apt-get update i get the following error.Does anyone know how to start fixing it? ...
1
vote
0answers
33 views

Replace apt package with compiled vers

I currently have openssl 1.0.1f installed from apt. I need to install 1.0.2d, which I have downloaded and compiled. What is the suggested way of installing a compiled package when one exists in the ...
1
vote
0answers
18 views

Recompiling unity from source

For some reason I have to modify some files on the source of unity. To get the source and its dependencies I had issued apt-get build-dep unity and apt-get source unity. To test whether the source ...
1
vote
0answers
447 views

ERROR: could not access file “$libdir/plpython2”: No such file or directory

I am running postgresql 9.4 ("PostgreSQL 9.4.4 on x86_64-unknown-linux-gnu, compiled by gcc (GCC) 4.1.2 20070626 (Red Hat 4.1.2-14), 64-bit" ) when I am trying to create language in postgres SQL : ...
1
vote
0answers
69 views

Getting a package not found exception even after its installed

I am getting below error when I do a ./configure. configure: error: Package requirements (gio-2.0 >= 0.23.0 libgcab-1.0 >= 0.1.10 uuid >= 1.41.3 ...
1
vote
0answers
131 views

Cannot get in gnome desktop after upgrade 15.04 to 15.10

I can not log in at tty1 after reboot; system hangs. Also after dpkg --configure -a I get: error getting authority: error initializing authority:Could not connect:no such file or directory ...
1
vote
0answers
50 views

Is it still possible to do distribution upgrade using apt-fast?

Over the past several upgrades, I've used the method in this thread: How to perform a distribution upgrade using apt-fast? However, when I've tried to use this method to upgrade to Wily Werewolf ...
1
vote
0answers
43 views

Why can't I match using package name in /etc/apt/preferences?

I'm trying to pin some packages from the google chrome repo. I can't figure out why I can't pin packages by name. When I run apt-cache policy google-chrome-beta I observe that the first of the ...
1
vote
0answers
130 views

DPKG Issues. Hangs, and won't let me run any commands

Ubuntu randomlly decided to install this huge batch of updates today and I let it. It froze however midway. I gave it an extra hour with no progress at all so I killed it and forced a hard restart. ...
1
vote
0answers
110 views

apt-get upgrade fail for Unmet dependencies after gcc compile

On my headless Ubuntu 14.04.3, I need to use the last release of gcc compiler (version 5.2.0), so I recompiled locally gcc downloading source an doing a checkinstall ( thanks to helpfull answer here: ...
1
vote
0answers
331 views

Can't install gcc-4.9-base:i386 on Ubuntu 14.04

I've been running into some problems while trying to install wine and steam on Ubuntu 14.04, and they all seem to stem from the gcc-4.9-base:i386 package. When I run sudo apt-get install ...
1
vote
0answers
21 views

Update LAMP stack

I have installed a LAMP stack using sudo apt-get install lamp-server^. I would like to update its components versions to the latest. In particular PHP's version. Is it possible to do via the default ...
1
vote
0answers
51 views

Unable to Update or Install new apps (Bug #993407)

My issues started earlier today when I ran the Software Updater on my computer which is running the 64-bit version of Ubuntu 14.04. The update failed and redirected me to the bug tracker for Bug ...
1
vote
0answers
159 views

Cannot install old version of chrome (conflict with ffmpeg chrome codec)

Ubuntu version: Ubuntu 14.04.3 LTS (xubuntu) I trying to install old chromium because of missing SSE2 instructions. I was installed the new version of chrome before. I removed it. I tried to start ...
1
vote
0answers
20 views

Errors from a particular source when I update (in any of the package managers)

When I update (using any of these, apt-get, synaptic or Ubuntu Software Center) I get several errors. First is this warning: Failed to fetch http://repo.mysql.com/apt/ubuntu/dists/utopic/InRelease ...
1
vote
0answers
54 views

Does optional add-ons automatically install on apt-get install command?

When I open the Ubuntu Software Center, on some software pages I see under the "Optional add-ons" some additional packages(?) that are automatically selected for install. The question is - when I run ...
1
vote
0answers
207 views

Restore Python installation to default plus apt package dependencies

I have played around a lot with my Python installations (2 and 3) and installed a bunch of packages, some using apt-get, but most using pip. I have also upgraded many apt-installed packages with pip ...