Advanced Packaging Tool, the package manager for Debian-based distributions. It is also the most used tool for installing packages in Ubuntu. Questions about using any of the apt tools should use this tag.

learn more… | top users | synonyms (1)

1
vote
1answer
89 views

How to install programs from a .deb file, like apt-get install supertux

I am an maintainer for a lot of computers in my town running ubuntu 12.04 and 14.04 with mate desktop, this is to help people just having a computer that just works :), and i cannot make them all do ...
0
votes
1answer
27 views

Update Error on my Ubuntu 14.04 [duplicate]

I am getting this error while my update never completed fully. W:Failed to fetch http://ppa.launchpad.net/iaz/battery-status/ubuntu/dists/trusty/main/binary-i386/Packages 404 Not Found , E:Some ...
0
votes
0answers
11 views

apache2 can't open config file

apache2 has come preinstalled on the VPS that I am using. However, upon using the apache2 command to start it in the terminal (PuTTY), it reported that it couldn't open the configuration file. Using ...
0
votes
0answers
14 views

Same error message at end of every update run

Each and every time that I run update, the last 4 lines read as follows: Reading package lists... Error! E: Encountered a section with no Package: header E: Problem with MergeList ...
-1
votes
0answers
11 views

Unable to install mysql-server-5.6 on ubuntu 14.04 [duplicate]

when i install mysql server on Ubuntu 14.04 san@san-desktop:~$ sudo apt-get install mysql-server-5.6 Output: E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable) E: ...
0
votes
1answer
29 views

how to check package version before install

Im trying to install Apache 2.4.12 or apache2.4 at least. I see some listings for apache2.2 in the apt-cache, but I don't see apache2.4. How can I verify the actually version that sudo apt-get ...
0
votes
1answer
46 views

Can't install software from repository [duplicate]

I want to play games from mini clip website, tried it in Firefox. Even though it has flash player installed through software center, the games are not working. I tried chromium, but was unable to ...
0
votes
3answers
68 views

Cannot install WGET in Ubuntu 12.04.5 lts

What do you think are the reasons that causes this error? The program 'wget' is currently not installed. You can install it by typing: apt-get install wget If I type apt-get install wget the ...
-1
votes
1answer
33 views

accidently removed python using purge

i accidently performed sudo apt-get purge python2 now my terminal wont show the colors and many libraries have been gone. Cant i revert back the changes even sudo apt-get build-essentials is ...
1
vote
0answers
14 views

Software Updater not detecting all upgrades [duplicate]

This happens every so often, I run this command in Terminal (after running sudo apt-get update): sudo apt-get upgrade And I get an output such as (this is what I got today): Reading package ...
0
votes
0answers
19 views

How to submit package to science universe repository?

I am one of the authors of an open-source (GPL) scientific package that I would like to make available to Ubuntu users through the science repository. Is there a step-by-step guide on how this is this ...
0
votes
1answer
21 views

Can Stand-alone deb packages be updated?

I've downloaded and installed a deb package of Ubuntu Tweak from its website: http://ubuntu-tweak.com/. Is there a way to watch for updates for the package like packages which are in a repository?
0
votes
1answer
12 views

install avr-libc

I'm using Avr controller for programming into Ubuntu, for that I'm installing library using following command, which gives error asphalak@asphalak-HP-Pavilion-11-x360-PC:~$ sudo aptitude install ...
0
votes
1answer
65 views

Unable to install packages using apt-get (Strange error)

prathya@Shriyansh:~$ sudo apt-get install i8kutils [sudo] password for prathya: Reading package lists... Done Building dependency tree Reading state information... Done ...
-1
votes
0answers
34 views

install libav version 9 in ubuntu14.10

Ubuntu 14.10 uses libav api version 11 but i want to manually install the libav version 9 because the version 11 is not supported by opencv so how do i remove the old libav and all the dependencies ...
1
vote
0answers
31 views

Install package into virtualenv using apt-get

According to this answer, apt-get installs packages system-wide (from canonical), and only pip can install packages into a virtualenv (from Pypi). However, I need to install a package into a ...
0
votes
0answers
171 views

VirtualBox for Ubuntu 14.10 Kernel driver not installed (rc=-1908)

I have this error message: Kernel driver not installed (rc=-1908) The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. ...
0
votes
0answers
64 views

libperl-dev fails to install because it can't find dependencies

I'm trying to install libperl-dev onto a server via chef but the server fails to install with the following error message: Err http://gb.archive.ubuntu.com/ubuntu/ precise-updates/main libc-dev-bin ...
0
votes
0answers
25 views

Ubuntu 14.04 unmet dependencies is not being resolved

I am completely new to ubuntu and I fell in love with it. I am completely happy with its features. But The problem is I've got some red icon in the task bar that is showing the following message: ...
0
votes
0answers
53 views

how kernel gets upgraded on ubuntu 14.04 installation?

There are linux-generic and linux-image-generic packages, that track latest linux-image package as their dependency. Those packages could be used to update kernel automatically but they aren't ...
0
votes
2answers
55 views

apt-get clear previously failed install

so, everytime I try installing a package using apt-get it is also downloading previous failed install (previously I install dropbox). how to remove/forget latest failed install? Setting up ...
1
vote
0answers
339 views

Unknown error: '<class 'KeyError'>' (“The cache has no package named wine-staging-i386”)

There is an error sign on my Ubuntu panel which states the error given in the title. I used sudo apt-get update but it gave me no errors. However the error sign persists. How do I fix this?
1
vote
0answers
29 views

Cannot remove openjdk without having an older version installed, how can I do so?

I am running Ubuntu 14.04.1 64-bit with Oracle Java installed, hence I would like to uninstall openjdk, but when I try to uninstall it via the command line I get the following output: ~$ sudo apt-get ...
0
votes
1answer
165 views

Can't Install wine without dependencies

Followed this guide to install wine. After adding repository installed wine using: sudo apt-get install wine1.7 But I get the following error: The following packages have unmet dependencies: ...
-1
votes
0answers
80 views

When i try to install Google Chrome (i386 64 bits) it ask me to remove pidgin-indicator. How can i get both running?

When i installed in first time pidgin-indicator from webup8 PPA (i have Ubuntu 14.04 64 bits), i didnt noticed that it removed me Google Chrome. When i realized that, i tried to install again Chrome, ...
2
votes
0answers
13 views

How can I use equivs-build to build packages that can be installed on older versions of Ubuntu?

I have several versions of Ubuntu installed, including 14.04 and 10.04. When I build packages using equivs-build on 14.04, it generates .debs that contain .xz-compressed data. The version of dpkg on ...
1
vote
0answers
46 views

Ubuntu 14.04 Installation of libdrm-dev

I am trying to install mesa-common-dev (sudo apt-get install mesa-common-dev), however I get the following message: mesa-common-dev: Depends: libdrm-dev(>= 2.4.52) but will not be installed. ...
0
votes
0answers
41 views

update-apt-xapian-index and chrt

update-apt-xapian-index can be an annoyance on older computers. Are there any bad side-effects known when changing scheduling priority to SCHED_BATCH in for example apt-apian-index with chrt -b ...
1
vote
1answer
71 views

Apt-get fails to fetch inside an LXC container

I have an Ubuntu 14.04.1 LTS server that's running LXC containers. The containers run Ubuntu 14.04.1 too. Network config of host is pretty standard, static IP, ISP's DNSes (IP1/IP2) plus google's : $ ...
1
vote
1answer
71 views

When to apt-get upgrade

It seems that every time I install software an apt-get update is helpful but when exactly is an apt-get upgrade necessary? Or perhaps, when is it helpful?
0
votes
0answers
33 views

Software Updater & apt-get upgrade not working

So i bought a new laptop and it had Ubuntu 12.04 installed in it.Since i saw info about the new versions i decided to update to 14.04 following the procedures in the forum. After the upgrade my ...
0
votes
1answer
49 views

Connect cluster controller to the region controller (MaaS)

I'm trying to build a MaaS cluster and this is what I've done so far: Region Controller install ubuntu 14.10 configure interfaces configure dns apt update apt upgrade apt install ...
1
vote
1answer
53 views

Can't install/remove packages - update-initramfs with little space on /boot

When I try to remove any package, I get (Reading database ... 604878 files and directories currently installed.) Removing bootchart (0.90.2-8ubuntu2) ... [skipped] update-initramfs: Generating ...
0
votes
0answers
23 views

The ISA Server requires authorization to fulfill the request

I installed Ubuntu 14.10. My network requires proxy and authentication to connect to the internet. I edited the file /etc/apt/apt.conf to this value Acquire::http::proxy ...
0
votes
0answers
22 views

ConVirt won't run. Requirement.parse('SQLAlchemy==0.5.6'))

ConVirt 2.5 on Ubuntu Precise won't run. Tail line of the error is: File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 588, in resolve raise VersionConflict(dist,req) # XXX put more ...
1
vote
0answers
75 views

rsyslogd hangs upon apt-get 14.04

If I do any apt-get install, it hangs permanently (have to CTRL-Z, CTRL-C does nothing) and then corrupts dpkg (have to run dpkg --configure etc) and I have to kill all rsyslog related processes. I've ...
3
votes
1answer
126 views

Why shouldn't I use apt-get install --qq without a no-action modifier?

From man apt-get: Note that quiet level 2 implies -y; you should never use -qq without a no-action modifier such as -d, --print-uris or -s as APT may decide to do something you did not expect. ...
0
votes
0answers
53 views

Synaptics Package manager and Software Manager crash

Hello when I try to open Synaptic Package Manager in Ubuntu 14.10 this error message appears: E: Type ‘apt-get’ is not known on line 1 in source list /etc/apt/sources.list.d/mono-xamarin.list E: The ...
1
vote
1answer
71 views

“Oracle JDK 7 is NOT installed” error even though JDK is installed

I installed Java Jdk manually by downloading jdk-7u40-linux-x64.tar.gz and following this link. When I check its version, it's OK: user@mylaptop:~$ java -version java version "1.7.0_40" Java(TM) SE ...
0
votes
0answers
43 views

Updating through apt-get in terminal versus the Software Center

There have been several times in my memory that I will be prompted via the Software Center GUI to download system and application updates. It tells me the size of the total updates that will be ...
0
votes
3answers
128 views

sudo apt-get -f install fails

I think I have a problem with mixing different repository packages, but I can't uninstall any of the conflicting packages. Any suggestions? gunnar@gunnar-VirtualBox:~$ sudo apt-get -f install Reading ...
0
votes
0answers
27 views

Why does this fail to make my postfix configuration step non-interactive?

I have a bash script to automate configuration of new Ubuntu systems. It works, except that postfix's process installation persists in bringing up a menu-based interface. I followed the answer given ...
0
votes
1answer
40 views

Malformed line in the source list /etc/apt/sources.list (dist parse), don't let me use update manager? [duplicate]

Here is the error hope i can get some help, i show you the update manager and the line of the error, if you need something else just ask for it. E: Malformed line 59 in source list ...
2
votes
1answer
71 views

SQLite 3.8.8 in Ubuntu 14.04 via apt-get

How to install the SQLite 3.8.8 in Ubuntu 14.04 via apt-get? The default installation is for 3.8.2. Thanks, Christian
0
votes
1answer
63 views

14.10 apt-get unable to locate package libopenal-dev in chroot

I'm trying to develop Torque2D on a 32-bit chroot, as there's no 64-bit version as of yet, and it requires libopenal-dev, among other packages to compile properly. I've tried compiling it without it ...
0
votes
0answers
42 views

problems with apt-get upgrade

After the last update of my server i got this error message: udev (204-5ubuntu20.9) wird eingerichtet ... * udev requires hotplug support, not started ...fail! invoke-rc.d: initscript udev, ...
0
votes
1answer
55 views

Cannot purge nvidia-304 - DKMS issue returns a removal error

sudo apt-get purge nvidia-304 Reading package lists... Done Building dependency tree Reading state information... Done The following packages were automatically installed and are no ...
0
votes
0answers
17 views

How can I modify the Ubuntu-12.04 Server ISO to include non-default kernel and headers (lts-raring in my case)

I have an ISO which I am customizing via preseeding. I am able to customize it from the preseeding point of view but I want to do a little more. The ISO image I am using is the standard ...
0
votes
1answer
32 views

Apt-get autoremove after I almost broke Ubuntu

Ok, so I wanted to uninstall wine, and of course I managed to uninstall 140 other packages with it using this command: sudo apt-get remove wine* I know, I should have googled it first, but the ...
0
votes
1answer
42 views

atlas lib symlink stuck in master-slave deadlock

after a few rounds of installs and removes, trying to get Atlas and OpenBLAS to be friend with each other, i have this update-alternatives error, which i think is really a master-slave deadlock, ie. ...