Advanced Packaging Tool, the package manager for Debian-based distributions. It is also the most used tool for installing packages in Ubuntu. Questions about using any of the apt tools should use this tag.

learn more… | top users | synonyms (1)

0
votes
1answer
37 views

Learning more things about dependecies and repositories

A month ago I moved from Windows to Ubuntu. While using Ubuntu I notice some things about installing software. I've read some installation guides about installing software, and been curious about two ...
0
votes
1answer
18 views

apt-get: error while loading shared libraries: libstdc++.so.6:

cannot open shared object file: No such file or directory This started after rebooting the server (sudo reboot). I am running Ubuntu 14.04 on AWS AMD64 server. Have searched high and low and ...
0
votes
1answer
33 views

Force resolve a dependency conflict apt

# apt-get install -reinstall xserver-xorg-input-all The following packages have unmet dependencies: gnome-control-center : Depends: libcheese-gtk23 (>= 3.4.0) but it is not going to be installed ...
0
votes
0answers
10 views

Screenshots for self hosted debian repos?

According to this link, you can add screenshots to a debian hosted package, but what about packages in repos that you host yourself and manually add to your list of sources? I've never actually run a ...
7
votes
1answer
5k views

How to upgrade PHP version to the latest stable released version? Let's say how to upgrade from PHP 5.5.19 to PHP 5.5.20?

I'm using a system running on Ubuntu 12.04 LTS 64-bit OS. I'm currently using following PHP version on this machine: Command used to get the below info at terminal : php -v Details I got are as ...
1
vote
1answer
64 views

Dependency is not satisfiable: libglibmm-2.4-1c2a (>= 2.42.0)

Updated my mysql to 5.6 and as a consequence broke my preexisting mysql workbench. Trying to reinstall the newest mysql workbench, from both the Software Manager and the latest .deb from their ...
0
votes
2answers
93 views

APT totally broken

i am on Ubuntu 14.04 and my apt is totally broken. The problem started with grub-pc package and now continues , along with that package, with libuuid1:amd64 package. intsallation of libuuid1:amd64 ...
3
votes
1answer
287 views

“apt-get update” gives many [Ign] errors - is that a problem?

I just ran sudo apt-get update once again and I thought that there are many lines starting with Ign instead of Hit in the output. I wondered what it means and researched on Ask Ubuntu and Super User, ...
1
vote
1answer
28 views

Problem with apt-get update (error) [duplicate]

I have problems with apt-get update once in a while. This error is shown sometimes I try to run this command: sudo apt-get update E: Could not get lock /var/lib/apt/lists/lock - open (11: Resource ...
-2
votes
0answers
11 views

Oracle 10G edition support in ubuntu? Why this eror occurs any solutions? [duplicate]

W: GPG error: http://oss.oracle.com unstable Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 2E2BCDBCB38A8516
0
votes
1answer
50 views

how to install bokken 1.8 or latest in ubuntu 14.04

i am trying to install bokken 1.6,1.7,1.8 in ubuntu 14.04 same error accer plz help me error is here najeeb@najeeb:~$ sudo apt-get install bokken [sudo] password for najeeb: Reading package ...
0
votes
1answer
25 views

E: dpkg was interrupted, you must manually run sudo dpkg --configure -a to correct it [duplicate]

I am trying to run following command $ sudo apt-get install cron but it gives following error E: dpkg was interrupted,
3
votes
1answer
27k views

How do I install gfortran?

I am trying to install gfortran in my computer with Ubuntu 12.04 by using these commands, sudo -i apt-get update apt-get install gfortran but I found the program saying "unable to locate package ...
1
vote
2answers
6k views

How to solve “Wrong sources.list entry or malformed file”?

I'm a new user of Ubuntu 13.10 so far so I don't have too much technical expertise. I recently tried to resolve a Skype installation issue and added some ppa involving binary-1386. Every time when I ...
0
votes
1answer
34 views

Why does the Software Updater allow me to update the package list without authentication unlike in Terminal? [duplicate]

I have found recently that when running the Software Updater GUI it automatically, without asking for authentication, updates the local package list, but when running the equivalent in Terminal ...
1
vote
1answer
52 views

apt-get really slow but no internet problems

I'm running into an issue where running apt-get update and apt-get install are really slow. It's relatively quick (~600 KB/s) for the first 5 seconds but then slows down to 4 KB/s or less. I don't ...
-1
votes
0answers
19 views

Unable to run Java in Ubuntu 14.04 using alien with .rpm file [duplicate]

I have installed jre1.8 and jdk1.8, using alien with .rpm extensions. Both are in /usr/java. But when i use java -version or javac -version command. it displays The program 'javac' can be found in ...
1
vote
1answer
4k views

Unable to correct problems, you have held broken packages while installing nfs server?

I am trying to install nfs server on my Ubuntu 12.04 machine but everytime it is giving me an error like this - david@machineA:~$ sudo apt-get install nfs-common nfs-kernel-server Reading package ...
5
votes
5answers
469 views

Unable to insall libgtk2.0-dev on ubuntu 12.04

I am using opencv 3 on ubunut 12.04 and while displaying an image the error message asks me to build the library with libgtk2.0-dev. I tried sudo apt-get install libgtk2.0-dev but I get the following ...
0
votes
0answers
28 views

APT complaining about no space left on device, although there is plenty

I'm having an issue with an Ubuntu server. It currently is not happy with APT for some reason and is giving me the following error: SystemError: E:Could not open file /var/cache/apt/srcpkgcache.bin - ...
0
votes
1answer
3k views

Installation:Troubleshooting webmin dependencies

I am having a dependency problem dpkg installing webmin 1.510 (deb) package on Ubuntu 10.04. I do not know where to look to find info about what dependencies are needed.
91
votes
24answers
159k views

How to fix Duplicate sources.list entry?

I keep getting this warning whenever I try to run sudo apt-get update. W: Duplicate sources.list entry http://archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages ...
-1
votes
3answers
66 views

Software-center crashed and problem with apt-get install -f

My software center on ubuntu 14.04 crashed. Some sources say that i have to do sudo apt-get purge software-center. but, when i run it there is some error, one of them is E: Unmet dependencies. ...
0
votes
0answers
24 views

APT-GET behind a proxy with DIGEST Authentication

I've edited apt.conf, applied "system wide configuration", edited /etc/enviroment, etc... but out of luck. My company is running a Squid proxy with DIGEST authentcation, which I think APT doesn't ...
2
votes
1answer
6k views

apt-get package is not available but is referred to by another package - but cannot find that package

When I try to install a package with apt-get install, I'll occasionally see a message of the form Package somePackage is not available, but is referred to by another package. This may mean that the ...
0
votes
1answer
135 views

in Ubuntu 14.04.3 UCK tool,I can't install wine 1.6 or wine1.7 [duplicate]

I can install wine1.7 successfully by following commond,but can't install in uck tool Why is this happening and how can I fix it? $ sudo add-apt-repository ppa:ubuntu-wine/ppa $ sudo apt-get update ...
1
vote
1answer
215 views

Get error on install Java

I tried install Java 8 for Oracle PPA but get a error. I have viewed “sha256sum mismatch jdk-7u3-linux-x64.tar.gz ” error when trying to install Oracle Java and How to remove error message when ...
0
votes
0answers
33 views

GPG error: http://ppa.launchpad.net trusty InRelease: Clearsigned file isn't valid, got 'NODATA' (does the network require authentication?)

I have been getting this error and its stopping me from downloading latest updates I have looked into other forum posts but im an absolute noob and they werent very clear and/or hard to understand and ...
1
vote
1answer
39 views

Apt-get upgraded package from 32bit to unsupported 64bit - why and how to revert?

Recently the repository of qtox had to change its domain and the new one only contains only 64bit builds at the moment. However, I'm on 15.04 32bit and can't run any 64bit software. Now when I last ...
5
votes
2answers
153 views

'apt-get update' gets stuck for hours at “100% [Working]” for specific PPA

When I run sudo apt-get update on Ubuntu 15.04, I get the following (shortened) output: $ LANG=C sudo apt-get update [sudo] password for ipc-admin: Ign http://ftp.uni-stuttgart.de vivid InRelease ...
0
votes
0answers
26 views

Got 403 error with regional aws S3 apt mirror

My instances are in us-east-1 and suddenly accessing us-east-1.ec2.archive.ubuntu.com.s3.amazonaws.com started got 403 error from 2 days ago. Anyone had the same issue?
0
votes
2answers
27 views

Trouble while installing redis-server

So for some reason it seems that the installation of the redis-server that was serving the sidekiq on one of my machines got removed (How does that happen?). I assume this because commands like which ...
1
vote
2answers
497 views

get list of all commands run in past with sudo apt-get install in terminal

As per command history in Ubuntu terminal we can see all previous command we run on system. I want to know how can we get all previous command which starts with some words/characters. Example : i ...
0
votes
0answers
13 views

Resolving Wine Dependency Errors

Here's the broken package problem I get from wine: The following packages have unmet dependencies: wine1.7 : Depends: wine1.7-i386 (= 1:1.7.12-0ubuntu1) E: Unable to correct problems, you have held ...
5
votes
2answers
88 views

Dependency: libasound2 (>=1.0.16) required for sl-modem-daemon

I'm trying to install a SmartLink modem on Ubuntu Trusty. I need to install sl-modem-daemon but I have no Internet access so I cannot use Ubuntu Software Center to download the dependencies. I used ...
0
votes
0answers
33 views

Unable to find expected entry 'restricted/source/Sources'

I was installing Ubuntu 14.04 in my lab machines. I found apt-get update is not working properly in 14.04 (tried all LTS versions) and 15.04. Its giving following error messages for all the computers. ...
0
votes
1answer
47 views

dependency problem mysql-server

I upgrade my server time to time with apt-get update then apt-get upgrade and dont use anything else. but these days I have a problem with mysql-server. apt-get cannot upgrade anything else, it break ...
64
votes
6answers
59k views

How can I update my nodeJS to the latest version?

I have installed nodeJS on Ubuntu with following code sudo apt-get install nodejs Since I am a new user for ubuntu I also ran this code too sudo apt-get install npm Now when I type nodejs ...
8
votes
2answers
13k views

Is it safe to use the command apt-get autoremove in this particular scenario?

The last time I used sudo apt-get autoremove, nearly every important display driver or parts got deleted. This made me very squeamish about using the command again. However, each time I install ...
1
vote
2answers
704 views

Cannot install minicom on 12.0.4 LTS

I cannot install minicom on 12.0.4 LTS. I get "package 'minicom' has no installation candidate' Is this because /etc/apt/sources.list is old?
0
votes
3answers
3k views

problem with 'sudo apt-get upgrade'

When I run sudo apt-get upgrade, the following error rises: Reading package lists... Done Building dependency tree Reading state information... Done The following packages have been kept back: ...
0
votes
0answers
46 views

upgrading gnome shell to 3.16.3 in ubuntu 15.04, some changes didnot took place correctly

Today I decided to upgrade my gnome to 3.16 because of the significant changes. so I searched it on the web and found the way to do that. I added two repositories: sudo add-apt-repository ...
2
votes
1answer
5k views

How to install qt3-dev-tools package

I am using Ubuntu 13.10 and want to install qt3-dev-tools package. When i run this command sudo apt-get install qt3-dev-tools i am getting this error, E: Unable to locate package qt3-dev-tools ...
2
votes
2answers
1k views

Is there a way to add repo to Snappy ubuntu core?

I am trying to install more stuff and I am seeing very little in snappy's install. Is there a way to use apt-get or add repositories to install?
0
votes
1answer
23 views

How can I install libsdl-ttf2.0:i386 without nuking my system?

I'm trying to play Toribash, and after regularly installing all of the required libraries, I decided to try the i386 ones and they solved the problems. Until I got to libsdl-ttf2.0. Trying to install ...
1
vote
1answer
34 views

Unable to Install OBS

I'm a super new Linux user and need some help installing OBS. I go through the steps on this page (and have tried others). The error I get is this: W: Failed to fetch ht ...
0
votes
0answers
28 views

deleted /var/cache on ubuntu 14.04 and apt-get and other programs crashes on terminal

I have installed Ubuntu alongside windows and have allocated only 10GB for the root. I kept getting messages that there's no space so I found according to the best voted answer in the following that ...
10
votes
1answer
362 views

Why is package 'xul-ext-ubufox' is required to install the Firefox package?

When trying to install the Firefox package on Ubuntu 14.04 it prompts me to also install xul-ext-ubufox: $ sudo apt-get install firefox Reading package lists... Done Building dependency tree Reading ...
557
votes
17answers
812k views

How to list all installed packages?

I'd like to output a list of all installed packages into a text file, so that I can review it and bulk-install on another system. How to do this?
2
votes
4answers
26k views

Uninstall an specific version of PostgreSQL

I have Postgresql 9.1.1 in my Ubuntu 12.04 which got installed due to automatic upgrades and whenever I uninstall it using the command: sudo apt-get --purge remove postgresql-9.1.1 I get an error ...