Advanced Packaging Tool, the package manager for Debian-based distributions. It is also the most used tool for installing packages in Ubuntu. Questions about using any of the apt tools should use this tag.

learn more… | top users | synonyms (1)

5
votes
2answers
87 views

Dependency: libasound2 (>=1.0.16) required for sl-modem-daemon

I'm trying to install a SmartLink modem on Ubuntu Trusty. I need to install sl-modem-daemon but I have no Internet access so I cannot use Ubuntu Software Center to download the dependencies. I used ...
0
votes
0answers
38 views

upgrading gnome shell to 3.16.3 in ubuntu 15.04, some changes didnot took place correctly

Today I decided to upgrade my gnome to 3.16 because of the significant changes. so I searched it on the web and found the way to do that. I added two repositories: sudo add-apt-repository ...
0
votes
1answer
21 views

How can I install libsdl-ttf2.0:i386 without nuking my system?

I'm trying to play Toribash, and after regularly installing all of the required libraries, I decided to try the i386 ones and they solved the problems. Until I got to libsdl-ttf2.0. Trying to install ...
1
vote
1answer
30 views

Unable to Install OBS

I'm a super new Linux user and need some help installing OBS. I go through the steps on this page (and have tried others). The error I get is this: W: Failed to fetch ht ...
0
votes
0answers
27 views

deleted /var/cache on ubuntu 14.04 and apt-get and other programs crashes on terminal

I have installed Ubuntu alongside windows and have allocated only 10GB for the root. I kept getting messages that there's no space so I found according to the best voted answer in the following that ...
10
votes
1answer
358 views

Why is package 'xul-ext-ubufox' is required to install the Firefox package?

When trying to install the Firefox package on Ubuntu 14.04 it prompts me to also install xul-ext-ubufox: $ sudo apt-get install firefox Reading package lists... Done Building dependency tree Reading ...
1
vote
2answers
41 views

Fix “half-installed” package

I have the latest google chrome but accidentally tried to install the .deb package i downloaded two years ago, then cancelled with ctrl-c when it was unpacking, now it keeps telling me its half ...
5
votes
1answer
312 views

Error during apt-get update [duplicate]

While running apt-get i get the following error :- W: GPG error: https://dl.bintray.com Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY ...
0
votes
0answers
13 views

Linking to different versions of a library with cmake

When using cmake to link code to a library, I am trying to understand how Ubuntu finds the correct library when there may be more than one version installed. For example, in my case, I have installed ...
0
votes
1answer
23 views

Update outside of the repositories

Let's assume, I have an application (called abc), that is, in the current repositories, on version 1.0 . So I find in the internet the news today 'BREAKING: abc Version 1.5 released, IT FIXES ...
0
votes
0answers
19 views

Linking with a newer library rather than an old one

I am trying to compile the Point Cloud Library from source (http://pointclouds.org/). After running cmake and make, I receive the following linking error: Linking CXX executable ...
0
votes
0answers
12 views

Prevent vendor change of packages

When you add another repository it can potentially “update” packages of your system with malicious software. On openSUSE I saw that Zypper warns you about “vendor changes” and can effectively prevent ...
0
votes
0answers
14 views

command for re-installing uninstalled packages?

I just removed a package with synaptic. Many additional (30-40) packages got also removed, because they had dependencies to the main package. Now I reinstalled the main package and I simply want to ...
0
votes
1answer
118 views

in Ubuntu 14.04.3 UCK tool,I can't install wine 1.6 or wine1.7 [duplicate]

I can install wine1.7 successfully by following commond,but can't install in uck tool Why is this happening and how can I fix it? $ sudo add-apt-repository ppa:ubuntu-wine/ppa $ sudo apt-get update ...
0
votes
0answers
43 views

Brother MFC 9700 brscan and mfc9700lpr dpkg returned an error code (1) 14.04

I have an Brother MFC9700 and I want to make it scan in ubuntu 14.04. I am able to print to this device (with MFC 9600 driver) but cannot scan. I downloaded and installed the drives below from ...
0
votes
1answer
17 views

Syanptic: Could not download all respository indexes

I've been trying on and off to fix this and I have come to the point where I need to ask for help. The last thing I did was visit here (Update manager: "Could not download all repository ...
0
votes
1answer
24 views

error installing vlc through terminal [duplicate]

E: Could not get lock /var/lib/apt/lists/lock - open (11: Resource temporarily unavailable) E: Unable to lock directory /var/lib/apt/lists/ E: Could not get lock /var/lib/dpkg/lock - open (11: ...
0
votes
0answers
14 views

Trouble with apt-get closing socket prematurely

When running apt-get update the command seem to run without errors, but still the package manager then still can't find packages I want to install, specifically those in the universe part. The same ...
0
votes
1answer
50 views

Apt-get Issues (and random crashes)

I'm running Ubuntu 15.04 (x64, i7, etc.). Everything has been working perfectly for a long time. However, this morning I was watching some videos online (YouTube) when Firefox crashed. I tried running ...
1
vote
0answers
14 views

Problem with libmyodbc - segfault error

I have an issue with libmyodbc as I am not able to connect to the MySQL database that it is pointing to. When I try from isql I get a "Floating point exception (core dumped)" error, and when I try ...
-3
votes
2answers
41 views

Terminal cannot install anything

I hav been using Ubuntu for quite sum time. yesterday i accidentally deleted the ubuntu partition (from windows) and again installed it. im having the following problems I tried 2 install Google ...
0
votes
0answers
19 views

install crashdump on ubuntu 1404

I am following [here] to install crash dump on Ubuntu 1404: sudo apt-get install linux-crashdump However, it throws exception as below: ... unmet dependencies linux-crashdump : Depends: ...
1
vote
0answers
52 views

apt-get is broken in 15.04. I can't install anything. Perl errors [closed]

I have managed to break my apt-get. When ever I try to install a package I get the following error. Any advice? I am a bit of a noob when it comes to apt. ➜ ~ sudo apt-get install nodejs Reading ...
0
votes
1answer
26 views

Unable to locate package libjpeg-dev

I am trying to install libjpeg-dev through the sudo apt-get install libjpeg-dev command on my Ubuntu machine, but keep getting the following error: Reading package lists... Done Building dependency ...
0
votes
0answers
36 views

apt-get update downloads 88+ GB's

So I installed a new Ubuntu 15.04 system. First thing I did was apt-get update user@user-desktop:~$ sudo apt-get update Ign http://us.archive.ubuntu.com vivid InRelease Ign http://security.ubuntu.com ...
1
vote
2answers
26 views

How to tell if a certain package exists in the apt repos? [duplicate]

I am specifically interested in determining whether a 32-bit version of OpenJDK 8 exists in the apt/Ubuntu repos. According to this answer, you can install the 32-bit version of the Open JDK 7 ...
1
vote
1answer
20 views

How to install Brosix secure instant messaging on an Aquaris E5 Ubuntu phone

I have already installed the Brosix .deb app on my Kubuntu 15.04 laptop without any problems. I copied the app to the downloads folder on my Aquaris E5 Ubuntu touch phone, downloaded the terminal from ...
0
votes
0answers
11 views

Update nautilus only? [duplicate]

Can I update only Nautilus in my Ubuntu 14.04? It is really buggy and I've seen that there has been some fixes released to these bugs (eg the copy/paste bug). I'm really reluctant towards doing ...
-1
votes
0answers
41 views

Can I fix package metadata locally? [on hold]

I have a dependency problem. A bunch of packages decided to depend on libgbm1 instead of libgbm1-lts-utopic at some point. What puzzles me is that libgbm1-lts-utopic does not provide libgbm1: $ ...
0
votes
1answer
47 views

How to install bimp for gimp 2.8 on ubuntu?

$ sudo apt-get install libgimp2.0-dev Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have ...
0
votes
0answers
14 views

Error while updating Ubuntu 15.04 [duplicate]

W: Failed to fetch cdrom://Ubuntu 14.04.2 LTS _Trusty Tahr_ - Release i386 (20150218.1)/dists/trusty/main/binary-i386/Packages Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get ...
0
votes
0answers
21 views

Package libgeotiff-epsg is not available and has no installation candidate

I am installing openstreet server on Ubuntu and for that I need to install libgeotiff-epsg package. When I do sudo apt-get install libgeotiff-epsg, it it returning that Package libgeotiff-epsg is ...
1
vote
2answers
61 views

I managed to get stuck with my Nexus 4 Ubuntu Phone, I can't reflash it back to the original ubuntu phone image?

I'm researching development on this phone and downloaded a number of packages using apt-get. It ran out of space and stopped. I can't do an apt-get purge because there is no space left ... I tried ...
-1
votes
1answer
71 views

Can not install steam: E: Unable to locate package

I've ran update and upgrade and are working fine. But when I try sudo apt-get install steam all i get is Reading package lists... Done Building dependency tree Reading state information... ...
0
votes
0answers
46 views

Problem in Installing GFortran in Ubuntu 15.04

I really need to install Fortran compiler for my current work. I decided to install gfortran package in Ubuntu 15.04 by following the steps on this link: ...
0
votes
0answers
6 views

When I try to install an app from the software center I get an error message [duplicate]

Hello Ubuntu community! So ever since I updated Unity to 14.04 I have not been able to install any of the apps from the store. After I click the install button a message pops up that says "you are ...
0
votes
0answers
20 views

Is it possible to exclude a specific source from “apt-get update” command?

It might not seem like an important problem to you, but it is a serious problem to me! The problem is that every time I run apt-get update command, it can't be successfully done because one of the ...
0
votes
0answers
18 views

E: Sub-process /usr/bin/dpkg returned an error code (1) when trying to execute sudo apt-get -f install

I get the error "E: Sub-process /usr/bin/dpkg returned an error code (1)" when trying to execute the command "sudo apt-get -f install" to install required dependencies. I've been searching around but ...
2
votes
0answers
69 views

Error installing Steam on 14.04.03 (missing 32-bit libraries)

I have the Steam Launcher installed (installed via Software Center), when double-clicking the launcher the following is executed in the command window: Steam needs to install these additional ...
-1
votes
0answers
16 views

how to downloand and install RKDET in ubuntu

hello guys i want to install rkdet (rootkit detector) in my system. currently i am using ubuntu 14.04 32 bit. i have downloaded rkdet and read install and read me text file even followed guideline ...
0
votes
1answer
30 views

open lock file /var/lib/dpkg/lock - open (21: Is a directory)

When ever i install a new application using terminal command, i get this error E: Could not open lock file /var/lib/dpkg/lock - open (21: Is a directory) E: Unable to lock the administration ...
2
votes
2answers
148 views

Package 'ttf-mscorefonts-installer' has no installation candidate

I am having a Java based web application running in Amazon EC2 Ubuntu server. I use Jasper reports to generate some reports in PDF format. I built these reports using 'Jaspersoft Studio' Now, when I ...
0
votes
0answers
21 views

xz-utils 5.2.1 on trusty: how to compile and re-package? Or ppa available?

I want to compile and use a newer version of xz-utils, in this case version 5.2 as well as create deb-packages to be distributed on different ubuntu (14.04) machines. The recent changes to xz were ...
-1
votes
0answers
16 views

installing pango and dependencies?

I want to install Pango. According to linuxfromscratch.com the dependencies for Pango-1.36.8 are Fontconfig-2.11.1, and it's dependencies are FreeType-2.6, it's dependencies are Harfbuzz-1.01.1, ...
0
votes
0answers
127 views

Upgrading KUbuntu 14.04.02 to 14.04.03 - Odd error

I'm trying to upgrade an install of Kubuntu 14.04.02 to 14.04.03, but I keep getting the following error that kills the upgrade. I get it both via apt-get upgrade or when doing it from Synaptic. The ...
0
votes
0answers
35 views

I accidently deleted /var folder

I was using terminal and accidently typed sudo rm -r /var. I stopped it, when had noticed, and can not see any errors in daily using. But when I want to install apache, nginx or something else. I got ...
0
votes
1answer
32 views

Skip updating certain updates in apt-get

A couple of months ago I started following tutorials about updating to the latest stable version of the Linux kernel for Ubuntu -which is currently 4.0.9. The updates where flawless and I noticed my ...
0
votes
0answers
28 views

Error while installing packages (for Virtual Box builds)

I am trying to install the following packages - Linux Packages (Website is down for some reasons. Here is the PDF copy of the website - Virtual Box Build Instructions) Here is the code I'm trying to ...
2
votes
0answers
250 views

Install packages from LTS Hardware Enablement Stack for Ubuntu 14.04.3 has unmet dependancies

I was able to install the new kernel,3.19, however, when I try to get the new packages for the hardware enablement stack and attempt this command sudo apt-get install --install-recommends ...
1
vote
0answers
36 views

apt-get and Software Center tries to remove core packages

Recently(before I got Ethernet wired on 12.04.01) I tried to install build-essentials and its dependences through .deb files, and failed ultimately so I gave up. Now, I tried to apt-get it now that I ...