Advanced Packaging Tool, the package manager for Debian-based distributions. It is also the most used tool for installing packages in Ubuntu. Questions about using any of the apt tools should use this tag.

learn more… | top users | synonyms (1)

0
votes
0answers
13 views

How to get a list of all pending security updates?

I need to list (not count or install) all pending security updates on an Ubuntu 14.04 system. I've read the post How to create a list of of only security updates with apt-get? and its accepted answer ...
0
votes
2answers
23 views

How do I install a specific lower minor version of gcc using package manager?

I am running an Ubuntu 14.04-4 64bit. gcc --version returns (Ubuntu 4.8.4-2ubuntu1~14.04.1) 4.8.4 Yet, I need version 4.8.2-10. What I tried: I found the specific gcc version in a debian snapshot ...
0
votes
1answer
21 views

grub2 can't configure after failed upgrade on raid

I tried to upgrade ubuntu with standard apt-get upgrade and ran into similar problems to what is described here: https://www.webhostingtalk.com/showthread.php?t=1315016 grub went through a ...
0
votes
1answer
68 views

How can nautilus-open-terminal, the Nautilus context menu item, be installed on Ubuntu 16.04?

I have attempted to use apt-get to install it, but I can't seem to find it: sudo apt-get install nautilus-open-terminal sudo apt-get install nautilus-open-terminal-here
3
votes
2answers
30 views

'Make command not found

I am having a problem that when I try to use make command. I cannot run the Make command. Message: bash: make: command not found When I used sudo apt-get remove make sudo apt-get install make ...
1
vote
0answers
23 views

What does the aptitude `why` and `why-not` mean?

From the manuals: The command why finds a dependency chain that installs the package named on the command line, as above. Note that the dependency that aptitude produced in this case is only a ...
-1
votes
0answers
15 views

Unable to install Icinga2 in Cygwin [closed]

I am using cygwin for my windows7 32-bit.I am trying to install icinga2 on my system. By giving this: "apt-cyg install icinga2", I am getting error:"Unable to locate package icinga2". Tell me how to ...
1
vote
1answer
18 views

ubuntu-standard package gone - how do I reinstall it in a clean way

This is pretty stupid and I wish I could go back in time... I installed cryptsetup and also ticked the boxes for mandos-client and busybox (I know now - I should'nt) and find myself with ...
0
votes
1answer
14 views

Is there any apt-get/dpkg/aptitude option to get apt cache folder location?

apt cache folder default location is /var/cache/apt/archives. i work in a python script. is there any way to know cache folder location in code. like run a apt-get option. like: apt-get ...
0
votes
0answers
28 views

dpkg: error processing archive - kmod (--unpack)

I am trying to upgrade an old debian system (Ubuntu squeeze) to 14.04. I updated the /etc/apt/sources.list with the sources for ubuntu trusty. I have some troubles installing the package kmod where a ...
1
vote
0answers
48 views

Hash Sum mismatch for cpp/gcc in ubuntu 16.04 LTS

I was trying to install cpp/gcc package in Ubuntu 16.04 LTS but getting error code - "Hash Sum mismatch" So far I have used different archive like - archive.ubuntu.com, us.archive.ubuntu.com and ...
0
votes
1answer
64 views

upgrading Ubuntu from 14.04 to 16.04_ Update problem

After upgrading Ubuntu from 14.04 to 16.04 I got the following two problems. 1. When I do sudo apt-get update I got: W: <http://us.archive.ubuntu.com/ubuntu/dists/precise-security/InRelease>: ...
1
vote
1answer
48 views

Cannot install software on Ubuntu 16.04

I am a new Ubuntu user. its version is 16.04. I cannot install any software from Ubuntu software. A red signal is shown in the upper right corner.
0
votes
1answer
44 views

Error while updating and installing a package in ubuntu server 14.04 LTS

I am new in the world of linux . I am trying to update and install some packages in Ubuntu Server 14.04 LTS but it is showing error . I have seen lot on same question in this site but not able to ...
-4
votes
0answers
25 views

Errors in installing nagios on Linux mint (cinnamon)

I want to install nagios on my computer, which is running Linux Mint. When I type: sudo apt-get install build-essential php5-dg libgd2-xpm libgd2-xpm-dev libapach2-mod-php5 libperl-dev ...
0
votes
2answers
51 views

I cannot install any software on my freshly installed Ubuntu 16.04 LTS

I am new to Ubuntu and so far not having a very pleasant user experience. I have tried to install multiple programs but no luck. The software "app" does not work and I get an error of Failed to load ...
0
votes
0answers
66 views

Sub-process /usr/bin/dpkg returned an error code in16.04LTS

During install of git-all error code (1) is displayed. after on running the following commands the output are: sudo apt-get install git-all [sudo] password for yash: Reading package ...
0
votes
1answer
67 views

Update problem with signiture key

I have just updated to Ubuntu 16.04 LTS I started setting up by installing Google-Chrome and then went to run a sudo apt-get update again before I started installing other software, and I get the ...
1
vote
0answers
32 views

Apt-get SSL client certificate not working on 16.04 (Error while reading file)

I ported the same working SSL client key/certificate and /etc/apt/apt.conf.d/01_https_client_cert rule from an (working) 14.04 VM to a fresh 16.04 installation. I am able to use the SSL client ...
0
votes
0answers
21 views

Network Manager crash not resolved [duplicate]

I lost my network connection following an upgrade I installed on Friday 13th May (no joke!). This was on both my desktop PC and my Sony laptop, both running on Ubuntu 14.04 LTS. I visited this site: ...
0
votes
0answers
16 views

Problems Downloading Packages when running Software Update in 16.04 LTS

Each time I run software update i get a message "check internet connection". It is not the connection as it informs me of updates autommatically by itself. It gives an error file containing lots of ...
1
vote
0answers
21 views

Problem with apt-get for kernel sources

I am running Ubuntu desktop 16.04 I tried to get the kernel sources using the command apt-get source linux-image-$(uname -r) as recommended in the Ubuntu wiki. I got the error E: You must put ...
0
votes
1answer
41 views

Remove Dependencies - I don't want to install them

PC Specs OS : Ubuntu 16.04 LTS 64 Bit After reinstalling ubuntu back on my laptop, I installed google-chrome-beta,virtualbox and opera-developer, I decided to remove LibreOffice and `firefox. I ...
0
votes
1answer
12 views

Muon does not apply changes

After updating muon does not ask for password, it only pops up a notification: can not continue due to invalid identification. I have to use apt-get to install one-by-one of my selections.
0
votes
0answers
12 views

removed package, but not enough was removed

I installed netbeans which is a fairly large package to install. However, when I removed it (because something simple like "help contents" crashes), just a couple of megabytes were saved and I think ...
0
votes
1answer
82 views

14.04 Cleanly upgrade to ppa:ondrej/php from ppa:ondrej/php5-5.6

I went through my usual server package upgrades today and discovered that ppa:ondrej/php5-5.6 has been depreciated and we must now upgrade to ppa:ondrej/php. The basic provided instructions are to ...
0
votes
1answer
50 views

Why does Ubuntu Software Center not show every package available?

The Software Center in Ubuntu 16.04 (Gnome Software) shows only part of the packages available. While e.g. apt list qtcreator correctly lists the corresponding package a search in Software Center ...
-1
votes
1answer
23 views

Error Installed packages have unmet dependencies , error with the sources.list file

I am trying to update my computer, but I am getting the following error: 'Unknown Error:'<class 'SystemError'>'(E: opening etc/apt/sources.list-ifstream::(13:permission denied))' Please ...
0
votes
1answer
53 views

Could not install GNU Octave

I am getting below error while installing ocatve. Command I run: sudo apt-get update && sudo apt-get install octave Error: The following packages have unmet dependencies: octave: ...
0
votes
0answers
27 views

fortran compiler for ubuntu

I have downloaded g95 compiler but I am unable to install it. Could you please let me know the commands to install g95 or any other fortran compiler. As sudo apt-get install gfortran doesn't work. A ...
0
votes
1answer
28 views

apt-get equivalent of this command

I'd like to know the equivalent of the dnf remove *nvidia* with the apt package manager.
0
votes
0answers
12 views

Troubles with the updating process in Ubuntu Studio 16.04 LTS [duplicate]

I'm using Ubuntu Studio 16.04 LTS and today, Monday, May, 16, 2016, I couldn't update my system (with the System Update routine) because it gave me a lot of errors. Using sudo apt-get update, the ...
0
votes
1answer
34 views

sudo apt-get update not working Unable to connect to 192.168.1.254:3128

Usually but not always when I try to download some few software through apt I have plenty of errors in the error log such as the following one: Err http://fr.archive.ubuntu.com trusty/universe ...
0
votes
1answer
32 views

keyserver timed out with add-apt-repository

I cannot add-apt-repository because the Ubuntu keyserver times out: $ sudo add-apt-repository ppa:git-core/ppa -y gpg: keyring `/tmp/tmpxzw15cei/secring.gpg' created gpg: keyring ...
0
votes
1answer
18 views

Cannot reinstall python3 on ubuntu 14.04

I think that I accidentally broke Python3 and was unable to do anything. I read somewhere that the solution was to remove python3 and reinstall it, but I got yet another problem: I was able to remove ...
0
votes
0answers
38 views

Ubuntu 16.04 Failed to download repository information: google music manager [duplicate]

When I try to check updates I get the following; W:http://dl.google.com/linux/chrome/deb/dists/stable/Release.gpg: Signature by key 4CCA1EAF950CEE4AB83976DCA040830F7FAC5991 uses weak digest algorithm ...
2
votes
2answers
87 views

How to repair corrupt package installation (mysql)

After upgrading to Ubuntu 16.04, I noticed mysql was having mind-boggling errors. Convinced, it was a broken setup, I tried running a purge of mysql. That didn't seem to delete everything, so I tried ...
0
votes
1answer
53 views

Cannot install ubuntu 14.04 packages

I have tried to install network-manager because after 13.05.2016 updates broke it. Anyway, there is few issues. I have downloaded from another computer network-manager ...
0
votes
0answers
20 views

Upgrade from from 15.04 to 15.10 (and possibly to 16.04)

I am not able to upgrade from 15.04 to 15.10 (notwithstanding I read analogues answers). 1st: with lsb-release -a I get No LSB modules are available. Distributor ID: Ubuntu Description: ...
0
votes
1answer
59 views

Offline install of packages

How I could download these packages: libmm-glib0 dnsmasq-base iputils-arping My ubuntu machine haven't internet connection since 13.05.2016 updates. So I have tried find a solution how to download ...
1
vote
2answers
29 views

Remove Getdeb from Ubuntu System

I tried deleting it from /etc/apt/sources and /etc/apt/sources.d, but whenever I run apt-get install for any package , it gives the following output in the end Setting up getdeb-repository ...
1
vote
0answers
19 views

Understanding section of “upstream_version” [duplicate]

When looking at the latest updates published by a package maintainer I noticed that there was a recent update to a package despite the minor version not incrementing: ...
1
vote
0answers
22 views

Error on installing applications

E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. E: _cache->open() failed, please report. When I run dpkg in the terminal, I get the following ...
0
votes
0answers
64 views

Ubuntu 14.04. cannot update [closed]

Similar to this question, I cannot apt-get update my machine. I've tried everything I could Google: adding the bad key, deleting my /var/lists/thingy, apt-get clean, deleting Chrome. But I keep ...
-1
votes
0answers
17 views

How can I know when update is avaible?

You wrote : Once the future upgrade from trusty-proposed is installed you can remove that hold with: sudo apt-mark unhold libnl-3-200 libnl-genl-3-200 libnl-route-3-200 But how can I guess the ...
1
vote
1answer
50 views

fixing broken packages in ubuntu : repost

I have a lot of broken packages in my ubuntu 14.04 distro, which I am trying to fix. I am following this answer by one of our community member. I followed the first two commands and after editing the ...
0
votes
1answer
29 views

sudo apt-get update error: Wrong sources.list entry or malformed file

I recently tried to install npm and nodejs and got some errors and was suggested to run sudo apt-get update. After running sudo apt-get update I get the following error: Failed to fetch ...
0
votes
0answers
23 views

Missing locales, running in low graphics, can't apt-get

When I try to apt-get upgrade I get error with dependencies and it tells me to use apt-get -f install, but when try it perl warning setting locale failed... The problem started when I used katoolin ...
0
votes
0answers
41 views

apt-get update, unlinking

I've recently moved to xenial ubuntu. After upgrading, I was no more able to run sudo apt-get update The output is the following: Get:1 http://it.archive.ubuntu.com/ubuntu xenial InRelease [247 ...
-3
votes
0answers
47 views

Windows 10 UBUNTU bash

I am having multiple problems getting UBUNTU to work properly.. I am getting pages of errors after running apt-get install -f the errors end with: 6b39-1.13.11-0ubuntu0.14.04.1); however: Package ...