Advanced Packaging Tool, the package manager for Debian-based distributions. It is also the most used tool for installing packages in Ubuntu. Questions about using any of the apt tools should use this tag.

learn more… | top users | synonyms (1)

52
votes
3answers
54k views

How can I install a package without installing some dependencies?

I'm trying to install the package LaTeXila, and the output looks like this: $ sudo apt-get install latexila --no-install-recommends Reading package lists... Done Building dependency tree ...
51
votes
7answers
45k views

Is it possible to undo an apt-get install command?

I installed Carpadio on my Xubuntu install (a Live USB), which then pulled like over 50 packages from, I suppose, the Ubuntu side of the repository. Now I would like to undo this. However for all my ...
50
votes
2answers
42k views

apt get install vs pip install

I am a bit confused about the cases in which the above commands must be used when downloading python packages. I was trying to download a package named pyudev in accordance with an answer with this ...
50
votes
1answer
23k views

create a .deb Package from scripts or binaries

I searched for a simple way to create .deb Packages for things which have no source code to compile (configs, shellscripts, proprietary software). This was quite a problem because most of the package ...
49
votes
6answers
38k views

Where can I look up my update history?

Is there a place where I can look what updates I've installed?
49
votes
1answer
40k views

How can I remove gpg key that I added using apt-key add -?

I don't need the key in my server's keyring anymore. Is it possible to remove it? I added the key using this command: curl http://repo.varnish-cache.org/debian/GPG-key.txt | apt-key add - Thanks ...
48
votes
10answers
4k views

Can't update because the word prox* is blocked

I live in Ethiopia and the government blocks all urls with the word "proxy" in them. I couldn't use that word in the title above because that would make the url contain the word proxy. When I ...
47
votes
2answers
33k views

“method driver /usr/lib/apt/methods/https could not be found” update error

sudo apt-get update E: The method driver /usr/lib/apt/methods/https could not be found. michael@Ubuntu:~$ sudo apt-get clean michael@Ubuntu:~$ cd /var/lib/apt michael@Ubuntu:/var/lib/apt$ sudo mv ...
47
votes
13answers
22k views

How to find manually installed packages?

I installed a plain Ubuntu 10.10 on my computer and installed some software via apt-get. Last week I managed to break everything and just started from scratch, and I need to reinstall my software. Is ...
46
votes
5answers
192k views

Permanently removing apache2

It seems a simple apt-get remove apache2 does not completely remove apache2 as I can still see it on one of the processes when running top. How does one remove apache2 completely on his ubuntu server? ...
46
votes
2answers
61k views

Error sudo: add-apt-repository: command not found [duplicate]

When i run in terminal: sudo add-apt-repository ppa:ubuntu-wine/ppa log here: sudo: add-apt-repository: command not found i tried to run sudo apt-get install software-properties-common but ...
46
votes
5answers
20k views

How can I remove the Translation entries in apt?

This is the output of aptitude update: Ign http://archive.canonical.com natty InRelease Ign http://extras.ubuntu.com natty InRelease Ign http://dl.google.com stable InRelease Ign ...
45
votes
5answers
37k views

Why was the virtualbox package removed from the 14.04 repository?

I'm having some problems trying to run my Windows XP virtual machine after upgrading to Ubuntu 14.04 today. When I tried to start it a message dialog was displayed saying that the kernel drivers ...
45
votes
5answers
42k views

“debconf: DbDriver ”config“: config.dat is locked by another process: Resource temporarily unavailable” while installing packages

I'm trying to install the flashybrid but when I enter the apt-get install flashybrid command, I get this error: root@user-desktop:/home/user# apt-get install flashybrid Reading package lists... Done ...
44
votes
4answers
42k views

How to install NodeJS 4 on Ubuntu 15.04 64 bit edition?

How can I install NodeJS 4 on Ubuntu using apt-get install? Which apt repo do I need to add as default sudo apt-get install installs Node 0.12.x
44
votes
3answers
53k views

apt-get autocomplete package name is broken

At some moment apt-get install autocomplete was broken It was very useful to me to see packages name with Tab press How to repair this autocomplete?
44
votes
2answers
23k views

apt-get stuck at 0 [Connecting to us.archive.ubuntu.com]

When I do upgrade it gets stuck here: user@plato:~# sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done ...
44
votes
5answers
16k views

What is the difference between apt and apt-get?

I read about the new fancy progress bar which was added to apt 1.0 in Softpedia and how to enable it here. However on running sudo apt-get update, I did not see the fancy progress bars. On reading the ...
43
votes
8answers
68k views

“GPG error: Release: The following signatures were invalid: BADSIG”

I ran this command in the Terminal: sudo apt-get update Updating ends with the following error report: W: A error occurred during the signature verification. The repository is not updated and the ...
43
votes
3answers
3k views

I installed a program by getting its source code, and then running `sudo make install`; how to make `apt-get` know about it?

I installed program (call it, for example,progA) by building it from source code, and then finally calling sudo make install and sudo ldconfig. However, it seems apt-get hasn't gotten the memo, ...
42
votes
2answers
3k views

“Do you want to continue[Y/n]?” Why the upper case?

I am new to Ubuntu and some little thing start to bug me. Such as when trying to install a program, Ubuntu asks, Do you want to continue[Y/n]? What is bugging me is why the letter "Y" is upper ...
41
votes
7answers
139k views

Installing and testing CUDA in Ubuntu 14.04

I am uncertain about how to install CUDA in my system. looking around there are many tutorials about cuda on 12.04 LTS and a few on 13.04 and 13.10, but they all talk about acquiring a deb package ...
40
votes
6answers
4k views

Could I remove apt with apt?

I know that I can use apt-get remove <package> to remove a program. But apt is a program itself. Could I use apt-get remove apt to remove it, or would it get confused part way through?
39
votes
5answers
34k views

How to set up an APT repository?

I would like to set up an APT repository on a server that will provide a couple of packages. Is there a way to set one up without installing any software on the server? How do the files have to be ...
38
votes
8answers
69k views

How do I remove a malformed line from my sources.list?

I have unistalled and reinstalled the Ubuntu Software Center as per info I found in a similar thread and I got the same response about line 91 or something like that. I just tried to upload a screen ...
38
votes
2answers
128k views

What does Package <package> has no installation candidate mean?

What does the above Error mean? What is an installation candidate? I was trying to do sudo apt-get install munin-memcached and I get this message: Reading package lists... Done Building ...
37
votes
2answers
17k views

How do I apt-get -y dist-upgrade without a grub config prompt?

Per Make apt-get (or aptitude) run with -y but not prompt for replacement of configuration files? I did the following: ec2run ami-3c994355 --region us-east-1 -n 1 -t m1.large -z us-east-1d On the ...
37
votes
7answers
84k views

apt-get update very slow, stuck at “Waiting for headers”

I have looked at similar questions: Stuck at 0% [waiting for headers] (apt) apt-get update stuck on "Waiting for Headers" However neither one of them answer my problem. I am running ...
36
votes
2answers
24k views

connecting to archive.ubuntu.com takes too long

I have a Ubuntu 11.10 server that I just installed fresh. Now if I try to do anything with apt-get, it tries to connect to archive.ubuntu.com .. It stays at [Connecting to archive.ubuntu.com ...
36
votes
4answers
11k views

What does apt-get install do under the hood?

What does the apt-get install ... command do? When I enter apt-get install ... command, there are some texts appearing on the screen, but that does not have enough information for me. I want to know ...
36
votes
8answers
29k views

Is it possible to install a .deb from a URL?

Is there a way to install a deb package directly from a URL, using a shell? Something like dpkg -i http://domain.com/path/to/package.deb (I know I could use wget and then dpkg, I'm just wondering ...
36
votes
10answers
68k views

How to use a .iso image as a CD-ROM Repository?

I have all images of Debian, Ubuntu and Ubuntustudio as .iso. How can I use them as repository to install my desired packages with sudo apt-get install package-name? I easily mount the .iso file with ...
35
votes
1answer
26k views

Make apt-get (or aptitude) run with -y but not prompt for replacement of configuration files?

When running apt-get -y install <packages ...> on Ubuntu 10.04 I would like apt-get (or aptitude if that makes it easier) to not prompt me when installing additional dependencies (behavior of -y ...
34
votes
2answers
11k views

There is no public key available for the following key IDs 1397BC53640DB551 [duplicate]

When I run the command: sudo apt-get update I got this following warning: There is no public key available for the following key IDs: 1397BC53640DB551 This is the only warning I got and I do not ...
34
votes
9answers
124k views

'apt-get' does not work with Proxy

For the command sudo apt-get update I get following error: W: Failed to fetch http://ch.archive.ubuntu.com/ubuntu/dists/maverick-updates/multiverse/binary-i386/Packages.gz 407 Proxy ...
34
votes
1answer
57k views

Failed to fetch update on Ubuntu 14.04 LTS (Trusty Tahr) [duplicate]

While running the update at Ubuntu 14.04 LTS (Trusty Tahr). The following error is being encountered: W: Failed to fetch ...
34
votes
2answers
32k views

What does “No apport report written because MaxReports is reached already” mean?

When installing a Linux kernel image package, I got, amongst other errors: No apport report written because MaxReports is reached already Where can I delete old reports so that Apport can ...
34
votes
5answers
13k views

Why doesn't apt-get autoremove remove my old kernels?

My boot partition is on a SSD, so it doesn't have room for more than about 8 installed kernel versions, and eventually some kernel update will fail to install because my boot partition is full of old ...
33
votes
3answers
110k views

E: Unable to correct problems, you have held broken packages

I am using Ubuntu 13.04 which I installed few days back. I am trying to install nodejs and npm. I tried to install from command line first and then uninstalled it. Then something broke. sudo apt-get ...
33
votes
10answers
55k views

Unable to install Skype on 64bit Ubuntu

I am receiving the following message while I am trying to install Skype: nidhin@ubuntu:~$ sudo apt-get update nidhin@ubuntu:~$ sudo apt-get install skype Reading package lists... Done Building ...
33
votes
8answers
15k views

How to see packages installed on a given date using aptitude

Does anyone know if there's an easy way to find a list of packages installed, sorted by date, when using aptitude (or apt-get)? I was installing a bunch of packages to try something new, and it ...
33
votes
3answers
4k views

apt-get is stuck at “Fetched XXKb in XXsec” [duplicate]

I tried to install crossover and after downloading the .deb from their website, I followed the steps as indicated when opening it with Ubuntu Software Centre: On 64-bit flavors of Debian and some ...
33
votes
4answers
37k views

What is nss-myhostname? And why is it not installable?

dmesg shows the line systemd-hostnamed[3964]: Warning: nss-myhostname is not installed. Changing the local hostname might make it unresolveable. Please install nss-myhostname! But sudo ...
33
votes
2answers
52k views

How to install suggested packages in apt-get

I know the question has been asked before, but please hear me out. So I wanted to install screenlets. I ran sudo apt-get install screenlets, and this is what I got: The following extra packages will ...
33
votes
3answers
3k views

Do I really need the “Source Code” in my repository list?

It takes a long time to update my software sources when I run: sudo apt-get update I believe that happens when the apt-get is downloading source code from the repository, in my case it the one in ...
32
votes
5answers
5k views

Why does apt-get not require restarts, where the update manager does?

Oftentimes I try to ‘beat’ the update manager by opening a console and entering the sequence sudo apt-get update sudo apt-get upgrade which, to the best of my knowledge, should update all packages ...
32
votes
5answers
37k views

How not to install recommended and suggested packages?

I use Ubuntu 12.04 64-bit, I did the following, sudo gedit /etc/apt/apt.conf and added APT::Install-Recommends "false"; APT::Install-Suggests "false"; but did not work. When I try to install a ...
31
votes
3answers
13k views

What does it mean that a package is “set to manually installed?”

When packages are already installed and I run an apt-get install <package-name>, sometimes it will print a line <package-name> is set to manually installed. What does that mean?
31
votes
2answers
42k views

Exclude packages from `apt-get upgrade` [duplicate]

Possible Duplicate: How to prevent updating of a specific package? Keep the Ubuntu package version I'm using now Is it possible to upgrade all packages except a given package? Is ...
31
votes
1answer
44k views

W: GPG error: http://ppa.launchpad.net precise Release: The following signatures couldn't be verified because the public key is not available:

I get the following error when i do sudo apt-get update W: GPG error: http://ppa.launchpad.net precise Release: The following signatures couldn't be verified because the public key is not available: ...