Advanced Packaging Tool, the package manager for Debian-based distributions. It is also the most used tool for installing packages in Ubuntu. Questions about using any of the apt tools should use this tag.

learn more… | top users | synonyms (1)

0
votes
0answers
19 views

Apt-get unmet dependencies

I´m using Ubuntu Server 12.04 and MySQL 5.5. When I try to install libsml2-dev I get the following message : root@myserver:/usr/local/php5516/php-5.5.16# apt-get install libxml2-dev Reading package ...
-1
votes
0answers
48 views

apt-get update is updating the same files again and again [closed]

i just got a new linuxmint 17, and after i did all the first updates, i always get these ones: sudo apt-get update Ign htt p://packages.linuxmint.com qiana InRelease Ign ...
0
votes
1answer
57 views

sudo apt-get update fails [closed]

get update` comand dosent work it gets Fails, sorry new to ubuntu W: Failed to fetch htt p://ppa.launchpad.net/jolicloud-team/ppa/ubuntu/dists/saucy/main/source/Sources 404 Not Found W: Failed ...
1
vote
0answers
26 views

join ubuntu 14.04 to AD error

I tried to join an ubuntu 14.04 machine to AD, but when I try to install likewise-open I get this error : E: Package 'likewise-open' has no installation candidate # sudo apt-get install ...
3
votes
1answer
33 views

How can I install applications (with apt-get) to an external disk?

I'm on a chromebook running Ubuntu inside a chroot via crouton. Thus, I have limited space. However, I have an external 32GB (extremely) high-speed SD Card. I'd like to install some of my larger ...
0
votes
0answers
20 views

determine which package(s) were installed from a particular source

Some time ago, I installed a package from a qantal ppt source - at the time, it was only available in the quantal (12.10) repos; I'm running precise (12.04). The qantal repo has now been removed from ...
0
votes
0answers
42 views

Nvidia update video driver

This is a really quick question. I tried looking around, but couldn't find a definite yes or no answer. In order to update my video card driver from 331.38 to 340 or higher, do I have to remove or ...
0
votes
1answer
26 views

Limit recursion in apt-get install --install-suggests

Recently I tried to install a package and it's suggests by using apt-get install tuxguitar --install-suggests although this worked, there was far more installed than I bargained for. A total of ...
1
vote
0answers
32 views

How do I release software on apt-get? [duplicate]

I'm a bit new to desktop programming, and I currently prefer to work with scripting languages (open source and all). When I polish a tool off I then want to release it for installation via apt-get but ...
0
votes
0answers
62 views

How to change gcc-4.9-base version without removing dependecies?

I have a freshly installed Ubuntu 14.04.1 but cannot install nvidia-331 driver because of dependencies conflict: lib32gcc1 should be installed but it conflicts with already installed gcc-4.9-base ...
0
votes
0answers
31 views

I can't use proprietary drivers for AMD 8970M (14.04)

I have checked in the additional drivers section but it says I am using manual drivers. I try clicking on trying to use the proprietary drivers but cant select that option. I have tried: sudo apt-get ...
1
vote
1answer
46 views

Undo apt-get remove --purge

I wanted a fresh install of Python and ran sudo apt-get remove --purge python. Apparently it has killed almost everything I had installed in my system. Looking at the history.log I guess I could ...
1
vote
1answer
24 views

How can I take a textbox text entry and make it a variable?

I am having trouble with Python and would like to have some help. I am making a apt GUI 'front-end' with a nice UI. def on_textbox_changed(self): self.instvar = ...
0
votes
1answer
11 views

Is it possible to individually uninstall packages previously installed using a meta-package?

I have no need for the help utility, document viewer, contacts app, etc. that Gnome has built into the gnome-shell. Is is possible to remove just those packages? Every time I try it wants me to ...
0
votes
1answer
20 views

Uninstall Eigen 3.0.5

In short, I believe that my question is about how to properly uninstall Eigen 3.0.5, but here is a brief story of how I got myself into a mess: I did sudo apt-get install libeigen3-dev; however, I ...
0
votes
1answer
38 views

How to install gcc-4.6 (4.6.3-1ubuntu5) Source Package

I have recently started working on ubuntu and I have been facing a lot of difficulties installing programs in it. I don't know how I managed to install NetBeans and JAVA JDK and JRE. Unfortunately the ...
0
votes
0answers
12 views

Update manager error [duplicate]

When I try to update Ubuntu from the Update manager I get this message: E:Encountered a section with no Package: header, E:Problem with MergeList ...
0
votes
2answers
23 views

Download packages (different architecture) different Ubuntu version

Ideally, I would like to specify architecture and Ubuntu version and download all dependencies for that package, then take them to another computer. I know about apt-get download.... and that would ...
-1
votes
1answer
39 views

Can't get rid of GPG-error: http://download.opensuse.org [duplicate]

I have been googling for hours trying to find a way to get rid of the annoying gpg-error referring to the link below. W: GPG error: http://download.opensuse.org Release: The following signatures ...
0
votes
1answer
71 views

Trying to install cifs-utils - the attempt created dependency hell

Trying to mount a smb share in Linux (12-10, kernel 3.5.0-17-generic) - I tried to install mounting utils sudo apt-get install cifs-utils response / error: ... Preparing to unpack ...
0
votes
1answer
35 views

apt-get update says E: Sub-process returned an error code

I am getting this error whenever I try and run any apt-get command. Currently I am trying to run sudo apt-get update. I have also noticed that the /var/lib/apt/lists is empty. How can I repopulate ...
1
vote
1answer
19 views

Is it safe to remove runit package?

I just upgraded my ubuntu box from 12.04 LST to 14.04 LTS. Now apt-get tells me: The following package was automatically installed and is no longer required: runit Use 'apt-get autoremove' ...
0
votes
0answers
20 views

Unable to find expected entry 'main/source/Sources' in Release file

I have few packages on my remote server. I have packages for both precise and trusty. Well, since apt repo of precise does not have ruby-2.0.0, I had to manually put it up. I use aptly and publish the ...
0
votes
0answers
36 views

When trying to upgrade to Ubuntu 14.04, libc6 breaks, why and how to solve this problem?

$ sudo apt-get install -f Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... Done The following packages were automatically ...
0
votes
1answer
30 views

is there something with my apt sources list?

Is it me or are packages in the depository like too frustratingly out of date to be of any use, in particular for development work.... Are there any problems with my sources list? Before I banish the ...
1
vote
1answer
72 views

Software Updater fail, and “apt-get update” throws “Invalid operation update” - what next?

I'm running a fairly vanilla 14.04 Ubuntu on a newish HP desktop. Just yesterday I got the dreaded "Failed to download repository information": A screenshot of this window has been seen on ...
0
votes
0answers
9 views

How to block installing grub into MBR while upgrade?

I have a problem with blocking installing GRUB into MBR. I have to block it in ubuntu and debian template to not let users "destroy" their XenServers (with GRUB in MBR they wont boot). Ubuntu ask for ...
0
votes
1answer
51 views

12.04 .. Red Circle Icon in top right corner - can't remove [duplicate]

Good morning, I am new to the whole "Ubuntu" system, I havean elementary OS, version 0.2.1 "Luna" 64 bit, Built on 12.04.. Everything was working fine up until I was in the software center ...
0
votes
0answers
32 views

error: parsing file '/var/lib/dpkg/updates/0001' near line 0: newline in field name `#padding'

I was try to install mono using the following command: sudo apt-get install mono-* I closed the terminal while it was installing. I restarted the install, and I got the error message: Could not ...
0
votes
1answer
27 views

Cleaning up an upgrade from 12 to 14 interrupted late in the process

I have been looking over all of the posts for interrupted updates and they are, so far, all reporting catastrophic failures. Most of them are saying they can't even boot. My situation is a bit ...
0
votes
1answer
14 views

muon package manager can't find packages

I've a strange problem with muon package manager. For a few days I've been trying to install packages (umlet for example) without any succes. All the time I'm trying to install anything muon says that ...
1
vote
0answers
34 views

Problems with upgrade to Ubuntu 14

Since upgrading to Ubuntu 14 a couple of weeks ago I've been unable to install or update any software using apt or the regular updates. When using apt-get I always get the error message E: ...
1
vote
1answer
42 views

Inverse of --install-suggests option in apt-get remove

Recently, I have installed a package with --install-suggests and now I want to get rid of it. How do the opposite thing, remove package with all suggested packages?
0
votes
1answer
50 views

apt-get want to remove all my packages

My apt-get thinks everything including my xserver gdm and other vital softwares are unnecessary. The following is the output. When I once ran upgrade it did remove evrything and I had to reinstall my ...
0
votes
0answers
25 views

problem is upgrading to ubuntu 13.04 [duplicate]

I am fairly new to the Linux world. I was trying to update from 12.10 to 13.04 and when I try to run software updater I got this error message saying : Failed to download repository information ...
0
votes
0answers
76 views

How to install Sublime Text 2 on Ubuntu 14.04

All tutorials on installing ST2 on Ubuntu describe 2 ways: Manual way of downloading the tar from the official website, extracting it, moving it to /opt/, creating a symlink and start menu entry ...
0
votes
1answer
36 views

Error with dpkg

When I try to install anything, I get an error. ex: diego@diego-Satellite-C655:~$ sudo apt-get install spotify-client Reading package lists... Done Building dependency tree Reading state ...
0
votes
1answer
31 views

problem in installing ffmpeg in ubuntu 14.04

I try to install ffmpeg in unbutu according to https://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu I create a shell file with below code sudo apt-get update sudo apt-get -y install autoconf ...
0
votes
0answers
12 views

Can't install git on Ubuntu, Unable to fetch some archives? [duplicate]

Trying to install git onto Ubuntu 13.04. Getting this error message. Tried sudo-apt get update and same problem. Very new to Ubuntu so your help will be appreciated. Err ...
-1
votes
2answers
84 views

Problem installing build-essential on 14.04.1 LTS [duplicate]

I'm trying to install VM Player on Ubuntu 14.04.1 LTS. I've seen threads for earlier versions of Ubuntu that say to install build-essential and linux headers first. It appears that linux headers is ...
-1
votes
2answers
34 views

How to: Make a “restore point” in Ubuntu, in case I break something?

How can i make a snapshot, a "restore point" in Ubuntu for when im about to try something I think is clever but turns out to be a "oh crap, not again" ?
1
vote
0answers
43 views

Missing system Settings in 14.04 LTS

I just installed 14.04 and tried talking on Skype but the other party can't hear me. I tried checking the sound settings from System settings and found out that System settings is missing. I ran the ...
0
votes
1answer
48 views

Varnish 4 on 12.04

I would like to use the latest version of Varnish (4.0.1) on precise. I tried following the instructions posted here: https://www.varnish-cache.org/installation/ubuntu apt-get install ...
-1
votes
1answer
391 views

GPG ERROR NO_PUBKEY : WARNING: The following packages cannot be authenticated! [closed]

I have just stared to receive some strange errors regarding GPG keys. Namely I have just added ppa:ubuntu-toolchain-r/test and wanted to update and after that I got this: W: GPG error: ...
0
votes
1answer
45 views

apt-get upgrade gives 'failed: Connection timed out', How to fix this?

apt-get upgrade command giving error: Connecting to archive.getdeb.net (archive.getdeb.net)|144.76.200.19|:80... failed: Connection timed out. I gave the ping command, as follows :: ping ...
-1
votes
0answers
38 views

apt and Ubuntu Software Center can't install or remove any software

$ sudo apt-get install -f Reading package lists... Done Building dependency tree Reading state information... Done Correcting dependencies... failed. The following packages have unmet ...
7
votes
1answer
142 views

“no public key available” while upgrading using update-manager

I decided to upgrade 12.04 to Ubuntu 14.04 latest. I followed... sudo update-manager -d Then it's opening the update-manger GUI. After clicking the upgrade button It's return the below error list: ...
0
votes
0answers
45 views

cannot update or install new packages Kubuntu 14.04.1 after upgrade from 12.04.5

I upgraded my 12.04.5 Kubuntu installation to Kubuntu 14.04.1, but during the installation of packages, two things went wrong. First was a long-named deb package that had "all" at the end of it, which ...
0
votes
0answers
29 views

“php-clamav: depends on: phpapi-20090626+lfs but it is not going to be installed”

I want to install "php-clamav" . But... msy@msy-Inspiron-One-2020:~$ sudo apt-get install -f php-clamav 正在读取软件包列表... 完成 正在分析软件包的依赖关系树 正在读取状态信息... 完成 有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是 ...
0
votes
0answers
25 views

apt-get install nfs-common does not create an idmapd

I am trying to get NFSv4 client to work with idmapd and I try sudo apt-get install nfs-common Unfortunately, this installs the expected files /etc/default/nfs-common, /etc/idmapd.conf etc., but ...