Writing applications for Ubuntu (including Ubuntu Touch) and questions about the application submission process to the Ubuntu Software Center. This covers both open source and commercial applications.

learn more… | top users | synonyms

1
vote
3answers
52 views

Can I find my car with my portable device?

Is there any software on Ubuntu which allows me to find my car with my tablet or cell phone which is running Ubuntu Touch? When I lost my car, I would like to use Ubuntu Touch on my portable device to ...
0
votes
1answer
15 views

How to edit description of a software using Quickly?

By default descriptions of all new Quickly apps are "UNKNOWN" in the debian/control file. Changing that and releasing a new version does not work (It gets reverted). How to edit the descriptions?
3
votes
0answers
108 views

FreshBooks Online Account

I'm developing an application that connects to FreshBook's API. I can either integrate the account authentication process within my application, or I can develop an Online Account that could be used ...
3
votes
1answer
40 views

What does Version mean in the .desktop file?

While submitting an application to the Ubuntu Touch store, I got the following error message. "desktop_Version (Cliffhanger)": { "text": "'0.3' does not match freedesktop.org version '1.0'" } ...
1
vote
1answer
43 views

Ubuntu phone development, where to start? [closed]

I'm a long time Ubuntu desktop user, but new to the development world. I'd like to start getting myself familiar with Ubuntu Touch and learn how to develop apps for it, however I'm a little bit lost ...
0
votes
0answers
128 views

titanium studio in ubuntu 12.04 LTS

how to install titanium studio in ubuntu. step by step the latest one. plss help. im getting an error JVM terminated. Exit code=13 /usr/bin/java -Xms128m -Xmx1024m -XX:MaxPermSize=256m ...
2
votes
1answer
34 views

What does lint_package_filename_version_match mean?

In a review of a .click package of my app, a message contained the following: lint_package_filename_version_match How can I fix it?
1
vote
1answer
27 views

What does desktop_Exec mean?

In a review for my click package, the message contained this bit: desktop_Exec What do I bear in mind to fix it?
2
votes
1answer
21 views

What does desktop_validates mean?

In a review for my click package, I saw a message containing: desktop_validates What does it mean and how do I fix it?
5
votes
1answer
54 views

What does functional_qml_applicationName_matches_manifest mean?

I submitted an application to the click store but it comes back with this error:- functional_qml_applicationName_matches_manifest What does this mean and how do I fix it?
4
votes
1answer
95 views

What does desktop_Icon mean?

I've submitted an app to the software store but it gets sent back with this error:- desktop_Icon What does this mean and how do I fix it?
1
vote
1answer
15 views

What does lint_control_click_version_up_to_date mean?

I submitted an app to the store and it gets rejected with this message:- lint_control_click_version_up_to_date How do I fix this?
1
vote
1answer
32 views

What does lint_package_filename_pkgname_match mean?

I've submitted an app to the click store, but it comes back with this message:- lint_package_filename_pkgname_match How do I fix that?
0
votes
1answer
5 views

What does desktop_Comment_boilerplate mean?

I'm uploading a click package and it's being sent back with the following message: desktop_Comment_boilerplate What does it mean and how do I fix it?
4
votes
1answer
56 views

What does lint_maintainer_format mean?

In a review for my click package, I saw the following message: lint_maintainer_format What does it mean and how do I fix it?
2
votes
1answer
55 views

What does functional_qml_application_uses_QtWebKit mean?

In a review for my click package, I saw the following message: functional_qml_application_uses_QtWebKit What does it mean and how do I fix it?
0
votes
0answers
63 views

Ubuntu touch kernel and android device drivers?

Since the kernel is open source but the android device drivers are not, is there not a way to use existing android drives and compile a new kernel with those drivers like GPS, Bluetooth, Wifi, etc...? ...
1
vote
1answer
79 views

Can't install the Ubuntu SDK due to broken qtcreator-plugin-ubuntu dependency [duplicate]

I tried to install the Ubuntu SDK on my Ubuntu 13.10 Virtual machine(VMwarePlayer) by typing sudo add-apt-repository ppa:ubuntu-sdk-team/ppa && sudo apt-get update && sudo apt-get ...
0
votes
1answer
46 views

I get the following errors when I try to install the Ubuntu SDK (ubuntu app development kit)

I use Ubuntu 12.04. I followed the steps given here . 1)When I try to execute the first step " sudo add-apt-repository ppa:ubuntu-sdk-team/ppa && sudo apt-get update && sudo apt-get ...
1
vote
0answers
39 views

Recommended way to check/fire alarm in Python (PyGI/PyGTK)

I am learning to develop an application by using Quickly (quickly create ubuntu-application). This application will stay in Application Indicator / Notification Bar and only work when a defined ...
0
votes
0answers
122 views

installing ubuntu sdk error

I was trying to install ubuntu SDK. at first I tried: sudo add-apt-repository ppa:ubuntu-sdk-team/ppa sudo apt-get update sudo apt-get dist-upgrade sudo apt-get install ubuntu-sdk and it says: The ...
0
votes
1answer
18 views

Quickly is Not Packaging My Application?

I Can't Package my Quickly Command Line Application , The Following is The Error Output quickly package --verbose shows the following output /host/cryptonite$ quickly package --verbose running ...
1
vote
1answer
214 views

Qt Creator cannot run HTML5 apps on Ubuntu 13.10, is it broken?

When attempting the Ubuntu HTML5 tutorial on the Ubuntu site, I have just created the template app and am attempting to run it. When I run it, I get this error: Starting ubuntu-html5-app-launcher ...
-1
votes
1answer
173 views

Ubuntu terminal commands and usage [closed]

I just got Ubuntu 12.04 yesterday and would like to learn how to use the terminal. The reason why is because I'm a developer and I'm trying to get any applications I develop supported on linux. From ...
1
vote
1answer
142 views

Ubuntu SDK installation error on Ubuntu 13.10

I followed the instructions from http://developer.ubuntu.com/apps/create/get-the-sdk/. But the installation failed with the following message at the end: The following packages have unmet ...
0
votes
0answers
53 views

Cannot install Ubuntu SDK [duplicate]

I get the following error in terminal while installing the SDK W: GPG error: http://ppa.launchpad.net precise Release: The following signatures couldn't be verified because the public key is not ...
0
votes
1answer
39 views

Weight of the commentaries in the source code [closed]

When I search for source-code of Linux parts (applications, kernels, ...), I often find commentaries to clarify the code. Now, I know that those commentaries are useful to help a human reading the ...
0
votes
0answers
50 views

How to use ANT+ radio in Ubuntu Touch?

As the Google Nexus devices tend to all have ANT+ radios in them now, and Ubuntu Touch currently targets these devices primarily, is there a way to access the ANT+ radio and connect and communicate ...
1
vote
0answers
106 views

Specifying Python Distribution in Ubuntu 13.10 (for Continuum Anaconda Python)

I've been trying to install Python on my Ubuntu 13.10 VM. Ubuntu already comes with Python, and when I remove it with apt a lot of other apps get removed. I have installed Continuum's Anaconda ...
1
vote
1answer
136 views

Multi-threading in Gtk python [closed]

I'm trying to display a GUI and do some work in the background.when the window is current window, GUI runs normally. Long after minimizing the window, GUI will freeze. The following code is created ...
2
votes
0answers
22 views

Touch SDK Expansion

In the Ubuntu Touch SDK description http://design.ubuntu.com/apps/building-blocks/expansion there is an UI element which is mentioned, namely the Expansion. From the description I don't really ...
3
votes
2answers
550 views

Why is Python V3.3 installed by default on Xubuntu 13.10?

I am running Xubuntu 13.10, 64 bit. python --version outputs Python 2.7.5+ which is normal since python 2.7 is installed by default on all Linux distros. But when I go to Software center -> and ...
2
votes
3answers
103 views

I have ideas for apps for Ubuntu.

How do I submit ideas for apps? I am not a programmer
0
votes
1answer
70 views

install ubuntu sdk error

I have this error: W: Failed to fetch cdrom://Ubuntu 12.04.3 LTS _Precise Pangolin_ - Release amd64 (20130820.1)/dists/precise/main/binary-i386/Packages Please use apt-cdrom to make this CD-ROM ...
1
vote
1answer
116 views

“sudoing” strategy for python script on ubuntu

I'm creating a small router program (GTK frontend) in python for some of our less CLI savvy users. I've developed the glade front-end and able to connect the various signals. Now, I'm facing only one ...
2
votes
1answer
113 views

Get source code for copy/paste [closed]

Every operation performed by operating system have a source code. So for coping operation there should be source code. So I need a file's name having source code for copy operation.So I can add some ...
1
vote
1answer
107 views

How do I add Webkit webview to the Ubuntu SDK?

I'm trying to do this tutorial for learning and it seems that I have to keep adding things for it to go smoothly. http://developer.ubuntu.com/apps/html-5/tutorial/ I don't have the "rss-sample.qml" ...
1
vote
0answers
28 views

How can I export a .ui file for a pygi window that I build dynamically?

I understand that building things with the MVC mindset is a good thing. I also understand that if you separate code maintenance and UI, that Glade UI files make it easier for non-programming people ...
1
vote
1answer
121 views

How can I create Unity dash integration for my Python script?

I have written an awesome script in Python and I seriously think it should help many rookie Ubuntu users out there -- especially for a quick solution/tip. My script searches through AskUbuntu.com and ...
3
votes
0answers
34 views

High-level library for Unity Dash?

I've wanted to write a GTK+ version of Unity Dash for some time. I think it could be useful for Xfce, Gnome Flashback, elementaryOS, etc. Before I start doing anything about it, I'd like to know if ...
0
votes
1answer
118 views

Simple GUI to display static text informations

I would like to know if there is a way to write or modify a simple program (I don't really care what language it'll use) that can be launched in GUI mode and will display formated text and URL that ...
0
votes
2answers
181 views

How to build gtkparasite

i'm not able to build gtkparasite when i run: ./autogen.sh i'm get this error checking for GTK... no configure: error: Package requirements (gtk+-3.0 >= 3.10.0 gtksourceview-3.0) were not met: ...
0
votes
0answers
30 views

Ubuntu Touch - .ogg Files don't transfer to device

I was making a sample app to handle .ogg files in QT Creator. Everything worked fine on the computer, and when I chose the option to "Run application on device" everything worked perfectly. But when ...
1
vote
1answer
69 views

Ubuntu Touch - Multiple App Windows

I'm learning how to make Ubuntu Touch OS applications, and I looked all over the web for something, but didn't find any satisfying results. This is either because I am the first to ask this question, ...
1
vote
2answers
418 views

Why doesn't `exec startx` work in 13.10?

I am used to being able to launch a second X session in TTY8 with exec startx but instead I'm getting an error: X: user not authorized to run the X server, aborting. And then in TTY 8 I end up with ...
1
vote
0answers
36 views

Problems with GTK

I started working on a project where I need to make a simple interface with C language using GTK, then I need to connect that interface with Linux system, I started working with "Glade" witch is an ...
0
votes
0answers
71 views

Quickly Error “can´t create or update ubuntu package”

Try to build a gmail view app for my owm but by creating a package i get this error. How to fix jeffrey@Chuhundra:~/gmail$ quickly package ...................... Command returned some WARNINGS: ...
-4
votes
1answer
46 views

Publication Lazarus project in Ubuntu Software Center [duplicate]

Can I publish desktop application has developed in Lazarus IDE in Ubuntu Software Center?
1
vote
1answer
92 views

Unable to install ubuntu sdk

While installing sudo apt-get install ubuntu-sdk, I am facing this The following packages have unmet dependencies: ubuntu-sdk : Depends: qtcreator-plugin-ubuntu-cordova but it is not going to be ...
1
vote
0answers
34 views

Using in game ads [closed]

Hi guys just a simple question, I made a game and would like to publish it to Ubuntu App Store, but I am not charging for the game and would like to make some profit, am I allowed to use in game ...