0
votes
0answers
13 views

ubuntu 14.04 apache2 how do I restrict some directories to localhost only

after upgrade from 12.04 to 14.04, my old modified apache2.conf files are in place. I would like to start my configuration over using the default 2.4.7 config files - but I don't want to overwrite ...
1
vote
0answers
19 views

Complete Deletion/Reinstallation of Downloaded Package

I want to know how to delete every file installed by a package using either aptitude or apt-get and then re-download and re-install that package completely again. I've tried doing aptitude reinstall ...
0
votes
0answers
112 views

Unable to reinstall apache on Ubuntu 12.04.5 LTS

Unfortunately, What I did: Updated apt repository to install apache244 and installed it. Uninstalled apache2.4 using following commands: apt-get remove apache* apt-get purge apache* apt-get clean ...
1
vote
1answer
30 views

How To Create A Custom ErrorDocument Page In Ubuntu 14.04?

I am new to Ubuntu and I am using Ubuntu Server 14.04. Now I want to use my own design HTML web pages as my server status errors like on 404 etc. I tried my own way but not getting my designed page ...
0
votes
1answer
80 views

Trying to remove apache2/httpd and installing mod_perl

It started with me trying to install Apache and mod_perl by following this guide. However, foolishly I installed Apache by using sudo apt-get install apache2, which installed 2.4 on my system. ...
0
votes
0answers
11 views

Apache2 updated, but not installed

I started Ubuntu, and it did it's normal update. Three out of the four packages were for Apache2, which I've always been told not to run outside a VM because it can be dangerous. I was surprised ...
0
votes
2answers
93 views

Broken apt-get state after apache install error

I tried to install php5 via sudo apt-get install php5 on my ubuntu 14.04 machine. It didn't install properly, because there were problems with the package apache2. So if I try to install anything, ...
1
vote
0answers
53 views

Why my apache service does not work correctly?

I am just a newbie using Ubuntu 12.04 LTS. In the beginning, I just want to install mcrypt, I followed this solution: cd /etc/php5/mods-available ln -sf ../conf.d/mcrypt.ini . php5enmod mcrypt ...
0
votes
0answers
9 views

Trouble installing apache2 on ubuntu 13.10 [duplicate]

When I try to install apache2 sudo apt-get install apache2 I get this error. I suspect this has something to do with trying to install Skype 32-bit on my 64-bit system. Why is it trying to tell me ...
0
votes
0answers
31 views

install php5-curl without upgrading php-cli

I am using imageantialias for php and php -r "var_dump(function_exists('imageantialias')); returns bool(true) I do have requirement for php5-curl, and if I install php5-curl using php5-curl (sudo ...
1
vote
3answers
190 views

apache2 not starting after purge and re-install

First of all - I have looked and tried several approaches including Apache server not starting I am using Ubuntu 14.04 64 bit I had purged using an answer at serverfault sudo service apache2 stop ...
1
vote
0answers
165 views

Subdirectories Show 404 Not Found on 13.10 web server

I recently set up a web server on Ubuntu 13.10 and when I enter the external IP it works fine showing the index file of var/www/ but whenever I try to add a folder, say one called test, and I go to ...
0
votes
2answers
594 views

owncloud -problem installing packages

I have just installed these packages for building my owncloud, but always get an installation aborted error: rqie@rqie-VirtualBox:~$ sudo apt-get install apache2 php5 php5-json php5-gd php5-sqlite ...
0
votes
0answers
140 views

Trying to install libapache2-mod-wsgi on Ubuntu 12.04, but it says I have unmet dependencies

I have upgraded my server from Ubuntu 10.04 to 12.04, but when I run Apache2, it doesn't understand WSGI, I I tried to install it with: # apt-get install libapache2-mod-wsgi It complained, saying: ...
1
vote
1answer
1k views

Apache2 re-install error

I am trying to re-install apache2 on my Ubntu12.X machine. I had apache2 before but due some reasons I have uninstalled. I use apt-get purge to remove apache tomcat but while re installing I am ...
1
vote
1answer
2k views

How to get latest Wordpress on 12.04.4 LTS

I have a server running Ubuntu 12.04.4 x64 , and want to install latest wordpress. I have two options use apt-get to install the package (sudo apt-get install wordpress) install the latest version ...
0
votes
1answer
60 views

apt-cache show specific dependencies

It would appear that it specifies that the following dependencies are installed: 2.4.6-2ubuntu4 2.2.22-1ubuntu1.4 2.2.22-1ubuntu1 Why does the apache2 package consist of sub dependencies ...
1
vote
0answers
128 views

Can't purge mysql-server installation

Since I've got no privileged user in my current MySQL-installation on 12.04 LTS I want to re-install the mysql-server completely by using: sudo apt-get purge mysql-server After a very short while I ...
0
votes
0answers
289 views

How to give an “503 Service Unavailable” error while apache is being upgraded by apt-get

I have an Ubuntu 12.04.3 LTS server (precise). Whenever apache2.2 is being updated by an apt-get upgrade command, the HTTP server is shut down, so the clients cannot connect at all during anything ...
0
votes
1answer
592 views

Can't Install php5-msql

Hello friends I'm finishing the process of installing Apache/Php/mysql installations but this shows up: # sudo apt-get install mysql-server php5-msql Reading package lists... Done Building ...
2
votes
1answer
2k views

Ubuntu 12.04: cannot install apache2-common

I've just upgraded to 12.04 from 10.04, and upgraded apache2. I ran into the following: While trying to install passenger, it complained that apache2-prefork-dev was missing. sudo apt-get install ...
0
votes
0answers
97 views

Apache still running after uninstalling

I am trying to uninstall apache to install nginx, but it doesn't seem to work. $ ps aux | grep httpd root 22348 0.0 0.2 167252 8864 ? Ss 14:33 0:00 /usr/sbin/httpd -k start -DSSL ...
0
votes
0answers
339 views

apt-get unmet dependencies apache2 mod-auth-mysql

After updating from Ubuntu 11.10 to 12.04 i got some package dependency errors with apache and the mod_mysql_auth: root@ks3275586:/etc/apache2 apt-get install libapache2-mod-auth-mysql Reading ...
1
vote
2answers
2k views

“Invalid command 'Order'” after deleting /etc/apache2

I'm having a hell of a time setting up a dev environment for Wordpress. I messed everything up a couple weeks ago and this afternoon wanted to start over. I tried to reset Apache by uninstalling ...
0
votes
1answer
4k views

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

I am using ubuntu 13.10 on evaluation board and my internet is not working. Also i need to install softwares and apt-get install is also not working. Terminal says : E: Unable to fetch some ...
1
vote
0answers
492 views

Problems with php-Server (Now: Broken Apache2) - “Unmet Dependencies" - Ubtuntu Server with Plesk

I have a Ubuntu Server with Plesk insalled. My Englisch and my "linux" ist not very great! Since a few Days my PHP doesn't work. If i load a php site my Browser download the php file instead of ...
1
vote
1answer
3k views

Update Apache 2.2.22 to 2.2.25

I need to update Apache to version 2.2.25 on ubuntu 13.04 I have tried installing the update from apt-get but the package is showing as 2.2.22 Can anyone help?
0
votes
2answers
1k views

What Package is '/usr/sbin/apache2' part of?

After I installed Apache trough the command sequence you can find below, it gave me an error: /usr/sbin/apache2ctl: 171: /usr/sbin/apache2ctl: /usr/sbin/apache2: not found. After some Googling I found ...
0
votes
1answer
82 views

How do I reinstall everything Ubuntu related software on my system?

Yesterday, I was tired and I did something pretty stupid. Apache wasn't working, so I decided to reinstall everything related to apache2. So I began by removing apache2 and then did the following: ...
0
votes
1answer
80 views

php version in apt - does it correspond to version on php.net and if not how to upgrade to latest release [duplicate]

So I'm setting up a lamp web server based on ubuntu 13.04 raring. I've installed all required software and run apt-get update and upgrade. When I run php info it reports php version 5.4.9-4ubuntu or ...
0
votes
2answers
2k views

PHP Fatal error: Call to undefined function mysql_connect() [duplicate]

I'm trying to connect my PHP page to MySQL database, but I'm getting this error : PHP Fatal error: Call to undefined function mysql_connect() I'm working on Ubuntu 11.10 MySQL 5.5 and PHP 5.3. I ...
0
votes
3answers
4k views

Can't find Skype package through software center - apt-get, Canonical partners' box uncheckable

I did a fresh install of Ubuntu 12.04 lts on my computer.One of the first things I wanted to do was to install skype. However I could not find skype in the software center.And when I tried to install ...
0
votes
1answer
129 views

Differences between “apache”'s installations

Are there any differences between installing Apache httpd using sudo apt-get install apache2 (as the guide of Ubuntu says - https://help.ubuntu.com/12.04/serverguide/httpd.html ) or following the ...
22
votes
5answers
73k views

Permanently removing apache2

It seems a simple apt-get remove apache2 does not completely remove apache2 as I can still see it on one of the processes when running top. How does one remove apache2 completely on his ubuntu server? ...
1
vote
1answer
995 views

Why do apache2 upgrades remove and not re-install libapache2-mod-php5?

We repeatedly see that when an apache2 update arrives and is installed it causes the libapache2-mod-php5 package to be removed and does not subsequently re-install it automatically. We must ...
2
votes
1answer
1k views

Why do I have to install apache2-utils when installing node.js?

I'm about to install node.js (Question about installing). It says that I have to install some packages first for using git and stuff if I'm running a clean server, which I actaully do: sudo apt-get ...
2
votes
1answer
6k views

Completely uninstallation LAMP

I just install LAMP by using a command line. sudo apt-get install lamp-server^ it's work! then I needed to uninstall them so I tried to sudo apt-get remove lamp-server^ by the way, It's show me to ...
0
votes
1answer
379 views

Why does my apache still do nothing after a complete purge and reinstall?

I followed this guide, to the best of my understanding: https://help.ubuntu.com/community/ApacheMySQLPHP And I'm stuck right after the install. Here's what I did so far: since I already had a ...
1
vote
1answer
1k views

Missing python.h when trying to install Apache Thrift

I have tried many times over to install Thrift (http://thrift.apache.org/) in Ubuntu Server. I tried it on two machines... And one I had nothing on it before; meaning fresh Ubuntu installation. I ...
6
votes
1answer
6k views

Install mod_jk with apt-get

Is it possible to install mod_jk via apt-get? If yes, what is the name of the package?
16
votes
4answers
36k views

How can I reinstall Apache HTTPD after deleting some of the configuration files?

I recently was messing around with my Apache config and wanted to reinstall so I could start from fresh. I followed some forum posts about reinstalling the apache2 package and this ended up deleting ...
3
votes
1answer
3k views

Why can't I purge apache2.2-bin and apache2.2-common?

I have tried to completely remove apache2.2 from my system. But the only thing that happens is that apt-get will remove "apache2-mpm-prefork" and install "apache2-mpm-worker". I have killed all ...
2
votes
5answers
5k views

Unconfigured package error: Package apache2.2-common is not configured yet

While executing apt-get install python-setuptools or apt-get upgrade, there are about a dozen of dependency errors, the top three are: apt-get install python-setuptools Reading package lists... ...