0
votes
0answers
22 views

Building reverse engineered project

I learn development for android, I would like to see how certain application is built, I also would like to adjust its UI controls positions for sole use. So, I decompiled the application and try to ...
0
votes
0answers
13 views

Create socket on local computer to access device shell via adb

I'm writing an application and one of the things i'm trying to do is give the users access to the devices shell(via adb -s DEVICE_NAME shell) but over telnet/ssh. meaning, is there any way to create a ...
1
vote
1answer
375 views

JDK 8 Installation for Ubuntu 14.04 (Android Studio & NetBeans)

I downloaded jdk-8u11-nb-8-linux-i586.sh and installed it in my home folder. Then I install NetBeans, it is successful I think because I can compile my java code using netbeans. Now when I install ...
0
votes
0answers
109 views

libGDX project generator: Build Failed : Cannot find java system compiler

while generating a project libGDX throws thid error: FAILURE: Build failed with an exception. * What went wrong: Execution failed for task ':core:compileJava'. > Cannot find System Java Compiler. ...
1
vote
0answers
127 views

Can Ubuntu for tablets run Java applets?

Can Ubuntu for tablets run JAVA applets in browser? My bank has netbanking build in Java and I need to use it on my android tablet which does not support Java browser applets. Don't have experience ...
1
vote
1answer
5k views

How to set the JDK for Android Studio?

I can't compile a default new project for Android 2.1 because(?) the JDK used by Android Studio is JDK 1.7 but it should be JDK 1.6. To change it I go to File -> Project Structure and try to find the ...
0
votes
0answers
447 views

I can't run FlashTool on ubuntu-gnome 14.04

I try to run Flashtool 0.9.16 on ubuntu-gnome 14.04 but if I run as Root then it return this error gelasak@gelasak-GA-MA785GT-UD3H:~/FlashTool$ sudo ./FlashTool Running as root. JAVA_HOME not set. ...
1
vote
2answers
48 views

Install Java 6 for a single project while leaving the default for the rest of the system at Java 7

In order to install a development environment for an older version of Android, I need to have Java 6 installed. I already, however, have Oracle Java 7 installed on my system and would like to keep it ...
0
votes
0answers
197 views

Problem with setting up path in Eclipse for sdk

I am currently working on Ubuntu 12.04 LTS and I have installed Eclipse from the Ubuntu Software Center and then according to the procedure suggested I dealt with the ADT. Next I had to install SDK ...
-1
votes
1answer
83 views

How to set up an environment to develop Android apps in Ubuntu that doesn't have internet Connectivity?

I have an Ubuntu laptop in which I need to develop Android apps. I know that all that software could be downloaded from the software center but the problem is that I don't have internet connectivity ...
0
votes
1answer
531 views

Installed libgdx and OpenGl in ubuntu

first let me say thanks for all the help in my other questions; the answers have really help a lot. Now I'm in the process in developing game for tablet, pc and android platform. I have decided to ...
0
votes
1answer
1k views

export PATH doesn't work correctly

I have a problem with $PATH export. The only place I found where I modify $PATH is /etc/environment: ANDROID_HOME="/opt/ADT/adt-bundle-linux-x86_64-20130522/sdk" ...
1
vote
1answer
509 views

Android sdk manager permission denied

I am setting up eclipse and ADT everything is working fine JAVA, android virtual devices and everything except the ADT sdk manager it says permission denied. /home/yousaf/android-sdks/tools/android: ...
0
votes
2answers
3k views

Setup JDK for android studio

I was setting up android studio and got this So I followed the answer here and used sudo update-alternatives --set java /usr/local/java/jdk1.7.0_17/jre/bin/java sudo update-alternatives --set ...
0
votes
0answers
35 views

Problem in opening SDK manager in Eclipse

When I click on Android SDK manager, a window pops up and says opening SDK manager shortly but then the window collapses and nothing happens
3
votes
1answer
2k views

Eclipse Kepler crashes without any log entry [duplicate]

I'm using Ubuntu 13.10 Saucy Salamander 64bit and Eclipse Kepler 64bit terminates after some random time without response. The windows simply disappears. There's also no entry about the crash in ...
0
votes
1answer
2k views

Remove Openjdk 7, install Openjdk 6?

I need to be using Openjdk 6 but cannot figure out how remove Openjdk 7. I used the apt-get purge command and it seems to be successful but even after installing Openjdk 6, java -version always ...
0
votes
1answer
1k views

Eclipse no longer useful

When I got my Eclipse from the Ubuntu Software Center, it was good and worked fine. I could work on Java projects fine. This week I was required to add ADT and tried the ADT-bundle, assuming it had ...
2
votes
1answer
649 views

How come I cannot make this file executable (chmod permissions)?

I downloaded Android Development Tool for linux (ADT) and placed it in home directory. After unzipping the files, when I double click the "eclipse" executable file; the eclipse works perfectly fine. ...
2
votes
0answers
144 views

I tried to transplant the wireless_tools to Android4.0 system, but I have a problem with Java

My Linux system is Ubuntu Kylin, a new branch of Ubuntu spreading mainly in China. I have changed some files, such as wireless.22.h, ifrename.c and iwlib.h, in wireless_tools.29/ which is located in ...
6
votes
1answer
22k views

“Please ensure you have JAVA_HOME points to JDK rather than JRE” message

I have java installed aaa@ubuntu:~$ whereis java java: /usr/bin/java /usr/bin/X11/java /usr/local/java /usr/share/java aaa@ubuntu:~$ whereis javac javac: /usr/bin/javac /usr/bin/X11/javac and ...
2
votes
1answer
3k views

How can I remove my current JDK and install default JDK? [duplicate]

I have Ubuntu 12.10 x64 installed on a virtual device (VMware workstation) on a host system Windows 8. I downloaded android source code. I wanted to build it, and it says: Checking build tools ...
0
votes
2answers
2k views

How can I uninstall my current java and install sun java 1.6

I installed jdk using the following command: sudo apt-get install default-jdk but it is the wrong version. I need Java SE 1.6 for building Android. When I try building Android, I get a ...
2
votes
2answers
514 views

building android filesystem

while building android filesystem, i am getting an error as You are attempting to build with the incorrect version of javac. Your version is: javac 1.7.0_12-ea. The correct version is: 1.6. Please ...
1
vote
1answer
2k views

Having trouble running android sdk tool on 12.10

When I try to run the Android SDK Manager from the command line it doesn't open. Keeps giving me command not found or permission denied message like so. ...
6
votes
1answer
4k views

No Android SDK, neither Java found

I have Java installed correctly, I did it by the manual http://www.wikihow.com/Install-Oracle-Java-on-Ubuntu-Linux I also installed Android SDK. However when I try to create a new Project IntelliJ ...
0
votes
2answers
459 views

Problem by installing Java

Yesterday night I was trying to download Java as per instructions given on http://developer.android.com/ .But I messed up somewhere and had to give up the thing. But since morning when ever I try to ...
2
votes
1answer
5k views

Exception in thread “main” java.lang.NoClassDefFoundError: Finger

I´am trying to use this Finger.java for my Android project, But I get this error. $java Finger username@host.com Exception in thread "main" java.lang.NoClassDefFoundError: Finger Caused by: ...
1
vote
2answers
1k views

When I run Android SDK from terminal, it shows error. How to fix it?

Exception in thread "main" java.lang.UnsatisfiedLinkError: no swt-gtk-3550 or swt-gtk in swt.library.path, java.library.path or the jar file at org.eclipse.swt.internal.Library.loadLibrary(Unknown ...
2
votes
1answer
827 views

Can anyone help me through the preparation of Eclipse IDE for an Android developer in Ubuntu 12.04?

I'm new to to Linux, in this particular case, to Ubuntu. I have a small android project I have to finish until this Friday and I'm still stuck with the install and preparing of the development ...
1
vote
2answers
981 views

Failed to parse Adb version -Wrong ELF Class

My PC CONFIGURATION : UBUNTU 11.10 version 64 bit , ECLIPSE 3.7 , ANDROID SDK I tried hard to remove adb error but itsms not working and showing following Errors: /platform-tools/adb:Error While ...