The Advanced Linux Sound Architecture (ALSA) provides audio and MIDI functionality to the Linux operating system.

learn more… | top users | synonyms

0
votes
0answers
18 views

Sound is not working in Ubuntu 16.04

I am Using ubuntu 16.04 on ASUS X555L. sound was working correctly but instantly it just not working. I have try every possible solution given on internet but still blank . My sound setting does not ...
1
vote
2answers
13k views

How can I reinstall pulseaudio? (12.04 64bit)

I accidentally removed pulseaudio from my Ubuntu 12.04 64bit. I have tried reinstalling it using sudo apt-get install pulseaudio but my sound card doesn't appear in the list of the devices (in ...
2
votes
1answer
4k views

ALSA samples capture: cannot open device

I'm quite new to Linux (Lubuntu 12.04 for sake of precision) and ALSA programming at all. I'm trying to write a C program to capture audio from internal PC microphone for processing it. So as first ...
1
vote
0answers
46 views
+50

How to Configure ALSA in Ubuntu 16.04 for Matlab?

Situation: unable to configure ALSA in Ubuntu 16.04 for Matlab 2016a System characteristics /proc/asound/cards 0 [HDMI ]: HDA-Intel - HDA Intel HDMI HDA Intel HDMI at ...
6
votes
1answer
2k views

Alsa problems with python2.7- Unable to open slave

I am using python's module pyaudio to process sound but ALSA returns: ALSA lib pcm_dsnoop.c:618:(snd_pcm_dsnoop_open) unable to open slave ALSA lib pcm_dmix.c:1022:(snd_pcm_dmix_open) unable to open ...
0
votes
0answers
20 views

Sound problems with intel DG41WV (alc888, intel hdaudio)

I recently built a basic pc for home use (core2duo E8500, Intel DG41WV (with realtek alc888 audio), 2G DDR3 1066 ram, 250G WD HDD), and installed ubuntu 14.04.02 on it. Everything went smoothly, but ...
3
votes
2answers
54 views

Persistent Dummy Output

The soundcard I want to use is detected and works (it only recently switched to dummy output and didn't allow me to go back). HDMI is no longer listed under Audio and Video - KDE Control Module; ...
0
votes
1answer
493 views

Ubuntu 14.10 Sound not working! [on hold]

My system sound seeting shows Dummy Output in Settings-->Sound and no Sound-cards is recognized by ALSA. Here is my Alsa Bug Report. I need help in fixing my sound-card problem?
0
votes
0answers
28 views

Jack audio suddenly does not work on Ubuntu 16.04

I am using Ubuntu 16.04. Audio was working perfectly, even jack, I was able to listen to music using headphones or external speakers. Today I tried to install tuxguitar from its .deb installer and ...
8
votes
5answers
20k views

“Dummy Output” sound in Ubuntu 14.04

None of the other questions about this have solved my issue. I'm using a Dell Inspiron N5110. The sound on my Ubuntu 14.04 is driving me crazy. It works and doesn't work randomly as I turn my PC on. ...
0
votes
0answers
25 views

ubuntu 14.04 lts audio stopped working

Audio just stopped working. I reinstall alsa. also I did this: aplay -l aplay: device_list:268: no soundcards found... sudo apt-get remove --purge alsa-base pulseaudio sudo apt-get install alsa-...
0
votes
0answers
8 views

Acer notbeook speakers occasionally make silent cackling noise when there is no output on 16.04

I have an Acer Aspire E5-773G running Ubuntu 16.04. Both the left and right speaker make sometimes pretty silent crackling noises. At first I perceived it as HDD sounds, but the HDD was not in use ...
5
votes
1answer
6k views

play audio through bluetooth speakers in 12.04 using CLI

I have gone through the whole gamut of trials with setting up playing audio through bluetooth and have not been able to make it work reliably (i.e., got it to work one time, and has not worked after ...
1
vote
3answers
5k views

Ubuntu 14.04 Pulseaudio in HDMI sound crackling

I've recently change my PC OS from MS to Ubuntu. Ubuntu 14.04 can correctly find my HDMI audio but with terrible echo and crackling sound. I fix the echo issue by following the guide here: Sound ...
0
votes
0answers
13 views

Music players with ALSA output option

Currently using kubuntu 16.04 with deadbeef player. I would really like different gui cause of the ammount of music on my drive, deadbeef is not a good idea when you have 1tb+ music. I've tried ...
4
votes
1answer
10k views

ALC892 Low sound issue fixed with changing alsa config, why does it work?

I updated to 14.04. My sound immediately transitioned from being normal to sounding extremely quiet, sounding like it was at 5% of max volume, though all my volumes were set properly. I tried lots ...
0
votes
0answers
25 views

Vokoscreen Microphone Audio Not Working

Ok, so recently, I decided to start making youtube videos using a screen recorder. I had previously tried several other Linux distributions, but am now using Xubuntu 16.06 LTS 32-bit on a Dell d410. ...
0
votes
0answers
14 views

Sound Goes Out In Ubuntu 16.04 But Works From Headphones

When I start Ubuntu 16.04 (I dual boot with Windows 7) the sound works from both the headphones and speakers. I can listen to music, watch YouTube videos, and test the sound. After a while, (I don't ...
0
votes
0answers
22 views

Sound coming from both the headphones and speaker on ubuntu 16.04

When I plugin my headphones through the front jack in my desktop my speaker does not auto mute and sound comes from both in Ubuntu 16.04. When I open the alsamixer program through terminal, I see ...
0
votes
0answers
30 views

Headphone Jack causes immediate shutdown

Every time I plug in my headphones into my laptop, its seems to power-off immediately after about 1.5-2 seconds. I have tried this with several other Linux distributions and they have all failed, so I ...
0
votes
0answers
17 views

Trying to use squeezelite with existing PulseAudio outputs

So I am trying to set up a squeezebox (Logitech media server) client using squeezelite on my Ubuntu 16.04 install, and am having some trouble getting what I want out of it. What I am trying to ...
0
votes
0answers
397 views

AUDIO PROBLEMS: Sound Stopped Working After Reboot!

As the title says, my sound has stopped working after a reboot. This is a new system (one-week old hardware, fresh install of Kubuntu 15.10). Linux audio is quite complicated, and I've tried my best ...
1
vote
1answer
62 views

mpd -> jackd -> usbaudio out

I am attempting to control my stereo from my Android phone, using mpd. I have an Ubuntu 16.04 box hooked up to the stereo system, via a USB -> Toslink -> DSP -> amps route. I am trying to drive ...
0
votes
1answer
62 views

miniDSP usbstreamer b and Ubuntu?

Has anyone had success streaming music via a miniDSP usbstreamer b unit? I'm attempting to cut out an extraneous digital->analogue conversion in my laptop-powered stereo system. The usbstreamer b ...
0
votes
0answers
17 views

Huge amount of static/echo over microphone

My microphone regularly bleeds through large amounts of static and the overall quality is terrible. I've tested all the hardware on windows with no problems, so the hardware is fine. I tried using a ...
3
votes
1answer
5k views

no sound in Ubuntu 12.04 and /dev/dsp does not exist

Computer isn't playing audio. I've checked the hardware volume buttons, pavucontrol, and alsamixer. Nothing is muted. I've added the ppa sudo add-apt-repository ppa:ubuntu-audio-dev. I've also done ...
2
votes
1answer
28 views

How to use alsa systemwide and still have a volume tweak

I have found that using alsa and not pulseaudio greatly improves the quality of my sound. I tested this using DeadBeef and "direct ALSA output". I'd like to have my entire system use ALSA directly ...
0
votes
1answer
30 views

No bass from my laptop's build in subwoofer on Ubuntu GNOME 16.04 LTS

I recently installed Ubuntu GNOME 16.04 LTS on my laptop, running alongside Windows 10 on UEFI, but I run into a few problems. Most of them are fixed now but one thing that bothers me is the fact that ...
2
votes
1answer
512 views

Headphones is not working in 15.04 Dell XPS 13

After upgrading to 15.04 , my headphones don't work, how to fix it? When I type command alsamixer , I see something strange:
1
vote
0answers
22 views

Sound on speakers, but headphones don't work on Asus X553M [Ubuntu 14.04.1]

I'm having a big problem with my headphones on partner's notebook: it's running on dual boot (Win10 and Ubuntu 14.04.1) and although sound works fine on speaker, it doesn't work on headphones. I've ...
1
vote
1answer
11 views

Earphone jack not working on Samsung All-in-one PC

I have looked at the answers given in the forum, but it seems one needs pc-specific solutions? Ubuntu 15.10 installed on a Samsung DP500A2D All-in-one-pc Here are the alsa info: http://www.alsa-...
0
votes
0answers
55 views

Audio devices detected, but no sound outputting

I cannot seem to get any audio outputting from my computer. Things I've already tried: Alsamixer (un-muting everything) PulseAudio Mixer (testing different devices) Setting my snd-hda-intel to ...
0
votes
1answer
60 views

No Audio from Ubuntu 14.04 installed Dell Optiplex 7040 PC

We have Dell Optiplex 7040 PC. Everything works fine in factory installed Windows 7 OS. However we installed Ubuntu 14.04 on it. And now there is no audio from speakers as well as from headphones. I ...
0
votes
2answers
75 views

Ubuntu 16.04: cannot turn audio back on

I recently changed the settings of my audio driver to play 24 bit / 96 Hz tracks. After a reboot, when I tried to play sound again, I noticed that the audio is muted and cannot be turned on again. I ...
0
votes
0answers
17 views

RPi 3 Pianobar Alsa message

I have been able to install a working PianoBar configuration but with every song, station, or command in the cli box a message pops up: ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM cards....
0
votes
1answer
24 views

Sound issue in ubantu 14.04 LTS

when I first install Ubuntu in my notebook I can heard the sound in both headphone and also in system speaker. But now I am not hear any sound in my laptop. Whenever I launch the command sudo apt-get ...
6
votes
6answers
39k views

Setting the default ALSA device for Pulseaudio

I recently got an external soundcard/DAC (Fiio E17) and am currently trying to properly configure it on my Ubuntu 12.04 installation. When plugging it in via USB, it's immediately recognized and shows ...
0
votes
0answers
70 views

SonicMaster subwoofer doesn't work on Asus N56DY (Ubuntu 16.04)

I have installed Ubuntu 16.04 on my Asus N56DY and now external subwoofer doesn't work. What should I do to fix it? $ lspci | grep Audio 00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] ...
0
votes
0answers
38 views

Fixing Intel 24-n014 speakers? (Conexant CX20753/4)

I have had trouble with these speakers since installing Ubuntu. I dual-boot Ubuntu with Windows 10. The speakers are, on the Windows boot, managed by the pre-installed Bang and Olufsen audio manager....
1
vote
1answer
529 views

16.04 ALSA / Radeon R9 380 HDMI Audio

I recently upgraded from Ubuntu Studio 15.10 to 16.04, and audio output from my GPU's HDMI port no longer seems to work at all. Output from alsa-info.sh can be found here, which includes aplay -l ...
1
vote
0answers
18 views

Pulse audio error module-echo-cancel.c not found

I am trying to activate echo cancel module . i added the line load-module module-echo-cancel But when i try to restart now the pulseAudio i get the error saying E: [pulseaudio] module-echo-cancel.c:...
0
votes
0answers
20 views

Q: I want to use SPDIF to output DTS 5.1 audio at 96Khz to Z5500 sound system using Ubuntu 16.04

I want to output audio to a Logitech Z-5500 using SPDIF DTS 5.1 at 96 Khz I use the integrated audio card on an ASUS P8Z77-V Deluxe and I use Ubuntu 16.04 x86-64 Is there a easy way to do this?
0
votes
2answers
272 views

Ubuntu thinks my Audient iD14 audio interface is Analogue Surround 4.0 when it's actually stereo. Is there any way to fix this?

I'm using an external Audient iD14 audio interface with a Windows 10 and Ubuntu 14.04 dual boot system. I mainly use Windows for FL Studio and the Adobe Creative Suite, but I like to mess around with ...
4
votes
2answers
4k views

Ubuntu sound volume is 40% lower than in Windows

I have 2x 2.1 speakers connected to the computer where I have Ubuntu 12.04 installed. On the software side I've set all the volume controls to 100% with the alsamixer program. The speakers have ...
0
votes
0answers
29 views

No audio after unlocking screen on Intel Graphics HD 520 (NUC6i3syk)

I just installed 16.04 on my NUC 6i3SYK. It has integrated Intel Graphics HD 520 with an HDMI output, which I've plugged into my TV. After locking the screen and letting the TV turn off, then ...
0
votes
0answers
38 views

How to make ALSA default to HDMI and use internal speakers if it's not available?

First of all, I have problems with pulseaudio, after some time it becomes very choppy and loads one core to 100%. From the fact that if I open systemsettings5 at this time the active sound output is ...
1
vote
1answer
132 views

Microphone is not working in Ubuntu 14.04.04 LTS

Microphone is not working in my Ubuntu 14.04.4 LTS. I've tried a bunch of ways that I picked from internet. alsamixer seems not updating the mic volume I've increased and is always zero on each reboot....
3
votes
0answers
43 views

No HDMI sound on Nvidia card on Ubuntu but no problem winth windows

Tested Mint 17,ubuntu 14LTS,kubuntu 16LTS,currently on ubuntu 16LTS. Nvidia driver installed. Checked alsamixer for muted device & unmuted them. pavucontrol shows all HDMI output unplugged. In ...
1
vote
0answers
21 views

Alsa chroot java program doesn't find microphone

I made a chroot environment from an architecture i386. Now I installed ALSA on it (alsa-base, alsa-utils, asound2). I mounted the proc,sys and dev directory too. Then I tested my microphone with the ...
0
votes
0answers
42 views

Unable to use Speech recognition module in Ubuntu 15.10

I am trying to use speech_recognition module in python 2.7, everytime when I import speech_recognition I get the following errors: $ sudo python2.7 -m speech_recognition [sudo] password for ...