The Advanced Linux Sound Architecture (ALSA) provides audio and MIDI functionality to the Linux operating system.

learn more… | top users | synonyms

0
votes
0answers
7 views

How to make ALSA default to HDMI and use internal speakers if it's not available?

First of all, I have problems with pulseaudio, after some time it becomes very choppy and loads one core to 100%. From the fact that if I open systemsettings5 at this time the active sound output is ...
1
vote
1answer
122 views

Microphone is not working in Ubuntu 14.04.04 LTS

Microphone is not working in my Ubuntu 14.04.4 LTS. I've tried a bunch of ways that I picked from internet. alsamixer seems not updating the mic volume I've increased and is always zero on each reboot....
2
votes
0answers
16 views

No HDMI sound on Nvidia card on Ubuntu but no problem winth windows

Tested Mint 17,ubuntu 14LTS,kubuntu 16LTS,currently on ubuntu 16LTS. Nvidia driver installed. Checked alsamixer for muted device & unmuted them. pavucontrol shows all HDMI output unplugged. In ...
0
votes
0answers
9 views

No audio on Intel Graphics HD 520 (NUC6i3syk)

I just installed 16.04 on my NUC 6i3SYK. It has integrated Intel Graphics HD 520 with an HDMI output, which I've plugged into my TV. $ aplay -l gives **** List of PLAYBACK Hardware Devices **** ...
1
vote
0answers
14 views

Alsa chroot java program doesn't find microphone

I made a chroot environment from an architecture i386. Now I installed ALSA on it (alsa-base, alsa-utils, asound2). I mounted the proc,sys and dev directory too. Then I tested my microphone with the ...
0
votes
0answers
25 views

Unable to use Speech recognition module in Ubuntu 15.10

I am trying to use speech_recognition module in python 2.7, everytime when I import speech_recognition I get the following errors: $ sudo python2.7 -m speech_recognition [sudo] password for ...
3
votes
2answers
1k views

Sound only out of internal speakers, never headphones (Alienware laptop, Ubuntu 15.10)

Alienware 17 r3 laptop, internal speakers work fine, headphone jack(s) seem to be ignored, so I can't get sound to an external speaker. (The Alienware has a second "microphone" jack, which apparently ...
0
votes
0answers
5 views

Analog headset Intel PCH ALSA suddenly mono

On a MacBook Air (11-inch, Mid 2011) with i7-2677M and the Cirrus 4206BCNZ audio controller on Ubuntu 16.04 GNOME 4.4.0-24-generic: Suddenly occuring problems after no apparent change: Analog ...
0
votes
1answer
12 views

Ubuntu 16.04: Recording from the output port of an Alesis DM6 drums to the headphone/mic input of an HDA Intel PCH onboard sound card

I am trying to record the sound of my eletronic drums Alesis DM6, which has an output port(jack connection), connecting it to the headphone/mic input from my laptop, which has an HDA Intel PCH onboard ...
2
votes
1answer
1k views

usb audio interface not recognized by alsa

after reading a lot of recommendations I finally bought a Focusrite Scarlett 2i4 and installed ubuntu studio. I am running unbuntu 14.04 on a amd64 desktop. $ uname -rvi 3.13.0-46-generic #76-Ubuntu ...
2
votes
0answers
44 views

ALSA Keeps Throwing Me Errors, really Frustrating

The Situation So my sound cards aren't totally fried, and everything works fine, it's just annoying when working with python scripts and Speech Recognition for Python. This being the result of my ...
-2
votes
0answers
13 views

Jack Sense won't work and Speakers Still work

I have problems with the jack sense. When i conect my headphones, the speakers still Enabled and it is a busy to me. I don't think about of how to solve this problem!
0
votes
0answers
40 views

Audio devices doesn't work Xenial 16.04 GNOME

I've followed the steps in this page: https://help.ubuntu.com/community/SoundTroubleshootingProcedure But can't get managed to work the sound system as in willy 15.10 (worked flawlessly) I've ...
0
votes
0answers
16 views

Alsamixer automatically sets headphones volume at 0 after login

On two of my devices (both eee PCs) sound never works automatically. Eventually, I found the problem to be headphones volume being at 0 in Alsamixer. To solve the issue, I always have to run Alsamixer ...
1
vote
0answers
23 views

Headphones automatically mute when plugged

Since I've upgraded to Ubuntu 16.04 LTS I have the following problem: When I plug in the headphones they are muted and to resolve this I have to un-mute the "speaker" in alsamixer, as seen in the ...
1
vote
2answers
2k views

Sound static in VLC Ubuntu 12.04

When I set the audio output module to Pulseaudio, Audio memory, or Open Sound System, the sound works sometimes, but usually is very staticy. If I switch to Alsa, the sound works fine, but if I pause ...
1
vote
0answers
15 views

Firewire audio puzzle: works in Xenial but

It doesn't seem to be a variant of other questions on firewire. Basicaly, my FW Solo works in Ubuntu 16 with pulseaudio (playback only but it's ok for my needs). But... it has to be initialized by ...
1
vote
0answers
36 views

Headphones not working on Ubuntu 16.04 installed on Alienware 17 R3

I own a Sony MDR-XB450 headphones and it is not being detected. Sound keeps playing through external speakers Alsamixer gives the details as below Card: HDA Intel PCH Chip: Creative CA0132 I can mute/...
0
votes
1answer
79 views

Suddenly no sound; aplay mentions xcb_connection_has_error

Ubuntu 16.04 (unity): sound disappeared all of a sudden. The only unusual observation is xcb_connection_has_error in: # aplay -l **** List of PLAYBACK Hardware Devices **** xcb_connection_has_error()...
10
votes
4answers
526 views

16.04 Headphones detected, but not switched on automatically after startup

I have this issue since 15.10, but it started to really grind my gears after making an upgrade to 16.04. Let's say that I have headphones plugged in. I reboot\relog on\boot to ubuntu, and play the ...
1
vote
2answers
13k views

How can I reinstall pulseaudio? (12.04 64bit)

I accidentally removed pulseaudio from my Ubuntu 12.04 64bit. I have tried reinstalling it using sudo apt-get install pulseaudio but my sound card doesn't appear in the list of the devices (in ...
0
votes
0answers
48 views

Sound problem in ubuntu (16.04)

Currently, i have ubuntu 16.04, and when i plug in my turtle beach z60's, it says it is plugged into the game audio part of the headphone, the one that is not low quality,the chat line. however, ...
2
votes
1answer
4k views

ALSA samples capture: cannot open device

I'm quite new to Linux (Lubuntu 12.04 for sake of precision) and ALSA programming at all. I'm trying to write a C program to capture audio from internal PC microphone for processing it. So as first ...
0
votes
0answers
31 views

HDMI/DisplayPort audio does not work via docking station ubuntu 16.04 Fujitsu s935

I have a Fujitsu S935, running under Ubuntu 16.04, with a docking station Port Replicator S26391-F1307-L100. HDMI sound works well if I use the HDMI port on the laptop. When the laptop is on the ...
1
vote
1answer
54 views

No Sound from Front Headphone Ports

My Front Headphone port has stopped working on its own recently as in no sound is coming from them. It was working fine till last week after I applied some fix I found on Google. I am sorry but I don'...
0
votes
0answers
42 views

Dummy output - No Sound Card Detected - VAIO VGN-FS640/W on Ubuntu 16.04 LTS

I know that this question has a lot of answers but, none of them work for me. I have been trying for hours to resolve this problem but nothing. The last thing I have tried is the following: Purge ...
0
votes
0answers
18 views

Sound not working on Hp Chromebook 11 G4 Ubuntu 16.04

I installed Seabios and then used usb to install Ubuntu Gnome 16.04 with no problems, I completely removed Chrome Os. I just realized while playing a game that the sound was not working. So my ...
1
vote
1answer
42 views

kubuntu 16.04: Sound card “access denied” error, can't play sound

I've checked out a dozen or more "solutions" (such as the one here), but my problem seems to go deeper than any of them. It all started when I built wine. I installed a few dozen dev and other ...
2
votes
1answer
739 views

Installed Lubuntu 16.04 version no audio now

I apologize if I am to vague in my question/statement. I just installed LUbuntu 16.04 onto my laptop, which is a HP Pavilion G6 series, AMD Processor, and it does have an HDMI port. I can't seem to ...
1
vote
1answer
56 views

Configuring automatic Bluetooth audio output via ALSA & command-line

I've got a Ubuntu 16.04 box on an Intel NUC for HTPC purposes (running Kodi). Most of the time it's outputting audio to the TV via HDMI (one day will be via a receiver) however occasionally I'd like ...
0
votes
0answers
60 views

sub-woofer howto

I have a laptop with a 2.1 audio system, the sub-woofer is external and in windows it's volume can be controlled by Realtek audio manager (the one which comes with audio drivers) and from windows ...
1
vote
1answer
32 views

No sound on 14.04 - various troubleshooting tried already

I've not used my laptop in about a week, I came back to it to stream some media from my NAS. Installed VLC and a couple of plugins since the file I was trying to play (mkv) was not working. I'm now ...
1
vote
0answers
29 views

Setup USB Audio Headset

I can't seem to setup a USB audio device to play sound. I do not have any speakers currently setup, so this is the only way I can play sound. I'm currently trying to install a Dynex Cyber-acoustics ...
0
votes
0answers
24 views

cant get three sound devices to show up in ubuntu 14.04

I have a dell optiplex with onboard alc269, a audigy2 and a asus dx soundcard. Deep down Alsa reload shows that emu10k1 is indeed loaded for the audigy2, hda-intel is loaded for the onboard and ...
0
votes
0answers
15 views

Microphone not working and headset not being detected on Dell Inspiron 3552 with preinstalled Ubuntu 14.04

Couple of weeks ago after restarting my dell inspiron 3552 my microphone was not working nor the headset. Before every time I plugged a headset a dialog appeared asking if it was a headset or ...
0
votes
0answers
13 views

Streaming audio via ices2 played by other application

I'm quite new to "linux sound issues" (so sorry for maybe stupid question). My problem is: There is a application which sometimes (event driven) plays some sounds using 'aplay' command. I need to ...
5
votes
1answer
2k views

Alsa problems with python2.7- Unable to open slave

I am using python's module pyaudio to process sound but ALSA returns: ALSA lib pcm_dsnoop.c:618:(snd_pcm_dsnoop_open) unable to open slave ALSA lib pcm_dmix.c:1022:(snd_pcm_dmix_open) unable to open ...
6
votes
2answers
5k views

PulseAudio can not load bluetooth module 15.10/16.04

EDIT: Works for 16:04 as well I am having trouble connecting my bluetooth speakers with a fresh 15.10 install. The speakers are connected however they are not listed as available audio device. I ...
0
votes
0answers
30 views

Fixing Intel 24-n014 speakers? (Conexant CX20753/4)

I have had trouble with these speakers since installing Ubuntu. I dual-boot Ubuntu with Windows 10. The speakers are, on the Windows boot, managed by the pre-installed Bang and Olufsen audio manager....
4
votes
1answer
9k views

ALC892 Low sound issue fixed with changing alsa config, why does it work?

I updated to 14.04. My sound immediately transitioned from being normal to sounding extremely quiet, sounding like it was at 5% of max volume, though all my volumes were set properly. I tried lots ...
5
votes
1answer
6k views

play audio through bluetooth speakers in 12.04 using CLI

I have gone through the whole gamut of trials with setting up playing audio through bluetooth and have not been able to make it work reliably (i.e., got it to work one time, and has not worked after ...
1
vote
0answers
19 views

'arecord' generating blank files with size 44kb

Linux c6a811x-evm 2.6.37 #1 Sat May 7 16:05:26 IST 2016 armv7l unknown The output of arecord -l **** List of CAPTURE Hardware Devices **** card 0: EVM [TI81XX EVM], device 0: AIC3X tlv320aic3x-hifi-...
1
vote
0answers
33 views

gnome-control-center missing options

I was having issues with microphone input and followed advice here to fix alsa-base. In doing so I have lost a number of options from gnome-control-center. Most people with the issue found that ...
1
vote
1answer
90 views

Headphones Issue

I got a new computer several months ago (MSI Ghost Pro GS60) and installed Ubuntu 16.04 on it. The whole time I've been using it, I've had some issues with the headphones that I haven't been able to ...
1
vote
0answers
56 views

No sound in headphones. After change in mixer no saved setting

Haven't sound at front output and have sound only rear side In mixer stand mute at headphones for default and no saved, after changes and reboot ProblemType: Bug DistroRelease: Ubuntu 16.04 Package: ...
1
vote
0answers
19 views

Problems with sound w/ HP elitebook 2540p

Hello people of AskUbuntu! I have installed the latest version of Ubuntu on my laptop, everything works perfectly apart from the fact that I have no sound! Ive tried the speaker test terminal code ...
0
votes
0answers
7 views

ACER One 11 Speakers Sound Crackle

Acer One 11. Model: A01-132-C2V7 Xubuntu 16.04 LTS Xubuntu running perfectly except for: Constant crackle sound from Internal speakers only. Headphones no problem. Realtek HD-audio / Intel HDA ...
0
votes
0answers
26 views

skype disables microphone

Ubuntu 15.04 The (internal) microphone works, but stops working the moment Skype accepts or initiates a call, UNLESS I have the sound settings dialog or pavucontrol running in the background at the ...
4
votes
3answers
1k views

Impulse convolution options in Ubuntu

I've made impulse to correct my speakers response, and would like to use it in my Ubuntu 11.04. The only possible (in common sense) way seems to be through Jack and the jack_convolver plugin. As not ...
3
votes
1answer
5k views

no sound in Ubuntu 12.04 and /dev/dsp does not exist

Computer isn't playing audio. I've checked the hardware volume buttons, pavucontrol, and alsamixer. Nothing is muted. I've added the ppa sudo add-apt-repository ppa:ubuntu-audio-dev. I've also done ...