The Advanced Linux Sound Architecture (ALSA) provides audio and MIDI functionality to the Linux operating system.

learn more… | top users | synonyms

2
votes
1answer
2k views

Jackd fails to start

I'm trying to have a setup where JACK interfaces directly to ALSA and pulseaudio communicates to JACK. This setup worked OK (I had to manually start things a few times) but as I understood the Ubuntu ...
2
votes
1answer
561 views

PulseAudio server connection failure: Connection refused

I get this error after installing new updates. This is the output of VLC: VLC media player 2.1.6 Rincewind (revision 2.1.6-0-gea01d28) [0x2100668] pulse audio output error: PulseAudio server ...
2
votes
2answers
540 views

Fix audio glitches with Intel HDA Realtek 887-VD

I've just self-build a beefy new desktop, with a Gigabyte Z97P-D3 mobo, intel i7-4790K, 16GB RAM. I am using the on-board sound hardware intel HDA (Realtek ALC887-VD) for audio output. I'm running ...
2
votes
1answer
337 views

No sound through headphones but works for internal speakers

I have a Lenovo Thinkpad T440p. I'm not entirely sure what happened but my sound decided to go out for my headphones. The sound also went out for my speakers but in the process of fixing it, sound now ...
2
votes
2answers
2k views

Analog sound output does not appear in “Sound settings”

I recently moved my computer, and after I set my speakers up again, I've had problems with outputting sound on them. It just doesn't work. The sound card is a Asus Xonar DX. I'm running Ubuntu 15.04 ...
2
votes
1answer
144 views

Alsamixer or Pulseaudio reverts PCM channel level to 100% in 14.04

Can anybody help me figuring out why every time I change volume with media keys, or restart my Dell E1405, the PCM slider goes up to 100%? How do I make it stay at 81% (which is one step below the red ...
2
votes
1answer
337 views

No sound in Ubuntu 14.04 after HDMI detatch

I was using my TV as a monitor connected to my lenovo laptop, through a HDMI connection, manually changing the sound sink in system options. Then I shutdown the system and then unplugged the HDMI, ...
2
votes
4answers
4k views

Audio applications not playing on 14.04

I recently installed Ubuntu 14.04 from scratch, overwriting 13.10. Ever since then, I haven't been able to play audio in most desktop media applications: Spotify, Rhythmbox, Pithos, Banshee...all of ...
2
votes
2answers
2k views

No audio input device on ubuntu 13.10 with front-mic plugged-in

I have sound but can't see any audio-input (mic) device in settings. The mic works, I have tested using gnome-alsamixer by redirecting the mic to output. But when I try the sound recorder it says "...
2
votes
1answer
213 views

Weird volume levels

I have a old HP Pavilion dv6645eo with the HP Quicklaunch buttons. When I use the volume buttons, the only sound in the upper echelons of the 'sound bar'. I've been looking long after why it happens. ...
2
votes
1answer
319 views

Is there an efficient way to set all lines with amixer?

On my hardware platform I have a LOT of lines. Is there a way to set the volume of all of these? Or mute all of these? If not, is there a way I can for loop this? If I change hardware platforms, is ...
2
votes
3answers
4k views

Sony vaio fit with ubuntu 12.04, sound missing

The speakers in my Sony Vaio Fit SVF15A1C5E don't work, while headphones do. lspci -nn|egrep 'ultimedia|udio|sound|AC97|ac97|EMU': 00:1b.0 Audio device [0403]: Intel Corporation Panther Point High ...
2
votes
1answer
2k views

No sound unless alsa-utils reinstalled

I am struggling with no sound problem on Ubuntu 12.04 and now on 12.10. I went through a lot of forums mentioning this issue and I have tried a lot of different solutions that worked for others but ...
2
votes
2answers
370 views

Thinkpad 13 Edge microphone noise problem

I'm having problems with the microphone making a annoying noise that makes talking really hard. My laptop is a ThinkPad Edge 13 (the version with an intel processor) I reported a bug [1] and I got ...
2
votes
2answers
1k views

How do I change sound output from the green audio jack to the blue audio jack?

Well i am new to linux, but i have a little problem. My green audio jack died and i only have a blue and a pink audio jack wich both work under windows. The pink jack works but I don't how to get the ...
2
votes
3answers
1k views

ALSA does not see sound cards after restoring previous HOME

I have trouble with sound on a fresh installation of 12.04. I have just installed a new graphics card and with that, I decided to install 12.04 from scratch. Previously, the computer ran 11.04 and I ...
2
votes
1answer
3k views

How to switch back and forth between pulseaudio+alsa and alsa only?

I prefer using alsa only while I make screencast and do skype. Other times, I use pulseaudio/alsa. Is there a quick and easy way to switch between these two states on Ubuntu 12.04 desktop?
2
votes
3answers
4k views

No soundcard found 12.04 after kernel update

After newest kernel update I have lost my sound card. There is only sound via USB adapter. My headphones or speakers are working only through this device. The sound setting widget doesn't show any ...
2
votes
3answers
2k views

Headphone jack does not cut speakers in 12.04

When I connecting my headphones to laptop, the speakers is still working. Where is the problem?
2
votes
1answer
827 views

Flash audio problem; redirecting to Pulse?

I am having a problem where the sound on flash objects other than YouTube videos are giving a strange distortion. It has a high pitched pulse sound every second or less that resembles skips on a ...
2
votes
2answers
5k views

espeak returns error on ubuntu server

I want to use espeak on my server, so I can scare my girlfriend from work :) ubuntu 11.04 server. sudo espeak -v en "Hello i am espeak" Error: ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown ...
2
votes
1answer
3k views

Restore sound configuration

After install some packages, I don't have sound! I installed Rosegarden, VMPK (piano software), Drumstick Virtual Piano and TiMidity. At the beginning, all works fine, but when I reset my PC, I don't ...
2
votes
1answer
286 views

Login sound plays, but no sound during session

When I installed Ubuntu, everything was great. But one day, I heard the login sound but no sound on the desktop session. This happens every time. I have reinstalled sound drivers several times, ...
2
votes
1answer
2k views

Sound driver for motherboard gigabyte ga-g1975x-c (Creative Sound Blaster Live 24-bit) (alsa, ca0106)

My motherboard is gigabyte ga-g1975x-c with integrated audio "Creative Sound Blaster Live 24-bit". I have installed Ubuntu 10.10, and there was no sound at all. Alsa drivers was already installed. ...
2
votes
1answer
4k views

No HDMI Audio with GeForce 9600GT and nForce board [closed]

I've been trying to get HDMI with sound working for the last few days, and I'm a little bit out of ideas. (I've verified that the hardware/Setup works via Windows.) aplay does not list my HDMI device:...
2
votes
2answers
175 views

Broken sound with ALC269 on Ubuntu 16.04 (Dell Inspiron Mini 10)

I just bought a Dell Inspiron Mini 10 with a Realtek HD ALC269 sound card and whatever sound it produces, it's broken. If I can't fix it, will have to put it back into WinXP and my little son will get ...
2
votes
1answer
344 views

PulseAudio fails to set card profile to 'a2dp_sink'. How can I see the logs and figure out whats wrong?

I have currently installed ubuntu 16.04 and a2dp used to work on fresh install, which I'd prefer to leave as a last option. When the pairing is erased from bluetooth settings and is paired again ...
2
votes
1answer
119 views

Sound From Speakers When Headphones connected

I am having an issue with my sound which I am aware other user's have had before: Sound works perfectly on my Ubuntu install, except when I put my headphones in, the speakers are not disabled ...
2
votes
1answer
116 views

ubuntu 15.04 no sound

there is no sound on my desktop and my Chassis Information are: Handle 0x0003, DMI type 3, 22 bytes Chassis Information Manufacturer: Gigabyte Technology Co., Ltd. Type: Desktop Lock: Not ...
2
votes
1answer
665 views

aslactl storing / restoring issues

I have a problem with alsa settings not surviving reboot. I have a headless server running 15.04, using sound for shairport-sync. When I reboot, I get messy alsa settings (volumes). Trying to restore ...
2
votes
1answer
513 views

Headphones is not working in 15.04 Dell XPS 13

After upgrading to 15.04 , my headphones don't work, how to fix it? When I type command alsamixer , I see something strange:
2
votes
1answer
908 views

Realtek HD Audio Driver failed to build

I have Ubuntu 15.04 x64 running on a Gigabyte GA-Z87X-UD4H with Realtek ALC898. The audio works mostly out of the box and the device is detected as my card1 (card0 is IntelHDA). The problem I'm having ...
2
votes
1answer
1k views

How to save alsamixer settings?

I work with sound in Ubuntu 14.04. And I can't save the desired settings of Alsamixer. I tried the command sudo alsactl store 0, but it has not helped. Alsamixer settings changed after reboot or after ...
2
votes
1answer
1k views

My microphone recording volume automatically changes

Whenever I do talk on Skype I can watch with alsamixer, how the setting: Internal reduces its volume. Sadly the volume goes so much down, that I get muted. I do have to constantly watch my recording ...
2
votes
1answer
703 views

Lenovo - E420s - sound from laptop speakers and headphones

All of a sudden, sound from all applications plays from both speakers and headphones when I plug in the headphones. I've checked lots of similar questions but they all apply to older versions of ...
2
votes
1answer
2k views

ALSA and Mednafen: No Sound

I am getting no sound in Mednafen on Linux MInt 17.1 Mate 64-bit. Relevant part of ~/.mednafen/mednafen.cfg are: ;Disable speed throttling when sound is disabled. nothrottle 0 ;Automatically save ...
2
votes
1answer
807 views

Apply LADSPA plugin to input (microphone)

Similar to How can I apply a LADSPA plugin to a PulseAudio stream?, but I'm trying to apply the plugins to my source, not a sink. Basically, I want other people to hear my voice with plugins applied ...
2
votes
1answer
1k views

Crackling and sound interruptions - speaker/headphone switching [closed]

Continuous crackling from moment Ubuntu starts up. When playing sound gives interruptions. I didn't experience any sound problem in Windows before I installed Ubuntu (ubuntu is great btw). ...
2
votes
1answer
195 views

Headphones noise, turning on and off

I have a Dell XPS13 9333 running Ubuntu 12.04. Speakers are working ok, while there are issues using headphones. Headphone are muted when there is no audio playing (that's ok), than when the audio ...
2
votes
1answer
321 views

BT_GET_CAPABILITIES warning slowing down audio apps

I'm using a bluetooth audio receiver to stream music from my PC to an old stereo. Everything works fine, except that everytime an app needs to use audio, and starts initializing ALSA, it gets lots of ...
2
votes
1answer
3k views

Ubuntu 13.10 no sound output

After upgrading to Ubuntu 13.10 from 13.04 I have no sound output devices listed on the sound settings and therefor no sound.. I have tried running sudo alsa force-reload and restarting but neither ...
2
votes
1answer
2k views

Sound completely cut out, and Restart or Pulse Audio can't fix it

Yes, I was watching a WebM video. Specifically the recent LinuxActionShow "review" of Elementary OS Luna. And about 8 or 9 minutes into the video. The sound just cut out completely. And now no sound ...
2
votes
1answer
765 views

Make a USB device show up as an input and output device

What am I attempting to do? I am trying to make my Line6 Toneport UX1 (hooked up via USB) an output and input device at the same time. Why am I trying to do this? For those of you that don't know, ...
2
votes
1answer
133 views

sound levels in alsamixer versus sound levels in the 'sound settings' menu

the maximum volume alsamixer allows me to reach is 100% the 'sound settings' menu (on the upper right corner) allows levels beyond 100% Why are these levels not reachable via alsamixer ? Is this ...
2
votes
2answers
664 views

Why do I have no sound when resuming from sleep, but if I plug in then remove headphones sound returns?

I am having strange issues with sound and volume with Ubuntu 11.10 I've noticed very often, especially when I get my computer out of sleep, it lacks sound even though the volume slider is cranked all ...
2
votes
2answers
6k views

5.1 Surround System Subwoofer not working

My subwo0fer is not working on Ubuntu 11.10. Satellites are all working. It is part of a 5.1 Soundsystem. I've already googled and changed in the /etc/pulse/daemon.conf file these Variables and ...
2
votes
1answer
3k views

tvtime + saa7134 doesn't work after upgrading to 11.10

When I used Ubuntu 10.10, my tvtime worked perfectly. After upgrading to Ubuntu 11.10, it only shows "no signal". I've searched throughout the internet for a whole day and couldn't fix it. I also use ...
2
votes
2answers
3k views

Using alsamixer produces error

I have recently installed the Realtek High Definition Audio Driver package using the Terminal. Before installing the software the sound was working fine but my sound sytem is 5.1 Creative. Out five ...
2
votes
1answer
29 views

How to use alsa systemwide and still have a volume tweak

I have found that using alsa and not pulseaudio greatly improves the quality of my sound. I tested this using DeadBeef and "direct ALSA output". I'd like to have my entire system use ALSA directly ...
2
votes
0answers
90 views

Headphones not working on Ubuntu 16.04 installed on Alienware 17 R3

I own a Sony MDR-XB450 headphones and it is not being detected. Sound keeps playing through external speakers Alsamixer gives the details as below Card: HDA Intel PCH Chip: Creative CA0132 I can mute/...