Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Update Manager refuses to install updates because it would require installing untrusted packages.

However, if I look at the list of so-called untrusted packages, those seem like they should be trusted. Why are all those packages treated as "untrusted" while they obviously are mainstream packages?

Here is the list:

accountsservice acpid aisleriot alsa-utils app-install-data-partner apport apport-gtk apturl apturl-common at-spi2-core banshee banshee-extension-soundmenu banshee-extension-ubuntuonemusicstore baobab bind9-host binutils bluez bluez-alsa bluez-cups bluez-gstreamer brltty bzip2 colord command-not-found command-not-found-data compiz compiz-core compiz-gnome compiz-plugins-default compiz-plugins-main-default cups cups-bsd cups-client cups-common cups-ppdc deja-dup desktop-file-utils dnsutils empathy empathy-common eog evince evince-common file-roller firefox firefox-globalmenu firefox-gnome-support gbrainy gcalctool gconf2 gconf2-common gedit gedit-common ghostscript ghostscript-cups ghostscript-x gir1.2-atspi-2.0 gir1.2-gconf-2.0 gir1.2-gnomebluetooth-1.0 gir1.2-gtk-3.0 gir1.2-gtksource-3.0 gir1.2-totem-1.0 gir1.2-webkit-3.0 gnome-accessibility-themes gnome-bluetooth gnome-control-center gnome-control-center-data gnome-desktop3-data gnome-font-viewer gnome-games-common gnome-keyring gnome-mahjongg gnome-online-accounts gnome-orca gnome-power-manager gnome-screenshot gnome-search-tool gnome-session-canberra gnome-settings-daemon gnome-sudoku gnome-system-log gnome-system-monitor gnome-utils-common gnomine gwibber gwibber-service gwibber-service-facebook gwibber-service-identica gwibber-service-twitter hpijs hplip hplip-cups hplip-data indicator-datetime indicator-session indicator-sound initramfs-tools initramfs-tools-bin initscripts isc-dhcp-client isc-dhcp-common language-selector-common language-selector-gnome libaccountsservice0 libarchive1 libasound2-plugins libatk-adaptor libatspi2.0-0 libbind9-60 libbluetooth3 libbrlapi0.5 libbz2-1.0 libcanberra-gtk-module libcanberra-gtk0 libcanberra-gtk3-0 libcanberra-gtk3-module libcanberra-pulse libcanberra0 libcolord1 libcups2 libcupscgi1 libcupsdriver1 libcupsimage2 libcupsmime1 libcupsppdc1 libcurl3-gnutls libdecoration0 libdns69 libevince3-3 libfreetype6 libgail-3-0 libgail-3-common libgck-1-0 libgconf2-4 libgcr-3-1 libgnome-bluetooth8 libgnome-control-center1 libgnome-desktop-3-2 libgoa-1.0-0 libgrip0 libgs9 libgs9-common libgssapi-krb5-2 libgtk-3-0 libgtk-3-bin libgtk-3-common libgtksourceview-3.0-0 libgtksourceview-3.0-common libgudev-1.0-0 libgweather-3-0 libgweather-common libgwibber-gtk2 libgwibber2 libhpmud0 libicu44 libimobiledevice2 libisc62 libisccc60 libisccfg62 libjasper1 libk5crypto3 libkrb5-3 libkrb5support0 libldap-2.4-2 liblightdm-gobject-1-0 liblwres60 libmetacity-private0 libmono-zeroconf1.0-cil libnautilus-extension1 libnm-glib-vpn1 libnm-glib4 libnm-util2 libnotify0.4-cil libnux-1.0-0 libnux-1.0-common libpam-gnome-keyring libpam-modules libpam-modules-bin libpam-runtime libpam0g libpulse-mainloop-glib0 libpulse0 libqt4-dbus libqt4-declarative libqt4-network libqt4-opengl libqt4-script libqt4-sql libqt4-sql-mysql libqt4-svg libqt4-xml libqt4-xmlpatterns libqtcore4 libqtgui4 libreoffice-emailmerge libreoffice-style-human libsane-hpaio libsmbclient libsyncdaemon-1.0-1 libt1-5 libtotem0 libubuntuone-1.0-1 libubuntuone1.0-cil libudev0 libunity-core-4.0-4 libunity6 libv4l-0 libwbclient0 libwebkitgtk-1.0-0 libwebkitgtk-1.0-common libwebkitgtk-3.0-0 libwebkitgtk-3.0-common libxml2 lightdm linux-generic linux-headers-3.0.0-15 linux-headers-3.0.0-15-generic linux-headers-generic linux-image-3.0.0-15-generic linux-image-generic linux-libc-dev lzma metacity metacity-common mobile-broadband-provider-info mousetweaks nautilus nautilus-data nautilus-sendto-empathy network-manager nux-tools onboard pulseaudio pulseaudio-esound-compat pulseaudio-module-bluetooth pulseaudio-module-gconf pulseaudio-module-x11 pulseaudio-utils python-apport python-brlapi python-cups python-cupshelpers python-gobject python-gobject-cairo python-launchpadlib python-libxml2 python-papyon python-problem-report python-pyatspi2 python-software-properties python-ubuntuone-client qdbus samba-common samba-common-bin seahorse shotwell simple-scan smbclient sni-qt software-center software-properties-common software-properties-gtk system-config-printer-common system-config-printer-gnome system-config-printer-udev sysv-rc sysvinit-utils telepathy-indicator thunderbird thunderbird-globalmenu thunderbird-gnome-support tomboy totem totem-common totem-mozilla totem-plugins ttf-opensymbol ubuntu-docs ubuntuone-client ubuntuone-client-gnome udev unity-services update-manager update-manager-core update-notifier update-notifier-common upstart vinagre x11-common xorg xserver-common xserver-xorg xserver-xorg-core xserver-xorg-input-all xserver-xorg-video-all xserver-xorg-video-intel xul-ext-ubufox

The output of sudo apt-get update && sudo apt-get upgrade is:

Ign http://security.ubuntu.com oneiric-security InRelease Ign http://nl.archive.ubuntu.com oneiric InRelease
Ign http://nl.archive.ubuntu.com oneiric-updates InRelease
Ign http://nl.archive.ubuntu.com oneiric-backports InRelease
Ign http://archive.canonical.com oneiric InRelease
Ign http://ppa.launchpad.net oneiric InRelease
Ign http://extras.ubuntu.com oneiric InRelease
Get:1 http://nl.archive.ubuntu.com oneiric Release.gpg [198 B]
Get:2 http://nl.archive.ubuntu.com oneiric-updates Release.gpg [198 B] Get:3 http://security.ubuntu.com oneiric-security Release.gpg [198 B] Get:4 http://archive.canonical.com oneiric Release.gpg [198 B]
Ign http://ppa.launchpad.net oneiric Release.gpg
Get:5 http://extras.ubuntu.com oneiric Release.gpg [72 B]
Hit http://nl.archive.ubuntu.com oneiric-backports Release.gpg
Get:6 http://security.ubuntu.com oneiric-security Release [40.8 kB]
Hit http://nl.archive.ubuntu.com oneiric Release
Get:7 http://nl.archive.ubuntu.com oneiric-updates Release [40.8 kB]
Hit http://extras.ubuntu.com oneiric Release
Ign http://ppa.launchpad.net oneiric Release
Hit http://archive.canonical.com oneiric Release
Hit http://nl.archive.ubuntu.com oneiric-backports Release
Hit http://extras.ubuntu.com oneiric/main Sources
Hit http://archive.canonical.com oneiric/partner i386 Packages
Hit http://nl.archive.ubuntu.com oneiric/main Sources
Hit http://nl.archive.ubuntu.com oneiric/restricted Sources
Hit http://nl.archive.ubuntu.com oneiric/universe Sources
Hit http://nl.archive.ubuntu.com oneiric/multiverse Sources
Hit http://nl.archive.ubuntu.com oneiric/main i386 Packages
Hit http://nl.archive.ubuntu.com oneiric/restricted i386 Packages
Hit http://nl.archive.ubuntu.com oneiric/universe i386 Packages
Hit http://nl.archive.ubuntu.com oneiric/multiverse i386 Packages
Ign http://ppa.launchpad.net oneiric/main TranslationIndex
Hit http://extras.ubuntu.com oneiric/main i386 Packages
Ign http://extras.ubuntu.com oneiric/main TranslationIndex
Ign http://archive.canonical.com oneiric/partner TranslationIndex
Hit http://nl.archive.ubuntu.com oneiric/main TranslationIndex
Hit http://nl.archive.ubuntu.com oneiric/multiverse TranslationIndex
Hit http://nl.archive.ubuntu.com oneiric/restricted TranslationIndex
Hit http://nl.archive.ubuntu.com oneiric/universe TranslationIndex
Get:8 http://nl.archive.ubuntu.com oneiric-updates/main Sources [120 kB] Get:9 http://security.ubuntu.com oneiric-security/main Sources [26.0 kB]
Get:10 http://nl.archive.ubuntu.com oneiric-updates/restricted Sources [1,337 B] Get:11 http://nl.archive.ubuntu.com oneiric-updates/universe Sources [40.4 kB] Get:12 http://nl.archive.ubuntu.com oneiric-updates/multiverse Sources [3,654 B] Get:13 http://nl.archive.ubuntu.com oneiric-updates/main i386 Packages [280 kB] Get:14 http://security.ubuntu.com oneiric-security/restricted Sources [14 B] Get:15 http://security.ubuntu.com oneiric-security/universe Sources [8,967 B] Get:16 http://security.ubuntu.com oneiric-security/multiverse Sources [1,629 B]
Get:17 http://security.ubuntu.com oneiric-security/main i386 Packages [74.6 kB] Get:18 http://nl.archive.ubuntu.com oneiric-updates/restricted i386 Packages [2,968 B] Get:19 http://nl.archive.ubuntu.com oneiric-updates/universe i386 Packages [92.1 kB] Get:20 http://nl.archive.ubuntu.com oneiric-updates/multiverse i386 Packages [6,336 B] Get:21 http://nl.archive.ubuntu.com oneiric-updates/main TranslationIndex [74 B] Get:22 http://nl.archive.ubuntu.com oneiric-updates/multiverse TranslationIndex [72 B] Get:23 http://nl.archive.ubuntu.com oneiric-updates/restricted TranslationIndex [71 B] Get:24 http://nl.archive.ubuntu.com oneiric-updates/universe TranslationIndex [73 B] Hit http://nl.archive.ubuntu.com oneiric-backports/main Sources Hit http://nl.archive.ubuntu.com oneiric-backports/restricted Sources
Hit http://nl.archive.ubuntu.com oneiric-backports/universe Sources
Get:25 http://security.ubuntu.com oneiric-security/restricted i386 Packages [14 B] Get:26 http://security.ubuntu.com oneiric-security/universe i386 Packages [24.7 kB] Hit http://nl.archive.ubuntu.com oneiric-backports/multiverse Sources
Hit http://nl.archive.ubuntu.com oneiric-backports/main i386 Packages Hit http://nl.archive.ubuntu.com oneiric-backports/restricted i386 Packages Hit http://nl.archive.ubuntu.com oneiric-backports/universe i386 Packages Hit http://nl.archive.ubuntu.com oneiric-backports/multiverse i386 Packages Hit http://nl.archive.ubuntu.com oneiric-backports/main TranslationIndex Hit http://nl.archive.ubuntu.com oneiric-backports/multiverse TranslationIndex Hit http://nl.archive.ubuntu.com oneiric-backports/restricted TranslationIndex Hit http://nl.archive.ubuntu.com oneiric-backports/universe TranslationIndex Err http://ppa.launchpad.net oneiric/main Sources
404 Not Found Err http://ppa.launchpad.net oneiric/main i386 Packages 404 Not Found Get:27 http://security.ubuntu.com oneiric-security/multiverse i386 Packages [3,345 B]
Get:28 http://security.ubuntu.com oneiric-security/main TranslationIndex [73 B] Get:29 http://security.ubuntu.com oneiric-security/multiverse TranslationIndex [72 B] Get:30 http://security.ubuntu.com oneiric-security/restricted TranslationIndex [70 B] Get:31 http://security.ubuntu.com oneiric-security/universe TranslationIndex [73 B] Ign http://extras.ubuntu.com oneiric/main Translation-en_US Hit http://nl.archive.ubuntu.com oneiric/main Translation-en
Hit http://nl.archive.ubuntu.com oneiric/multiverse Translation-en
Hit http://nl.archive.ubuntu.com oneiric/restricted Translation-en
Hit http://nl.archive.ubuntu.com oneiric/universe Translation-en
Get:32 http://nl.archive.ubuntu.com oneiric-updates/main Translation-en [130 kB] Ign http://archive.canonical.com oneiric/partner Translation-en_US
Hit http://security.ubuntu.com oneiric-security/main Translation-en
Ign http://extras.ubuntu.com oneiric/main Translation-en
Hit http://security.ubuntu.com oneiric-security/multiverse Translation-en Hit http://security.ubuntu.com oneiric-security/restricted Translation-en Hit http://nl.archive.ubuntu.com oneiric-updates/multiverse Translation-en Hit http://nl.archive.ubuntu.com oneiric-updates/restricted Translation-en Get:33 http://nl.archive.ubuntu.com oneiric-updates/universe Translation-en [55.1 kB] Ign http://archive.canonical.com oneiric/partner Translation-en
Ign http://ppa.launchpad.net oneiric/main Translation-en_US
Hit http://nl.archive.ubuntu.com oneiric-backports/main Translation-en Get:34 http://security.ubuntu.com oneiric-security/universe Translation-en [17.4 kB] Hit http://nl.archive.ubuntu.com oneiric-backports/multiverse Translation-en Hit http://nl.archive.ubuntu.com oneiric-backports/restricted Translation-en Hit http://nl.archive.ubuntu.com oneiric-backports/universe Translation-en Ign http://ppa.launchpad.net oneiric/main Translation-en
Fetched 971 kB in 1s (711 kB/s) W: Failed to fetch http://ppa.launchpad.net/elementaryart/ppa/ubuntu/dists/oneiric/main/source/Sources 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/elementaryart/ppa/ubuntu/dists/oneiric/main/binary-i386/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

share|improve this question
    
NB: I installed 10.11 yesterday with Gnome-Shell and removed Unity. –  Benjamin Jan 30 '12 at 17:43
    
Sorry, what is your question? –  BrownE Jan 30 '12 at 18:48
    
@BrownE: how come those packages are treated as "untrusted" while they obviously are main packages. –  Benjamin Jan 30 '12 at 19:13
    
what is the output of sudo apt-get update && sudo apt-get upgrade ? –  fossfreedom Jan 30 '12 at 20:09
    
@fossfreedom: output added to question. –  Benjamin Jan 30 '12 at 20:40

1 Answer 1

up vote 1 down vote accepted

With issues like this, you can usually narrow down the problem by looking at the errors as a result of running:

sudo apt-get update && sudo apt-get upgrade

With your latest update to your question you can see a 404-error which indicates that a web-page cannot be accessed (a 404 is a standard web-response). In this case, the elementaryArt PPA is not accessible. Usually this is a server issue - which disappears if the server comes back-on line.

However, in this case, if you look on launchpad, the PPA in question does not have an oneiric repository.

As to why you get untrusted packages error - usually this is because the signature for a repository needs to be updated or is temporarily unavailable.

In your specific case, the repo-keys have been "refreshed" via the update/upgrade action.

If you at a later date receive errors such as BAD-SIG and/or NO_PUBKEY you can fix these via the linked questions below


Linked Questions:

  1. How do I fix the GPG error "NO_PUBKEY"?
  2. What is the easiest way to resolve apt-get BADSIG GPG errors?
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.