Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I would like to rsync a folder but have some problems doing so due to the fact that the folder's path contains some special chars. My rsync command uses to look like this:

rsync -Pavzbe ssh [email protected]:"/home/user/Bücher" /home/user/

I get the following message:

Unexpected remote arg: [email protected]:/home/gast/B\\#303\#274cher
rsync error: syntax or usage error (code 1) at main.c(1232) [sender=3.0.8]

I tried the following command instead but got the same result

rsync -Pavzbe --iconv=CP1250,UTF-8 ssh [email protected]:"/home/user/Bücher" /home/user/

Who can help?

share|improve this question
    
Try with --iconv=. or --iconv=utf8,cp1250. –  geirha Apr 9 '12 at 12:10

1 Answer 1

I would try one of:

  1. Making a symlink to the folder, and rsync that folder (of course with a "follow symlinks" option on the command line).
  2. Syncing the folder /home/user instead, and use filters to make sure I only got what I wanted.
  3. Rename the unfortunate folder.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.