Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was having issue with the vim-gnome package and command-t with vim not compiling with the system ruby. So I built vim with.

sudo apt-get install mercurial
hg clone https://vim.googlecode.com/hg/ vim
cd vim
./configure --enable-rubyinterp
make
sudo make install

But I made a mistake. when I did vim --version | grep ruby I realised my error. I had forgotten to turn off rvm before compiling.

   -Wl,-R -Wl,/home/renshaw/.rvm/rubies/ruby-1.9.3-p0/lib -L/home/renshaw/.rvm/rubies/ruby-1.9.3-p0/lib -lruby -lpthread -lrt -ldl -lcrypt -lm  -L/home/renshaw/.rvm/rubies/ruby-1.9.3-p0/lib   

But I can't get apt-get remove it and I cannot see vim in /usr/bin/. It still runs if I type vim, but how do I remove it so I can compile it properly?

share|improve this question
    
It should be in /usr/local –  jrg Jan 30 '12 at 11:34
    
using which vim you can at first find out where the executable is located which is invoked.I suggest to read the README or INSTALL files which usually are in the project archives. Further it should as well be possible to just run make install again after a new compilation. –  Michael K Jan 30 '12 at 11:34
    
Ah yes thanks /usr/local/bin –  sayth Jan 31 '12 at 5:27
add comment

1 Answer

up vote 1 down vote accepted

As one of the commenter's (jrg) suggested it's likely to be in /usr/local. You don't need to uninstall before recompiling and reinstalling though. When you install again it will simply overwrite the previous version.

You can normally run ./configure --help to see what the options available are, like the install path (normally labeled prefix and set to /usr/local I believe).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.