Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I am trying to install Apache Apollo on Ubuntu, it is not getting installed. It is showing apollo: command not found Permissions to the apollo file are 777. JAVA_HOME is also properly set. Can anybody help me out? I have followed Official installation guide properly. Can you please help me out?

share|improve this question
    
Do you need to add /var/lib/mybroker/bin/ to the PATH? –  user8290 Jan 30 '12 at 23:39
    
@Christopher : Thanks for the comment. According to my knowledge, firstly I need to create the broker 'mybroker' using command 'apollo create broker mybroker'. This command will create mybroker folder i.e. /var/lib/mybroker folder. When I run this command, I get error 'apollo : command not found'. –  Saurabh Jan 31 '12 at 4:36

1 Answer 1

up vote 0 down vote accepted

I followed the APOLLA documentation (linked in above question) blindly. i.e. I was trying to create broker using

cd /var/lib
${APOLLO_HOME}/bin/apollo create mybroker 

but 'apollo' is sh file. Hence it should be run using 'sh'. When I tried 'sh apollo create mybroker', it worked.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.