Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i want to mount my /home in etc/fstab for quota limits how do i do that ?

My Ubuntu-Server

fstab

 # /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
/dev/mapper/vg0-lv0 /               ext4    errors=remount-ro 0       1
/dev/mapper/vg0-lv1 none            swap    sw              0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

UPDATED

@Rinzwind

fstab

home /home ext4 defaults,usrquota 0 0 
mount -o remount /home

root@ubuntu:/home/one# mount -o remount /home
mount: /home not mounted already, or bad option

After Rebooting enter image description here

share|improve this question

1 Answer 1

up vote 0 down vote accepted

You need to add ,usrquota to the options of the partition that your created for this. A possible(!) valid method would be:

home /home ext4 defaults,usrquota 0 0 

but since you do not have a partition with mount point home I am just guessing. After that you need to remount /home.

mount -o remount /home

and the filesystem then knows it needs to check for quota (ie. /home/aquota.user).

share|improve this answer
    
what will be entries in fstab , plz update –  One Zero Jan 30 '12 at 8:57
    
home /home ext4 defaults,usrquota,grpquota 0 0 ? –  One Zero Jan 30 '12 at 9:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.