Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't get my fresh install of Ubuntu 11.10 to recognize that I've got a drive for CDs, DVDs, and Blu-Rays...

Here's the output of a couple of commonly-requested terminal commands in other forum posts I've read on the topic:

$ ls -l /dev/{cd,dvd}\*
ls: cannot access /dev/cd*: No such file or directory
ls: cannot access /dev/dvd*: No such file or directory

$ sudo lshw -c disk
  *-disk:0
       description: ATA Disk
       product: ST9250421ASG
       vendor: Seagate
       physical id: 0
       bus info: scsi@2:0.0.0
       logical name: /dev/sda
       version: DE12
       serial: 5TH00M12
       size: 232GiB (250GB)
       capabilities: partitioned partitioned:dos
       configuration: ansiversion=5 signature=00099b7e
  *-disk:1
       description: ATA Disk
       product: ST9250421ASG
       vendor: Seagate
       physical id: 1
       bus info: scsi@3:0.0.0
       logical name: /dev/sdb
       version: DE12
       serial: 5TH00HHY
       size: 232GiB (250GB)
       configuration: ansiversion=5

$ sudo lshw -c drive

Additionally, here's my fstab file:

\# /etc/fstab: static file system information.
\#
\# Use 'blkid' to print the universally unique identifier for a
\# device; this may be used with UUID= as a more robust way to name devices
\# that works even if disks are added and removed. See fstab(5).
\#
\# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
\# / was on /dev/sda1 during installation
UUID=3112a024-7483-447b-9069-c6d0b5ed23d4 /               ext4    errors=remount-ro 0       1
\# swap was on /dev/sda5 during installation
UUID=5742166e-368f-4374-b188-a1ce61faadaa none            swap    sw              0       0

Sorry, I really don't know much about the Linux auto-detect/ mount process. Any help would be greatly appreciated!

share|improve this question

1 Answer 1

Ah, apparently Ubuntu doesn't detect the type of connection I have by default...after installing all updates to the OS, it autodetects and mounts appropriately.

My bad.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.