Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On one of my laptops, I installed all of the popular DEs because I like to experiment with them. I have Unity, GNOME Shell, KDE, and xfce all installed. It seems that KDE and GNOME don't "get along", and makes things messed up such as words and characters on the screen. Also, it appears that some applications get mixed up with each other. Is there any way to make the DEs less "messy"? - Ubuntu 11.10

Also, is there a way to install KDE in a way that DOESN'T install a bunch of other stuff that isn't needed. Such as the KDE sentences... They aren't needed since I already have the GNOME applications. Also, when you install KDE it also changes the shutdown and startup screen to Kubuntu instead of Ubuntu.

In response to a comment on my question, I tried to install KDE-core but I could not find it. And will installing KDE mess up the fonts in my other DEs?

share|improve this question
    
I'm using Nautilus (which is drawing the desktop) KDM (Display manager) XFCE panel, and the KDE Plasma desktop perfectly fine. KDE apps are themed by using QT4 Settings, I'm logged into the XFCE session. –  Uri Herrera Jan 30 '12 at 0:43
    
I haven't noticed the xfce application interfering too much with the GNOME apps. Just KDE. –  Jordan Jan 30 '12 at 0:52
    
Is there a way then to make KDE a bit more integrated into the system? Or when you go to install kubuntu-desktop, is there some "extras" I don't need to install? –  Jordan Jan 30 '12 at 1:06
    
Ok so just KDE, KDM, and QT4? –  Jordan Jan 30 '12 at 1:10
    
Alright thank you very much, I'm gonna try installing it now. –  Jordan Jan 30 '12 at 1:20
show 7 more comments

5 Answers

I think that if you want to experiment with different Desktop Environments it is perhaps best to do that on virtual machines rather than the computer you use all the time.

Each DE installs so many other programs you're bound to get some clashes, and certainly lots of alternative apps you probably don't want (how many office apps do you need?)

share|improve this answer
add comment

Check this page, it shows how to get an uniform look for Gnome and KDE apps https://wiki.archlinux.org/index.php/Uniform_Look_for_Qt_and_GTK_Applications

share|improve this answer
add comment

To install KDE without a lot of other stuff, depending on which other stuff you don't want installed, you could probably do:

sudo apt-get --no-install-recommends install <KDE package name>
share|improve this answer
add comment

For plymouth option see this page too.By this way you can change which logo should come on booting ubuntu.

share|improve this answer
add comment

You can install only the kde-plasma-desktop or plasma-desktop package in Ubuntu, they give you the basic desktop environments needed for kde. I think kde-plasma-desktop is better, since it is more parent package for plasma-desktop and not bigger than it's child (plasma-desktop).

As for the startup and shutdown screen, enter the following commands in terminal. If you have already installed the kubuntu-desktop package.

sudo apt-get remove plymouth-theme-kubuntu-logo plymouth-theme-kubuntu-text.

You can also install the packages with names starting with kde-config-xxxx, since they provide the volume control, networking_applet, bluetooth and other system-configuration functionality for the KDE.

Don't forget the kde-config-gtk package and gtk3-engines-oxygen, gtk2-engines-oxygen and optionally oxygen-moleculepackages. They provide you the uniform look and feel in KDE and GNOME. ( Prevents ugly look of Gnome apps, when opened in KDE).

You can install other recommended packages as per your need by

  • opening the synaptic package manager,
  • search for kubuntu-desktop package in the search bar,
  • right clicking on the package name, pointing the mark recommended for Installation list,
  • and selecting a package from newly appeared sub-menu.

Note: From my experience, I see that, after opening firefox in KDE, when you open it again in GNOME, you will get ugly looking font-rendering of firefox. This happens because KDE use Full hinting style, where Gnome use Slight hinting style. To prevent this,

  • delete the file in your home directory with name .fonts.conf after login in Gnome session
  • or edit the file with replacing hintmedium with value hintslight.

Hope this will help.


If don't like to remove kubuntu-logo splash screen

If you simply want to switch to ubuntu splash screen, you can do this by entering following in terminal

sudo update-alternatives --config default.plymouth and selecting ubuntu-logo.plymouth by entering associated number. This will restore Ubuntu splash screen. You must enter sudo update-initramfs -u command following the previous command, to save the change.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.