Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying not to hate Unity, but I'm still not in love.

If I have windows non-maximized, I often find that the window is stuck so the title bar is hidden by my Unity top bar. I had to enable Compiz's Window Management Grid just to give myself ctrl-alt-num6 as a way to force windows back into the visible screen.

Is there a way to keep windows from slipping up under the top bar?

share|improve this question
6  
While not an answer, you can hold ALT and left-click (and hold) anywhere in a window to move it around. From there you have your window controls accessible again. –  Tom Brossman Jan 29 '12 at 20:24
    
Yup. I do a lot of that as well. –  Amanda Jan 29 '12 at 20:29
    
OP are you still looking for an answer? If so, you may need to repost your question as this is flagged for closure. Regards, –  Ringtail Apr 7 '12 at 4:57
    
No, I installed OpenBox. I never could get Unity to work for me. –  Amanda Apr 9 '12 at 14:00
    
@Amanda I ran into this problem in Compiz the other day (using Gnome-classic) and I found the solution. I'll post an answer, since it may help someone else. –  RolandiXor Sep 14 '12 at 4:52
show 1 more comment

1 Answer 1

up vote 3 down vote accepted

You need to set the appropriate option in the Compiz Place Windows plugin.

  • Open CCSM (make sure you have it installed first).
  • Find the Place Windows plugin:
    CSSM
  • Now, in the options, make sure that smart placement is selected.
    Smarty

This option is usually set by default, but sometimes for some reason it is not. I am not 100% certain as to the cause (still trying to find it). If you do not have the place windows plugin, make sure to check that you have any additional compiz plugins installed in the software center.

share|improve this answer
2  
For me, it is Smart already, and yet my title bar is behind top bar... Alt+drag worked for me though. Perhaps it was an unintentional Alt+drag that got me there at the first place. –  tishma Apr 20 '13 at 9:00
    
In my computer placement mode is already set to smart, but I have this problem too. –  rashed azad Jun 18 at 18:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.