Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ok, so I've got the 5650 as a discrete gpu and integrated 4200. The problem is that I cant switch to 5650. fglrxinfo shows that 4200 is on, but aticonfig -px-list shows that Discrete GPU is active.

lspci shows this:

01:05.0 VGA compatible controller [0300]: ATI Technologies Inc M880G [Mobility Radeon HD 4200] [1002:9712]

02:00.0 VGA compatible controller [0300]: ATI Technologies Inc Madison [AMD Radeon HD 5000M Series] [1002:68c1] (rev ff)

as xorg looks like this:

xorg device section:

Section "Device"

Identifier "aticonfig-Device[0]-0"

Driver "fglrx"

BusID "PCI:1:5:0"

EndSection

I thought that if I change busid to PCI:2:0:0 it'll help, but it won't. looks like ubuntu can't see 5650 as with PCI:2:0:0 I cant run X. any suggestions what to do?

Also I can't disable 4200 in BIOS

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Have you tried switching with vgaswitcheroo? For more information on this topic, have a look at HybridGraphics in Ubuntu. When it comes to owning vgaswitcheroo, I use:

sudo chmod -R 705 /sys/kernel/debug and

sudo chown -R $YOURUSERNAME:$YOURUSERNAME /sys/kernel/debug/vgaswitcheroo

I don't use the proprietary drivers though.

share|improve this answer
    
SOLVED I simply uninstal fglxr, and then I did everything from this site: asusm51ta-with-linux.blogspot.com –  Tobias Jan 30 '12 at 0:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.