Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use a wired PPPoE connection to connect to the Internet. What I need to do on Windows to connect to it is put in static IP address, gateway, subnet mask and DNS servers for my LAN card. Next I have to create a dialer for a PPPoE connection, put in my user name, the service name and the password, and "dial" this connection. And it works fine.

On Ubuntu 10.04, however, I have tried setting things up in a similar fashion - put in all static addresses for the "automatic" wired connection, then put in user name, service name, password for a "DSL" connection. It worked for a while, then stopped. I have tried putting in all the details within the DSL configuration dialog, same thing happened - it worked for a while, then stopped. I have tried deleting the ethernet connection and only keeping the DSL one with all the numbers put in place, same thing happened - it worked for a while, then stopped. Each of the times, when it connected, it connected randomly, after trying a few times, and either stopped working within a few minutes, or after I had rebooted. I have deleted and remade the connection dozens of times - even with different names, but nothing seems to be working.

I have also tried pppoeconf from the terminal, didn't work.

I have checked /var/log/kern.log, but nothing changes in the file when I try to connect. I have also checked /sbin/route, but gedit can't even open it (says it can't figure the character encoding...).

The "connection established" notification pops up from the top right corner, the same way as when the computer is actually connected to a network.

Can anyone figure what's wrong and how it can be solved?

share|improve this question

1 Answer 1

up vote 5 down vote accepted

I seem to have found the solution.

I deleted all the previous connections, deleted the configuration file from /etc/network created by pppoeconf and rebooted. Then I set up the wired connection (Automatic ethernet) using the static addresses but made sure it didn't have "connect automatically" checked in the configuration dialog. Then I created a DSL connection, but of all the settings, I only filled in the user name, service name and password for it. I checked "available to all users" and closed the settings dialog. Then from the "connections" applet on the panel, clicked the connection name. And it connected and worked.

Nevertheless, after a couple of reboots, I'm noticing that sometimes it won't connect on the first "click". It'll show notification "Connection established" but I won't have internet access. So I need to disconnect and retry a few times, and eventually it works.

Update: I forgot to mention - I had to set the MTU to 1452 as well.

share|improve this answer
    
Glad to see you found a workaround! Hopefully someone else will benefit from this in the future. +1 –  erjiang Nov 2 '10 at 19:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.