Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I run gnome-tweak-tool, a lot of the options are locked. In particular, I'm talking about the gnome shell theme, and the gnome shell extensions. They all have a "warning" type icon with an exclamation point next to them.

I am not logged in to a unity session or Gnome classic, just regular "Gnome"

share|improve this question
    
...and what do you mean by regular gnome? Is it Gnome 2 or 3? Is it Gnome Shell or Gnome Classic? What version of Ubuntu do you have? –  mikewhatever Jan 29 '12 at 7:46
1  
This may be a duplicate question, see the first answer here: askubuntu.com/questions/72042/… –  Tom Brossman Jan 29 '12 at 9:21
    
mikewhatever - I mean that the session I chose from the login screen was called "Gnome", not "Gnome Classic". I assume this is gnome3. –  dbb Jan 29 '12 at 19:20
    
Tom - that answer was not helpful. When I try to enable the user theme extension, the error is "Unknown extension error". Also, the screenshot you added to my question is inaccurate. The error next to the theme is "user theme extension not enabled". –  dbb Jan 29 '12 at 19:23
    
Sorry about that. Can you add the new details to your original question please? That makes it easier to follow, and increases your chances of getting a good answer. –  Tom Brossman Feb 2 '12 at 8:21
add comment

2 Answers

Gnome in the login menu is "gnome-shell" you need to have gnome-shell-extensions common and gnome-shell-user-theme installed. there are a number of ways to do this, one is to use the

https://extensions.gnome.org/

to add the different extensions for your GS version or you can add one of the ppa's that are available! such as webupd8

sudo add-apt-repository ppa:webupd8team-gnome3/oneiric

if your extensions are not loading properly then check that your extension and gnome-shell version are the same :-)

sudo gedit /usr/share/gnome-shell/extensions/user-theme@gnome-shell-extensions.gcampax.github.com/metadata.json

and look for shell version you can edit the extension version to match your own i.e. "3.2.1"

share|improve this answer
add comment

You will need to install a few extensions.

First, you need to install gnome-extensions-common and gnome-shell-user-theme. These aren't included in the default repositories.

To get them, use this code:

sudo add-apt-repository ppa:webupd8team/gnome3
sudo apt-get update
sudo apt-get install gnome-extensions-common gnome-shell-user-theme

You might also need to restart GNOME Shell. To do this, either log out and log in again or press Alt + F2, type r, and press enter. Make sure Alt + F2 is enabled in the keyboard settings.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.