Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to introduce my friend to the amazing that is GNOME Shell. So I opened a terminal and ran

sudo apt-get install gnome-shell

and all went apparently well. After restarting, on the login screen I selected the "GNOME" option from the drop-down menu. However, upon logging in, the desktop looks (and acts) exactly like Gnome Classic. From everything I have read it seems there are no other steps involved, and I have installed GNOME Shell myself on a nearly identical laptop, just one model older than my friend's (they are school-provided models). In case it's relevant, the laptop in question is the Lenovo W500.

share|improve this question
    
probably your notebook doesn't support 3d acceleration (which would be strange) also the ATI drivers are known to have issues with gnome-shell askubuntu.com/questions/76112/… which would revert to the classic session. Not very sure about that, you can check the link to make sure if the ATI drivers are related to your problem –  zurdo Jan 29 '12 at 3:48
    
I have ATI drivers (fglrx) playing nicely with the full load of stuff, but it doesn't answer why gnome-shell is failing. –  hbdgaf Jan 29 '12 at 4:48
    
Yeah. Again, I have the same system (earlier model) using essentially identical hardware and drivers and it works fine for me. –  KenB Jan 29 '12 at 5:19
    
we need some graphics details - what is the output to lspci | grep VGA as well as /usr/lib/nux/unity_support_test -p –  fossfreedom Jan 29 '12 at 10:16
add comment

1 Answer

Your friend's laptop includes a fancy new thing where it actually has two video cards: one for low power consumption when it isn't doing much and one powerful one for performance on the fancy stuff. Linux support for the switching mechanism between the two is still pretty sketchy.

For that laptop in order to get fancy accerated desktop stuff like Gnome-3 to function, you will need to be running on the faster ATI graphics card. This requires a proprietary binary driver to be installed.

If you search in the settings manager for "drivers" you should get a program (install jockey if it doesn't show up) that lets you manage proprietary drivers.

Once you get drivers installed and activated that support OpenGL acceleration, Gnome-Shell should start working. Until then, it will continue to revert to the "classic" mode.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.