Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I prevent Banshee from remembering what files I have played? I really hate the way it keeps surprising me by automatically playing, after the current track, the previous file it had played. I really HATE that. I was just listening to a beautiful piece of music and in a nice mood when Banshee, without asking me, immediately afterwards, started playing a really annoying answerphone message from earlier.

My solution so far is to manually delete all files in the playlist, but obviously that's not a long term solution. I cannot find an option anywhere that says "Do not remember my history"

(Did I mention I hate the way Banshee plays my files without asking me?)

share|improve this question
    
Are you asking how to prevent Banshee from looping through your playlist? –  Jacob Johan Edwards Jan 28 '12 at 20:16
    
This is not a playlist of mine. Banshee is just remembering what was played previously and then automatically playing those files after the file I chose to play finishes. I don't want Banshee to remember files at all. I think I'll get rid of Banshee and use VLC media player instead. –  dunderhead Jan 29 '12 at 17:52
    
I'm still not sure I understand. You're listening to a playlist with tracks A, B, C, D, E. You play track B, Banshee finishes and moves on to track C, then back to track B, is this correct? Please update your answer with the exact steps to reproduce this problem. –  michaelms Feb 7 '12 at 15:28
    
Thanks michaelms, but I've got rid of Banshee which has solved the problem! I'm now using VLC media player, which has the options I wanted but could not find in Banshee. For example: in VLC there is a checkbox with 'Save recently played items' - uncheck and it's not remembering your history. Banshee did not offer me that option. VLC also has a 'clear recent' option in the menu, which again I could not find in Banshee. So if Banshee does not have such fundamental and basic options as those then it's software that I do not want on my computer. –  dunderhead Feb 7 '12 at 17:21
    
@dunderhead Had you imported your music collection into Banshee, or were you listening to everything in the File System Queue? –  michaelms Feb 7 '12 at 18:39
show 1 more comment

3 Answers

Take a look and see where playback or smart mode is in preferences and change it or switch off smart-mode. Or check playback repeat or shuffle is off.

share|improve this answer
    
I don't have those options in my installation of Banshee (2.2.1). I've thought of a plan, though: I think I'll just remove Banshee from my system altogether! –  dunderhead Jan 29 '12 at 17:23
    
I installed banshee to check it out and i didn't have this problem, however i played around with it a bit and the default settings where pretty clear i think perhaps you should report a bug bugzilla.gnome.org/enter_bug.cgi?product=banshee –  bmbaker Jan 30 '12 at 10:52
    
try out Guayadeque esp if you have a large music collection i would recommend installing from svn as its the most uptodate version guayadeque.org/forums/index.php?p=/page/installing#InstallSVN let me know what you think :-) –  bmbaker Jan 30 '12 at 10:53
    
Thanks for the suggestions bmbaker - much appreciated! Are you saying that when you installed banshee you did have an option to turn off the autoplay? And is there an option to prevent banshee from remembering files? –  dunderhead Jan 30 '12 at 14:25
add comment

Sounds like that file ended up in your play queue from having been opened earlier. Banshee relies on its own library in your Music folder (which it assumes is all music), and while it tries, its design doesn't cope well with opening audio files outside that library. It's still a really nice application for playing music in the background, though!

If you'd like, you can keep Banshee but change this behaviour. Open System Settings, choose the Details panel and then "Default applications." Here you can set your music player to something other than Banshee. I set mine to the default Movie Player, and VLC is a fine choice as well.

Setting default applications in System Settings

Now when you open an audio file it will be played in that application you selected. When you wish to use Banshee, you can start it from the dash or the sound menu :)

share|improve this answer
    
Thanks Dylan. Yes it must have been in my play queue. One of the reasons I have tried to get away from Windows / Mac is that they take over your computer and log everything in a most unhelpful way. I was dismayed to see Ubuntu also heading in that direction, which is why I decided to get away from that too. Users should have a choice; events should not be logged if it's not needed or wanted. –  dunderhead Jul 9 '12 at 5:47
add comment

I have filed a bug on this behavior, and am determined to fix it!

https://bugzilla.gnome.org/show_bug.cgi?id=699961

share|improve this answer
    
Thanks brooksbp! But due to annoyances like this I no longer use Banshee nor Ubuntu. I've switched to Debian and VLC media player and am a lot happier. –  dunderhead May 9 '13 at 6:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.