Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install redcar by following instructions from here. I installed Jruby as it was mentioned, but when I tried to run this command:

jruby -S bundle install

I get error like this:

jruby: No such file, directory, or command -- bundle

Edit:

I tried even running :

 sudo gem install redcar

(after installing required packages), which gives a warning:

WARNING:  Invalid .gemspec format in '/var/lib/gems/1.8/specifications/redcar-0.13.gemspec'

And then proceeds like this:

Successfully installed redcar-0.13
1 gem installed
Installing ri documentation for redcar-0.13...
Installing RDoc documentation for redcar-0.13...

And got stopped!

I'm very new to Ubuntu, I don't know what this error mean.

Thanks in advance.

share|improve this question

1 Answer 1

in terminal:

cd var/lib/gems/1.8/specifications/

then

sudo vim redcar-0.13.gemspec

use down arrow key and search:

s.add_dependency(%q<cucumber>, ["#<YAML::Syck::DefaultKey:0x7f6c7dc26938> 1.1.2"])

replace with:

s.add_dependency(%q<cucumber>, [">=1.1.2"])

if u like add terminal command, then go to /usr/bin and:

sudo ln -s /var/lib/gem/1.8/bin/redcar redcar

then u can open redcar from your folder project:

cd ~/myProject
redcar .

if you get permission error like this:

1.8/gems/redcar-0.13/lib/redcar.rb:300:in `initialize': Permission denied - /home/

do it:

cd ~/
sudo chmod -R 777 .redcar/
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.