Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed Ubuntu 11.10 on my Inspiron 9100 a week ago. I have a HP Laser Jet 1100 connected to it. I can print a file from LibreOffice Write. So the printer is working. Now, the question is, How do I print a pdf file (or few pages of a pdf file)?

When I click the pdf file, some package opens the file. I can view the file, but it does not provide any option to print the file.

What am I missing? Thanks in advance.

share|improve this question
You can also install Adobe Reader for Linux right here ====> – Geppettvs D'Constanzo Jan 30 '12 at 5:06

The PDF file should be opening in the Evince document viewer. You need to hover the mouse over the top panel to reveal the menu (AKA global menu).

Global menu location

Under "File" you will find the "Print..." option. Alternatively, press Ctrl+P to access the print dialogue.

share|improve this answer
I was also going to say the good old Ctrl + P – unknown user Jun 14 at 22:55

You can use LibreOffice Draw to open, edit and print PDF files.

In Ubuntu install LibreOffice Extension for Importing PDF Files from the Software Center.

share|improve this answer
Have you tried this? I've never had this work. When I open PDFs I get dozens of pages of random strange characters. – Tom Brossman Jan 30 '12 at 5:56
For LibreOffice for Linux you need to install "LibreOffice Extension for Importing PDF Files", from the Software Center. – C.S.Cameron Jan 31 '12 at 9:50
When you go to open the PDF, use Draw, go to file, open, select the PDF you want to open, click All files, (lower right), scroll down to PDF, Click it, then hit open. (Windows version edits PDF's right out of the box, I think the Linux version defaults to viewing the code). – C.S.Cameron Jan 31 '12 at 10:05
Wow, that worked! Thanks, I learned something new today. – Tom Brossman Jan 31 '12 at 14:45

I had the same problem on 11.10. I was able to do a sudo apt-get install cups-pdf. After doing so, I was able to see/select PDF.

enter image description here

share|improve this answer
This is to print to a PDF file, Question is to print a PDF file. – squarebear Dec 18 '12 at 18:30

I opened LibreOffice Writer and then opened the .pdf document in there. Clicked Print and Voila!

share|improve this answer

Just to add to this once you print to PDF the output is located in /home/(username)/PDF folder.

share|improve this answer
This is to print to a PDF file, Question is to print a PDF file. – Galgalesh Dec 29 '13 at 16:15

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.