Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I power off my laptop with Ubuntu 11.10 during apt-get upgrade, then I power on and choose Ubuntu in grub, but after the Ubuntu logo, a blurred screen comes.

Then I choose recovery mode in grub, and then I can type commands as root,

I tried apt-get upgrade and it tells something wrong with /var/lib/dpkg/lock, and suggest dpkg --configure -a, then I tried dpkg --configure -a but comes something wrong because read-only file system, then I have no idea..

Any suggest will be helpful.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

You probably did not remount your file system as writable, there is a similar question that can help you mount it in recovery mode, please have a look

share|improve this answer

when you choose "ubuntu" in grub, is there only one? Maybe you can try an older ubuntu-version.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.