Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to mount and view the contents of a USB drive on my Ubuntu 10.10 desktop, but it doesn't mount. I have usbmount installed.

When I view /var/log/kern.log I get the following:

Oct 27 23:37:37 user kernel: [ 205.220019] usb 4-2: reset full speed USB device using uhci_hcd and address 3

Oct 27 23:37:52 user kernel: [ 220.332019] usb 4-2: device descriptor read/64, error -110

I don't know how to make it work.

share|improve this question
2  
Sounds like it might be broken... (And you don't need usbmount for this to work.) –  JanC Oct 28 '10 at 5:45

2 Answers 2

This issue is usually caused by some faulty usb device. The device that causes the problem could be any one, not just the drive that doesn't mount. So first, try to disconnect all the other usb devices and check if the drive works that way.

If nothing works, you can try this workaround. Just type this into the console.

cd /sys/bus/pci/drivers/ehci_hcd/
sudo sh -c 'find ./ -name "0000:00:*" -print| sed "s/\.\///">unbind'

Note that will make all the usb devices on your computer go to 1.1 mode: the data transfer speed will be terrible.

There is bug report about this issue, if you want to follow it.

share|improve this answer

I had the same issue some months ago. and i used this command to get rid off.

sudo rmmod uhci_hcd

and then just reconnect the usb drive

Hope this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.