Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Everytime I boot my computer, Skype starts automatically after login. The problem is two fold: * it keeps asking me to accept the licence agreement * it keeps forgetting my password

That's quite annoying. Does anyone have any idea of where the problem might be coming from? It's been like that for a while, but I can't pinpoint when it started exactly.

share|improve this question
add comment

3 Answers 3

up vote 6 down vote accepted

Skype holds its settings in a hidden folder ~/.Skype.

Possibly you have the wrong permissions or possible corruption in the files the application uses.

Try renaming this folder. Then re-add your login details and retest closing and reopening the application.

In a terminal

mv ~/.Skype ~/.Skype_backup
share|improve this answer
add comment

I was having the same problem, Skype was forcing my to re-accept EULA and was forgetting my settings e.g. whether I wanted pop-ups or not.

The EULA problem was corrected by removing the shared.xml in the .Skype folder:

$ cd ~/.Skype
$ rm shared.xml

The settings problem was corrected by removing the config.xml in my user's folder under .Skype e.g. if my user is pinocchio

$ cd ~/.Skype/pinocchio
$ rm config.xml

Restarted Skype all is well with the world again.

share|improve this answer
add comment

I had the same issue, the problem was that config.xml was owned by root.

The solution was easy :

sudo chown user:user ~/.Skype

change user to your login name (you can find it by typing :

echo $USERNAME
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.