Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've successfully managed to setup SSH server individually on 2 PCs(master and slave setup).

I can login from the slave to the master but the vice versa isn't happening.

From he individual PCs I can login to the localhost also.

Can someone help me out? I've disabled the firewalls and tried everything. Should I provide more specific details regd this?

I've installed the openssh-server on both PCs already. And I'm using the above mentioned syntax. Also, the error message I'm getting is:

ssh uname@10.5.10.251 ssh: connect to host 10.5.10.251 port 22: Connection refused

Whereas this works perfectly fine when I ssh from the slave.

On trying ssh -v I get:

OpenSSH_5.8p1 Debian-7ubuntu1, OpenSSL 1.0.0e 6 Sep 2011

debug1: Reading configuration data /etc/ssh/ssh_config

debug1: Applying options for *

debug1: Connecting to 10.5.10.251 [10.5.10.251] port 22.

debug1: connect to address 10.5.10.251 port 22: Connection refused

ssh: connect to host 10.5.10.251 port 22: Connection refused

And pinging the slave from master works fine. This means that master is able to reach slave, right? Also, I've disabled the firewall on the slave using the UI.

share|improve this question
2  
what is the error message you are getting when you can't login? –  Alexandre Jan 28 '12 at 13:21
1  
Run SSH with the -v flag and update your answer. A few things could be going wrong here, either your computer is not finding the other computer on the network, the other computer isn't running the openssh-server on port 22, or the other computer could have a firewall like ufw blocking traffic. –  Naftuli Tzvi Kay Feb 1 '12 at 6:35
add comment

1 Answer 1

If you have installed SSH servers through apt-get via $ apt-get install openssh-server on both servers, you should be able to access them both ways with their respective IP addresses.

If you have only on one PC a SSH server, and you try the other one without a SSH server, it will obviously not work.

Also be sure to respect the target machine's username you try to connect with: $ ssh username@192.168.1.245.

share|improve this answer
    
If your question isn't answered to your satisfaction, then please edit your question and be way more precise what you have done, etc. –  Marc-André Appel Jan 28 '12 at 8:42
    
Thanks all! I'd installed the openssh-server on both PCs already. And I'm using the above mentioned syntax. Also, the error message I'm getting is: ssh root@10.5.10.251 ssh: connect to host 10.5.10.251 port 22: Connection refused Whereas this works perfectly fine when I ssh from the slave. –  P Ramesh Feb 1 '12 at 5:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.