Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The Situation

I have just went through a fresh install on 32bit version of ubuntu 11.10. After the installation finished the computer rebooted and a login screen shows up. I entered my password from the installation steps and it doesn't accept it.

What I have tried

  • I reinstalled again with the same result.
  • I have entered the recovery mode by booting up my machine and holding Shift and I selected "Ubuntu, with Linux 3.0.0-12 (recovery mode)" then selecting "root Drop to root shell prompt". I then tried passwd adam (adam being my username) and entered a new password. On screen I get

    passwd: Authenication token manipulation error
    passwd: password unchanged
    

So I tried the following instructions with no luck:

Also make sure you are mounting the file system read/write.

After immediately selecting 'Drop into root shell prompt' I found the filesystem was mounted read only, which prevents resetting the password.

Choosing the option to remount / as read/write and going back into the root shell prompt enabled the password change.

And I tried the following instructions with no luck:

Check the permissions on your /etc/shadow file. They must be set to 000 or you cannot edit user password data.

Which gave me the following:

-rw-r----- 1 root shadow 1045 2012-01-28 00:13 shadow
share|improve this question

closed as too localized by Eric Carvalho, Kevin Bowen, Mateo, Basharat Sialvi, Eliah Kagan Apr 2 '13 at 2:46

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Have you tried this - ideaexcursion.com/2009/09/11/… –  zm1 Jan 28 '12 at 6:55
    
Yes I have but after selecting 'Drop into root shell prompt' to enter recovery mode I found the filesystem was mounted read only. So when I run command: sudo apt-get remove likewise-open I get the following: W: Not using locking for read only lock file /var/lib/dpkg/lock E: unable to write to /var/cache/apt E: The package lists or status file could not be parsed or opened. –  X-TraxxX Jan 28 '12 at 16:56
    
Maybe, after remounting your root fs as 'rw' you can try rm -f /var/lib/dpkg/lock and then try removal of likewise-open. –  zm1 Jan 29 '12 at 6:51
    
This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! –  Eric Carvalho Apr 1 '13 at 23:56

Browse other questions tagged or ask your own question.