Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can not use echo DIS > /sys/kernel/debug/vgaswitcheroo/switch to switch to discrete ATI card. After I run the command, cat /sys/kernel/debug/vgaswitcheroo/switch still gives:

0:IGD:+:Pwr:0000:00:02.0
1:DIS: :Pwr:0000:01:00.0

I use Ubuntu 11.10 amd64 arch in Lenovo Thinkpad W500. What is the matter?

share|improve this question
add comment

2 Answers

First, you need to run the command as root.

Second , you can not re-direct output when using sudo.

So ..

1)

sudo bash -c 'echo DIS > /sys/kernel/debug/vgaswitcheroo/switch'

2) Use tee

echo 'DIS' | sudo tee /sys/kernel/debug/vgaswitcheroo/switch
share|improve this answer
    
Of course, I do it using root user. –  waterloo2005 Jan 28 '12 at 6:37
add comment

Your change works, but it is most likely a delayed one. To make the change you should logout and re-login. This is because the change is applied after you exit X.

When Ubuntu was using Gnome desktop manager there was the gnome-session-logout command, which would do that for you. I am uncertain how to logout and re-login with Unity, which you most likely have.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.