Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The UMPC HTC Shift is about 4 years old but could anyone tell me how to install Ubuntu 11.10 on a HTC Shift? I have searched for hours for a solution and tried some manuals and how tos but nothing works.

The main problem:

  • WIFI Marvell SD8686 does not work

I tried lspci, lshw and everything shows nothing about any wlan device.

share|improve this question
    
What specifically doesn't work, the entire thing doesn't work or only wireless doesn't work? –  Jorge Castro Jan 28 '12 at 14:26
    
@thonixx You really should check out the XDA-Developers forums for something like this. Here is a thread about Ubuntu on the Shift: forum.xda-developers.com/… –  Tom Brossman Jan 29 '12 at 18:54

1 Answer 1

up vote 2 down vote accepted

You will have to decide it it is easier to get that wireless card up and working or purchase an alternate card. You can get a wireless card (usb or internal) that works with Linux for 10-20. With the price dropping, I usually purchase a new wireless.

At any rate, I have no experience with your card, but to get it working you will likely need to download the firmware and build a custom kernel.

These pages have the background information you will need:

http://labs.igep.es/index.php/How_to_setup_Marvell_88w8686_SDIO_wifi

http://wiki.laptop.org/go/Libertas

https://help.ubuntu.com/community/Kernel/Compile

The fact that these cards work with OLPC is very encouraging, not sure if the firmware alone will be sufficient or if you will need to read the third link and compile a kernel.

Wish I could give a better answer,but without experience with this card that was the best I could do for you.

Perhaps someone with experience with that card will post a detailed walk thorough.

share|improve this answer
    
I will try it in the next days. Thanks. –  Michael Tanner Jan 28 '12 at 0:44
    
Ok my conclusion: I loaded the libertas_sdio kernel module (also tried all the others) and looked for the wlan adaptor in dmesg and it showed a wlan device. But with iwconfig and ifconfig -a nothing shows up and the wlan does not work. This is driving me to hell. –  Michael Tanner Feb 24 '12 at 19:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.