Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded to oneiric. When my machine boots, I get a black console with text messages listing the services that are starting up, and then my machine sits there in that state and lightdm never comes up. I am able to log in by doing control-alt-F1, logging in, and doing a startx by hand.

I tried switching from lightdm to gdm, but that hasn't helped either.

I tried doing sudo start gdm but it tells me that gdm is already running.

The file /etc/X11/default-display-manager contains /usr/sbin/gdm.

Any suggestions on how to fix this? Thanks.

My video card is nvidia:

$ lspci | grep VGA
02:00.0 VGA compatible controller: nVidia Corporation GT216 [GeForce GT 220] (rev a2)
share|improve this question

2 Answers 2

I'm assuming you had proprietary graphics drivers installed. This would have created an xorg.conf file. If you rename it, you should be able to boot to a graphical desktop using open-source drivers. If you have previously blacklisted the open-source drivers, you will need to un-blacklist them.

To rename xorg.conf

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.backup

Oneiric is designed around lightdm - therefore reconfigure your display manager

sudo dpkg-reconfigure lightdm

/etc/X11/default-display-manager should now point to lightdm.

If you are still left with a black-screen, then the opensource nouveau graphics driver is at fault/and or KMS is at fault.

First try booting with nomodeset in your GRUB boot options.

You could also try force booting to the low resolution VESA graphics via xforcevesa or possibly xforcevesa nomodeset.

If you are unsure how to temporily add these GRUB boot options see my linked question.

If these temporary boot options still don't work - you can install the nvidia proprietary graphics driver from the command line:

sudo apt-get install nvidia-current

Linked Question:

  1. How to set nomodeset for installation?
share|improve this answer
    
Thanks for your suggestions. I have nvidia video, and I've edited the question to say so. Is lsmod the way to tell what driver I had/have? When the problem first occurred, lsmod said nvidia; I don't know if that's a proprietary driver or an OSS one. There doesn't appear to be anything video-related in /etc/modprobe.d/blacklist.conf. I renamed xorg.conf, set my display manager to be lightdm, checked that /etc/X11/default-display-manager pointed to lightdm, and rebooted. Lsmod still says nvidia. My system still behaves the same as before. –  Ben Crowell Jan 27 '12 at 23:53
    
... I've added a few more options to try. Need to know the exact model of your graphics card - please edit your question and add the output of lspci | grep VGA –  fossfreedom Jan 28 '12 at 7:06
    
Thanks for your help. I had binary-blob video drivers installed. Switching to nouveau fixed the lightdm problem, but had the mysterious side-effect of breaking ethernet. Bizarre. I did a fresh install of oneiric, and everything seems to be working fine now. Apparently the problem was something broken about the upgrade path from natty to oneiric. –  Ben Crowell Jan 29 '12 at 19:21

I came across your question after having a similar problem, and solved it a different way after a lot of frustration. /etc/lightdm/lightdm.conf was trying to use "unity-greeter" but I changed it to "lightdm-gtk-greeter". This worked for me. I hope it might help somebody.

share|improve this answer
    
.. in my case it may be relevant that my setup is Mythbuntu and I am running Xfce instead of GNOME or Unity. –  Josh May 9 '12 at 17:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.