Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a new computer with a Seagate ST500DM002 SATA internal hard drive.

I am trying to install on it Ubuntu 11.10 @ 64 bit but the installer does not recognize/detect/see the hard drive. When I reach the "Installation type" step, the panel -- which was supposed to show devices and partitions -- looks empty.

A "sudo fdisk -l" shows only /dev/sda1, the USB drive from which I am running the installation. I have already the following two solutions without any success:

  1. sudo apt-get remove dmraid
  2. switch the SATA mode in the BIOS from IDE to AHCI

I am sure it's not a hardware related problem as I have already successfully installed another operating system on the same computer.

The output of "sudo lshw -class storage -class disk" follows:

  *-ide UNCLAIMED         
       description: IDE interface
       product: ASMedia Technology Inc.
       vendor: ASMedia Technology Inc.
       physical id: 0
       bus info: pci@0000:06:00.0
       version: 01
       width: 32 bits
       clock: 33MHz
       capabilities: ide msi pm pciexpress cap_list
       configuration: latency=0
       resources: ioport:d040(size=8) ioport:d030(size=4) ioport:d020(size=8) ioport:d010(size=4) ioport:d000(size=16) memory:fe400000-fe4001ff
  *-storage
       description: SATA controller
       product: 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller
       vendor: Intel Corporation
       physical id: 1f.2
       bus info: pci@0000:00:1f.2
       logical name: scsi1
       version: 05
       width: 32 bits
       clock: 66MHz
       capabilities: storage msi pm ahci_1.0 bus_master cap_list emulated
       configuration: driver=ahci latency=0
       resources: irq:44 ioport:f0b0(size=8) ioport:f0a0(size=4) ioport:f090(size=8) ioport:f080(size=4) ioport:f060(size=32) memory:fe705000-fe7057ff
     *-cdrom
          description: DVD-RAM writer
          product: DVDRAM GH22NS70
          vendor: HL-DT-ST
          physical id: 0.0.0
          bus info: scsi@1:0.0.0
          logical name: /dev/cdrom
          logical name: /dev/cdrw
          logical name: /dev/dvd
          logical name: /dev/dvdrw
          logical name: /dev/scd0
          logical name: /dev/sr0
          version: EX00
          capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
          configuration: ansiversion=5 status=nodisc
  *-scsi:0
       physical id: 1
       bus info: usb@1:1.2
       logical name: scsi6
       capabilities: emulated scsi-host
       configuration: driver=usb-storage
     *-disk
          description: SCSI Disk
          physical id: 0.0.0
          bus info: scsi@6:0.0.0
          logical name: /dev/sda
          size: 14GiB (16GB)
          capabilities: partitioned partitioned:dos
          configuration: signature=0004e5a4
  *-scsi:1
       physical id: 2
       bus info: usb@1:1.3
       logical name: scsi7
       capabilities: emulated scsi-host
       configuration: driver=usb-storage
     *-disk
          description: SCSI Disk
          product: Storage Device
          vendor: USB Mass
          physical id: 0.0.0
          bus info: scsi@7:0.0.0
          logical name: /dev/sdb
          capabilities: removable
        *-medium
             physical id: 0
             logical name: /dev/sdb

Any idea on what I could do to fix this problem?

share|improve this question
    
What is your motherboard? Which SATA plug is it in, i.e., what color is it and where is it located? –  Huckle Jan 27 '12 at 16:45
    
@Huckle the motherboard is an ASRock H61M/U3S3. The SATA cable is black, the plug is white, named SATA3_0 and located nearby the RAM slots. –  Krige Jan 27 '12 at 17:42

3 Answers 3

I have exactly the same problem. I have the same ASRock motherboard and I tried different Linux distros without success. Finally Ubuntu 12.10 live usb booted correctly but my hard drive wasn't read.

The solution for me was to switch SATA connector: The hard disk was connected to the SATA3_0 connector and I switch it to one of the SATA2 connectors (SATA2_1 to be exact). It works now. I didn't check if Windows (which is installed in a partition of that disk) complains about this.

share|improve this answer

Some SATA ports have different controllers on the motherboard. Often times these extra ports are for eSATA, SATA3, SATA6, etc. When these ports are operating in new-ish modes then it is possible that Ubuntu wont understand how to use them. Switching SATA ports and changing the modes to the most universal often solves these types of problems.

share|improve this answer
up vote 1 down vote accepted

As workaround I went in the BIOS and set the SATA Mode to "IDE" and the SATA3 Mode to "AHCI". After doing this the installer did detect the hard drive and installed Ubuntu alongside the other operating system.

I called it a workaround and not a fix because the other operating system won't load with the SATA3 Mode set to AHCI, so every time I need to switch OS I am forced to go in the BIOS and change the SATA3 Mode.

Another problem I had after applying the workaround was that the boot loader didn't show up on the next boot but the other operating started booting without any prompt. I've fixed this other problem by identifying the Ubuntu partition with:

sudo fdisk -l

(which was sda6) and then running:

sudo mount /dev/sda6 /mnt
sudo grub-install --root-directory=/mnt/ /dev/sda
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.