Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was using ubuntu 11.10 with gnome-shell. I installed various useful softwares and ran system update using update manager which ran smoothly and asked me to restart my comp at the end. I restarted it to find that Ubuntu entries were missing from the GRUB bootloader and only memory test and windows are showing up. I took a lot of pain in installing various important softwares and cannot afford a re-installation.

Tried to boot from the live cd and installed boot-repair and after running it .. it wasnt working properly .. it was just showing that it was "scanning systems" for more than an hour.

Kindly help. Thank you ..

share|improve this question
add comment

1 Answer 1

Boot into the Ubuntu Live CD and run a few commands.

First, identify which is the Ubuntu partition:

sudo fdisk -l

Next, mount it (replacing sda2 with the appropriate partition number):

sudo mount /dev/sda2 /mnt

And finally, reinstall Grub (replacing sda with the appropriate hard drive):

sudo grub-install --root-directory=/mnt /dev/sda

Now, run this:

sudo update-grub

This should detect your Ubuntu installation and add it to the Grub menu.

share|improve this answer
    
i have tried these and here are the results .. ubuntu@ubuntu:~$ sudo fdisk -l Disk /dev/sda: 500.1 GB, 500107862016 bytes 255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors Units = sectors of 1 * 512 = 512 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disk identifier: 0x0005fa31 –  beginer Jan 28 '12 at 4:49
    
Device Boot Start End Blocks Id System /dev/sda1 * 206848 327886847 163840000 7 HPFS/NTFS/exFAT /dev/sda2 327886848 651470847 161792000 7 HPFS/NTFS/exFAT /dev/sda3 651470848 898387967 123458560 7 HPFS/NTFS/exFAT /dev/sda4 898390014 976771071 39190529 5 Extended /dev/sda5 898390016 914272255 7941120 82 Linux swap / Solaris /dev/sda6 914274304 976771071 31248384 83 Linux Disk /dev/sdb: 4009 MB, 4009754624 bytes –  beginer Jan 28 '12 at 4:53
    
ubuntu@ubuntu:~$ sudo mount /dev/sda6/mnt –  beginer Jan 28 '12 at 4:55
    
mount: can't find /dev/sda6/mnt in /etc/fstab –  beginer Jan 28 '12 at 4:56
1  
Spaces and case are very important when entering commands in the Terminal. Judging from your output, here are the exact commands you should run. Try copy/pasting, if possible. 1: sudo mount /dev/sda6 /mnt 2: sudo grub-install --root-directory=/mnt /dev/sda 3: sudo update-grub –  SirCharlo Jan 28 '12 at 14:35
show 12 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.