Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Prevent gedit from creating files with the '~' suffix

I dont know how to explain it very well so I took a picture of it.

It seems that every time I edit a Text file and save it, the sistem makes a file with the changes or whatever next to the other file. I am making a website and when I copy them through ftp it takes longer becaouse of those files, and i have to delete them one by one in the folder every time I edit them

enter image description here

share|improve this question

marked as duplicate by Rinzwind, Stefano Palazzo Jan 27 '12 at 10:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
Here you go: askubuntu.com/questions/83026/… –  Rinzwind Jan 27 '12 at 10:25

1 Answer 1

up vote 3 down vote accepted

Do you use gedit?

If so, uncheck the following settings in Edit | Preferences menu:

File Saving:

  • Create a backup copy of files before saving
  • Autosave files in every [ ] minutes

Doing so will disable these „safety features” of the editor. It might be better though to keep these enabled and run a pre-upload script to clean up the unwanted files (or filter them in your synchronization client).

share|improve this answer
    
Thankyou! It helped me a lot. Its good to know that I can do that, although I used the script solution. –  jaimehrubiks Jan 27 '12 at 10:44
    
The Script: #! /bin/bash find . -type f -name "*.*~" -exec rm -i '{}' \; Save it and give it execute permission, then run –  jaimehrubiks Jan 27 '12 at 10:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.