Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Make Network Manager restart after dropped connection?

I configured the pppoe connection in network manager it works perfectly fine when i start my computer after some couple of hours/min the network gets disconnected. When i check the network manager it says wired connection unplugged so when i restart it works fine again.

Can anybody help because I dont want to restart my pc again and again .

share|improve this question
    
does it work when you disable and enable network manager? Click the top right icon for networking (the "up and down arrows" icon), select Enable Networking to uncheck/disable it. Select Enable again to check/enable it. –  medigeek Jan 27 '12 at 10:36
    
no it does not work... i tried that too... –  Bhavesh Jogadia Jan 27 '12 at 12:41
    
(1) Need more info :) When the internet goes down, open a terminal, run these commands: pastebin.com/h1fGQmu9 - Save the output of commands in a text file on your Desktop (and the contents of dmesg.log). Restart your pc to have a working connection, open your temporary file and paste the output in a new pastebin at www.pastebin.com (2) This might sound stupid, but try it if it's a desktop: Shut down your pc and turn off your router. Unplug from power source/socket (important), leave it for about 2 minutes. Reconnect/Power up everything and boot again. –  medigeek Jan 27 '12 at 14:17
add comment

marked as duplicate by Ringtail, Uri Herrera, Eric Carvalho, hhlp, Thomas W. Jan 16 '13 at 16:20

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

Please try these two solutions. Unfortunately I don't have a mobile broadband connection to try them out.

Right-click on the NetworkManager applet in Gnome, and select Edit Connections. Highlight "System eth0" and click Edit.

Go to the IPv4 Settings tab Click the Routes button Make sure the checkbox "Use this connection only for resources on its network" is CHECKED. Click OK to save the setting.

Then make sure that the checkbox is NOT checked for "apply settings to all users", and click Apply.

Otherwise, the setting above cannot be changed by an ordinary non-root user (it won't save the changes). Unchecking this allows the setting to be changed for the logged in user and therefore everything will work.

Now, time to apply the trick.. In PPP settings tab, disable “Use Point-Point Encryption (MPPE)” as follows.

share|improve this answer
    
even I don't have a mobile connection. It's a DSL (wired) connection: a cable that plugs into a telephone type socket. There's no intervening router or modem at my end –  Bhavesh Jogadia Jan 29 '12 at 8:09
    
BTW i tried it didnt work internet completely stopped working –  Bhavesh Jogadia Jan 29 '12 at 10:13
    
plz help........................................................ –  Bhavesh Jogadia Jan 30 '12 at 19:39
    
I'd love to, but I'm out of ideas. :) Try with the live cd and leave it running. –  medigeek Jan 31 '12 at 0:26
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.