Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed the Faience theme (sudo apt-get install Faience) and it installed fine. Then I tried installing another package and it said this...

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 faience : Depends: faenza but it is not going to be installed
 gnome-shell-extensions-user-theme : Depends: gnome-shell-extensions-common but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Please help :O!

share|improve this question
2  
First off, have you tried sudo apt-get -f install as apt tells you? –  Zoke Jan 27 '12 at 2:03
    
This is most likely a problem during post-installation of a package that caused apt-get to abort. Removing the package is the only safe solution. –  pablomme Jan 27 '12 at 2:05
add comment

2 Answers

Try running sudo apt-get remove faience, or equivalently sudo apt-get remove -f. The fact that installing a package resulted in this situation is most likely a packaging problem that caused apt-get to abort during post-installation.

share|improve this answer
add comment

this is probably because faience is made from faenza try donwloading them from deviantart rather than apt-get and placing them in your home folder under .icons or .themes (depends what they are) , if you are using gnome tweak tool/gnome shell you will possibly need the user theme extension specified.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.